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Compatible with Excel 2010: 32 & 64 bit**
Menu Layout: Classical or DMAIC

Recall Last Dialog

Worksheet Manager**

Data Manipulation:

e Subset by Category, Number, Date or Random
e Stack Subgroups Across Rows

e Stack and Unstack Columns

e Standardize Data

e Random Number Generator
o Normal
o Uniform (Continuous & Integer)™*
o Lognormal**
o Weibull**
o Triangular**

e Box-Cox Transformation

Templates & Calculators:
e DMAIC & DFSS Templates

o Team/Project Charter

o SIPOC Diagram

o Flowchart Toolbar

o Data Measurement Plan

o Cause & Effect (Fishbone) Diagram and Quick Template
o Cause & Effect (XY) Matrix with Pareto**

o Failure Mode & Effects Analysis (FMEA) with RPN Sort**
o Quality Function Deployment (QFD)

o Pugh Concept Selection Matrix

o Control Plan

e Lean Templates
o Takt Time Calculator
o Value Analysis/Process Load Balance
o Value Stream Mapping**

e Graphical Templates
o Pareto Chart
o Histogram
o Run Chart

e Statistical Templates
o Sample Size — Discrete and Continuous
o 1 Sample t Confidence Interval for Mean**
o 2 Sample t-Test (Assume Equal and Unequal Variances)**
o 1 Sample Confidence Interval for Standard Deviation
o 2 Sample F-Test (Compare 2 StDevs)**
o 1 Proportion Confidence Interval (Normal and Exact)
o 2 Proportions Test & Fisher's Exact™

e Probability Distribution Calculators**

o Normal, Lognormal, Exponential, Weibull
o Binomial, Poisson, Hypergeometric

e MSA Templates
o Gage R&R Study — with Multi-Vari Analysis
o Attribute Gage R&R (Attribute Agreement Analysis)

e Process Sigma Level — Discrete and Continuous
e Process Capability & Confidence Intervals
e DOE Templates

o 2 to 5 Factors
o 2-Level Full and Fractional-Factorial designs
o Main Effects & Interaction Plots

e Control Chart Templates

o Individuals
o C-Chart

Graphical Tools:

e Basic and Advanced (Multiple) Pareto Charts

e EZ-Pivot/Pivot Charts: Easily create Pivot Tables and
Charts

e Basic Histogram

e Multiple Histograms and Descriptive Statistics
(includes Confidence Interval for Mean and StDev.,
and Anderson-Darling Normality Test)

e Multiple Histograms and Process Capability
(Pp, Ppk, Cpm, ppm, %)

e Multiple Boxplots, Dotplots

e Run Charts (with Nonparametric Runs Test allowing
you to test for Clustering, Mixtures, Lack of
Randomness, Trends and Oscillation)

e Overlay Run Chart

e Multiple Normal Probability Plots (with 95%
confidence intervals to ease interpretation of
normality/non-normality)

e Multi-Vari Charts

e Scatter Plots (with linear regression and optional 95%
confidence intervals and prediction intervals)

e Scatter Plot Matrix

Measurement Systems Analysis:
e Create Gage R&R (Crossed) Worksheet:

o Generate worksheet with user specified number of parts,
operators, replicates

e Analyze Gage R&R (Crossed)

o ANOVA, %Total, %Tolerance (with upper and/or lower
specifications), %Process, Variance Components, Number of
Distinct Categories

o Gage R&R Multi-Vari and X-bar R Charts

o Confidence Intervals for %Total, %Tolerance, %Process and
Standard Deviations

o Handles unbalanced data

e Attribute MSA (Binary)
o Any number of samples, appraisers and replicates
o Within Appraiser Agreement, Each Appraiser vs Standard
Agreement, Each Appraiser vs Standard Disagreement,
Between Appraiser Agreement, All Appraisers vs Standard
Agreement; Fleiss' kappa

Process Capability:
e Multiple Histograms and Process Capability
e Capability Combination Report for

Individuals/Subgroups:
o Histogram, Normal Probability Plot and Normality Test
o Capability Report (Cp, Cpk, Pp, Ppk, Cpm, ppm, %)
o Control Charts
e Capability Combination Report for Nonnormal Data

(Individuals)™*

o Box-Cox Transformation (includes an automatic threshold
option so that data with negative values can be transformed)

o Johnson Transformation

o Distributions supported: Half-Normal, Lognormal (2 & 3
parameter), Exponential (1 & 2), Weibull (2 & 3), Beta (2 & 4),
Gamma (2 & 3), Logistic, Loglogistic (2 & 3), Largest Extreme
Value, Smallest Extreme Value

o Automatic Best Fit based on AD p-value

o Nonnormal Process Capability Indices: Z-Score (Cp, Cpk, Pp,
Ppk) and Percentile (ISO) Method (Pp, Ppk)

e Distribution Fitting Report™*

o All valid distributions and transformations reported with
histograms, curve fit and probability plots

o Sorted by AD p-value

** New features in SigmaXL® Versions 6.0 & 6.1






























What’s New in Versions 6.0 & 6.1
New features in SigmaXL Version 6.1 include:


· Now compatible with Excel 2010 64-bit version

· Updated Cause & Effect (XY) Matrix Template with Pareto Chart option

· Updated Failure Mode & Effects Analysis (FMEA) Template with Risk Priority Number (RPN) Sort

· Updated Gage R&R Study (MSA) Template with Create Stacked Column Format for “Analyze Gage R&R” >> button


· Updated Attribute MSA Template with Create Stacked Column Format to Analyze with “Attribute MSA (Binary)” >> button


· Add Data menu options for Control Charts now include: “Add Data to this Control Chart” and “Add Data to all Control Charts”


· Capability Combination Report, Distribution Fitting and Control Charts for nonnormal data have updated dialogs with the distribution selection options displayed visually. This makes it easier to determine which distribution to select.



New features in SigmaXL Version 6.0 include:

· Powerful Excel Worksheet Manager (SigmaXL > Worksheet Manager)
· List all open Excel workbooks

· Display all worksheets and chart sheets in selected workbook

· Quickly select worksheet or chart sheet of interest


· Reorganized Templates and Calculators (SigmaXL > Templates and Calculators >):
· DMAIC & DFSS Templates

· Lean Templates

· Basic Graphical Templates

· Basic Statistical Templates

· Probability Distribution Calculators

· Basic MSA Templates

· Basic Process Capability Templates

· Basic DOE Templates

· Basic Control Chart Templates

· Templates are also available within each menu section:

· Basic Graphical Templates (SigmaXL > Graphical Tools > Basic Graphical Templates)
· Basic Statistical Templates (SigmaXL > Statistical Tools > Basic Statistical Templates)
· Basic MSA Templates (SigmaXL > Measurement Systems Analysis > Basic MSA Templates)
· Basic Process Capability Templates (SigmaXL > Process Capability > Basic Process Capability Templates)
· Basic DOE Templates (SigmaXL > Design of Experiments > Basic DOE Templates)
· Basic Control Chart Templates (SigmaXL > Control Charts > Basic Control Chart Templates)
· New Lean Template (SigmaXL > Templates and Calculators > Lean):
· Value Stream Mapping

· New Statistical Templates (SigmaXL > Templates and Calculators > Basic Statistical Templates or SigmaXL > Statistical Tools > Basic Statistical Templates):
· 1 Sample t Confidence Interval for Mean
· 2 Sample t-Test (Assume Equal Variances)
· 2 Sample t-Test (Assume Unequal Variances)
· 2 Sample F-Test (Compare 2 StDevs)

· 2 Proportions Test & Fisher’s Exact


· New Probability Distribution Calculators (SigmaXL > Templates and Calculators > Probability Distribution Calculators):
· Normal, Lognormal, Exponential, Weibull

· Binomial, Poisson, Hypergeometric


· New Random Number Generators (SigmaXL > Data Manipulation > Random Data):
· Uniform (Continuous & Integer)

· Lognormal

· Weibull, Exponential
· Triangular

· New Capability Combination Report for Nonnormal Data ( SigmaXL > Process Capability > Nonnormal > Capability Combination Report (Individuals Nonnormal) ):
· Box-Cox Transformation (includes an automatic threshold option so that data with negative values can be transformed)

· Johnson Transformation

· Distributions supported: 
· Half-Normal
· Lognormal (2 & 3 parameter)
· Exponential (1 & 2 parameter)
· Weibull (2 & 3 parameter)
· Beta (2 & 4 parameter)
· Gamma (2 & 3 parameter)
· Logistic
· Loglogistic (2 & 3 parameter)
· Largest Extreme Value
· Smallest Extreme Value

· Automatic Best Fit based on AD p-value

· Nonnormal Process Capability Indices: 
· Z-Score (Cp, Cpk, Pp, Ppk)
· Percentile (ISO) Method (Pp, Ppk)

· New Distribution Fitting Report (SigmaXL > Process Capability > Nonnormal > Distribution Fitting or SigmaXL > Control Charts > Nonnormal > Distribution Fitting):
· All valid distributions and transformations reported with histograms, curve fit and probability plots

· Sorted by AD p-value

· New Response Surface Designs (SigmaXL > Design of Experiments > Response Surface > Response Surface Designs):
· 2 to 5 Factors

· Central Composite and Box-Behnken Designs

· Easy to use design selection sorted by number of runs

· New Contour & 3D Surface Plots (SigmaXL > Design of Experiments > 2-Level Factorial/Screening > Contour/Surface Plots or SigmaXL > Design of Experiments > Response Surface > Contour/Surface Plots)

· New Control Chart features:
· Exclude data points for control limit calculation

· Add comment to data point for assignable cause

· ± 1, 2 Sigma Zone Lines

· New Control Charts for Nonnormal data (SigmaXL > Control Charts > Nonnormal > Individuals Nonnormal)

· Box-Cox and Johnson Transformations

· 16 Nonnormal distributions supported (see Capability Combination Report for Nonnormal Data)

· Individuals chart of original data with percentile based control limits

· Individuals/Moving Range chart for normalized data with optional tests for special causes

· EZ-Pivot tool has been relocated to SigmaXL > Graphical Tools > EZ-Pivot/Pivot Charts

· Attribute control charts have been relocated to SigmaXL > Control Charts > Attribute Charts.
Installation Notes 

1. This installation procedure requires that you have administrator rights to install software on your computer. Also please ensure that you have the latest Microsoft Office service pack by using Windows Update before installing SigmaXL.


2. You will be required to activate SigmaXL.  To do so, you should ensure that you are connected to the Internet.  If you do not have Internet access or have firewall restrictions, you can activate using telephone or e-mail.  Note that activation is required within 30 days of first use.  For more information on product activation, see http://www.sigmaxl.com/Activating_SigmaXL.htm or www.SigmaXL.com, click Help & Support > Product Activation FAQ Section.


3. Please uninstall any earlier (or trial) versions of SigmaXL.


4. If you are installing from a CD, the SigmaXL installer will run automatically.  If you downloaded SigmaXL, please double-click on the file [image: image1.bmp]  SigmaXL_Setup.msi .
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Statistical Tools:

e P-values turn red when results are significant
(p-value < alpha)

e Descriptive Statistics including Anderson-Darling
Normality test, Skewness and Kurtosis with p-values

e 1 Sample t-test and confidence intervals

e Paired t-test, 2 Sample t-test

e 2 Sample comparison tests:

o Reports AD Normality, F-test and Levene’s for variance, t-test
assuming equal and unequal variance, Mann-\Whitney test for
medians.

o Recommended tests are highlighted based on sample size,
normality, and variance

e One-Way ANOVA and Means Matrix
e Two-Way ANOVA (Balanced and Unbalanced)

e Equal Variance Tests (Bartlett, Levene and Welch’s
ANOVA)

e Correlation Matrix (Pearson and Spearman’s Rank
Correlation)

e Multiple Linear Regression:

o Accepts continuous and/or categorical (discrete) predictors

o Interactive Predicted Response Calculator with 95% Confidence
Interval and 95% Prediction Interval

o Residual Plots: histogram, normal probability plot, residuals vs.
time, residuals vs. predicted and residuals vs. X factors

o Residual types include Regular, Standardized, Studentized
(Deleted t) and Cook's Distance (Influence), Leverage and
DFITS

o Highlight of significant outliers in residuals

o Durbin-Watson Test for Autocorrelation in Residuals with p-
value

o ANOVA report for categorical predictors

o Pure Error and Lack-of-Fit report

o Collinearity Variance Inflation Factor (VIF) and Tolerance report

o Fit Intercept is optional

e Binary and Ordinal Logistic Regression

o Powerful and user-friendly logistic regression.

o Report includes a calculator to predict the response event
probability for a given set of input X values.

o Categorical (discrete) predictors can be included in the model in
addition to continuous predictors.

o Model summary and goodness of fit tests include Likelihood
Ratio Chi-Square, Pseudo R-Square, Pearson Residuals Chi-
Square, Deviance Residuals Chi-Square, Observed and
Predicted Outcomes — Percent Correctly Predicted.

o Stored data includes Event Probabilities, Predicted Outcome,
Observed-Predicted, Pearson Residuals, Standardized Pearson
Residuals, and Deviance Residuals.

e Chi-Square Test (Stacked Column data and Two-Way
Table data)

e Nonparametric Tests:
o 1 Sample Sign and 1 Sample Wilcoxon
o 2 Sample Mann-Whitney
o Kruskal-Wallis and Mood’s Median Test
o Kruskal-Wallis and Mood’s include a graph of Group Medians
and 95% Median Confidence Intervals
o Runs Test
e Power and Sample Size Calculators for:
o 1 and 2 Sample t-Test
o One-Way ANOVA
o 1 Proportion Test, 2 Proportions Test
o The Power and Sample Size Calculators allow you to solve for
Power (1 — Beta), Sample Size, or Difference (specify two, solve
for the third).
e Power and Sample Size Chart. Quickly create a graph
showing the relationship between Power, Sample Size
and Difference.

Design of Experiments:

e Generate 2-Level Factorial and Plackett-Burman

Screening Designs
o User-friendly dialog box
o 2to 19 Factors; 4,8,12,16,20 Runs
o Unique “view power analysis as you design”
o Randomization, Replication, Blocking and Center Points
e Basic DOE Templates
o 2 to 5 Factors, 2-Level Full and Fractional-Factorial designs
o Automatic update to Pareto of Coefficients
o Easy to use, ideal for training
e Main Effects & Interaction Plots
e Analyze 2-Level Factorial and Plackett-Burman
Screening Designs
o Used in conjunction with Recall Last Dialog, it is very easy to
iteratively remove terms from the model
o Interactive Predicted Response Calculator with 95% Confidence
Interval and 95% Prediction Interval.
o ANOVA report for Blocks, Pure Error, Lack-of-Fit and Curvature
o Collinearity Variance Inflation Factor (VIF) and Tolerance report
o Residual plots: histogram, normal probability plot, residuals vs.
time, residuals vs. predicted and residuals vs. X factors
o Highlight of significant outliers in residuals
o Durbin-Watson Test for Autocorrelation

e Contour & 3D Surface Plots**

e Response Surface Designs**
o 2 to 5 Factors
o Central Composite and Box-Behnken Designs
o Easy to use design selection sorted by number of runs

Control Charts:

e Control Chart Selection Tool

e Individuals, Individuals & Moving Range

e X-Bar & R, X-Bar & S

¢ -MR-R, I-MR-S (Between/Within)

eP, NP, C, U

e P’ and U’ (Laney) to handle overdispersion

e Control charts include a report on tests for special
causes. Special causes are also labeled on the
control chart data point. Set defaults to apply any or
all of Tests 1-8.

e Process Capability report (Pp, Ppk, Cp, Cpk) is
available for |, I-MR, X-Bar & R, X-bar & S charts.

e Add data to existing charts for operator ease of use!

e Scroll through charts with user defined window size

e Advanced Control Limit options: Subgroup Start and
End; Historical Groups (e.g. split control limits to
demonstrate before and after improvement)

e Exclude data points for control limit calculation**

e Add comment to data point for assignable cause**

e+ 1, 2 Sigma Zone Lines**

e Control charts for Nonnormal data (Individuals)**
o Box-Cox and Johnson Transformations
o 16 Nonnormal distributions supported (see Process Capability)
o Individuals chart of original data with percentile based control
limits
o Individuals/Moving Range chart for normalized data with
optional tests for special causes

Reliability/Weibull Analysis:

e Weibull Analysis
o Complete and Right Censored data
o Least Squares and Maximum Likelihood
o Output includes percentiles with confidence intervals, survival
probabilities, and Weibull probability plot.

** New features in SigmaXL® Versions 6.0 & 6.1




We recommend that you accept all defaults during the install.  Enter your User Name and Company Name.  Setup type should be Complete.  The installer will create a desktop shortcut to SigmaXL.


6. To start SigmaXL double-click on the SigmaXL desktop icon        or click Start > Programs > SigmaXL > V6 > SigmaXL.

Tip: SigmaXL can also be automatically started when you start Excel.  After starting SigmaXL, you can enable automatic start by clicking SigmaXL > Help > Automatically Load SigmaXL.  If you need to disable this feature, click Excel Tools > Add-Ins and uncheck SigmaXL, click OK (to disable in Excel 2007:  Office Button | Excel Options | Add-Ins, select Manage: Excel Add-ins, click Go… uncheck SigmaXL, click OK;Excel 2010 : File | Options… ).  This feature should be used with caution in cases where you automatically start other third-party Excel add-ins. The Excel menu may become cluttered and potential software conflicts may occur.
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The following dialog box will appear on first use of SigmaXL  (if you are using Excel 2007 or 2010 see Installation Notes for Excel 2007/2010 below):
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Check Always trust macros from this source as shown below.  SigmaXL is digitally signed by Verisign.  Users can be confident that the code has not been altered or corrupted since it was created and signed.  



















9. Click Enable Macros.  Note that the prompt to enable macros will not be given again, unless SigmaXL is removed from the list of Trusted Sources.  This list is available in Tools > Macro > Security.  Click Trusted Sources  (Excel 2007:  Office Button | Excel Options | Trust Center | Trust Center Settings | Trusted Publishers; Excel 2010: File | Options…).


10. The following dialog box will now appear:

[image: image2.png]You have 30 days left on your trial
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 [Ackivate SigmaXL_ (Enter  serial number.)
 Purchase SigmaXL
 Start SigmaX. Trial Version
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11. If you wish to evaluate SigmaXL, select Start SigmaXL Trial Version as shown.  Steps to activate SigmaXL are given below - see Activation via the Internet.  
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Click Next. The SigmaXL menu is added to Excel’s menu system as shown:
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In Excel 2007/2010, the SigmaXL Ribbon appears as shown:




Activation via the Internet:
Please proceed with the following steps if you have a valid serial number and your computer is connected to the Internet. If you do not have an Internet connection, activation can be completed by e-mail or telephone (see steps below). If you purchased SigmaXL as a download, you received the serial number by e-mail.  If you purchased a CD, the serial number is on the label of the CD. 

If your trial has timed out and you do not have a serial number but wish to purchase a SigmaXL license, please click Purchase SigmaXL in the Activation Wizard Box and this will take you to SigmaXL’s order page http://www.sigmaxl.com/Order%20SigmaXL.htm.  You can also call 1-888-SigmaXL (1-888-744-6295) or 1-416-236-5877 to place an order. 


1. In the Activation Wizard box select Activate SigmaXL (Enter a serial number).
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2. Click Next.  Enter your serial number as shown below. If you received the serial number by e-mail, simply copy and paste from the e-mail. Note that the serial number GGGGG-RRRRR-TTTTT-GGGGG-RRRRR-TTTTT-0 is given as an example – it will not activate your copy of SigmaXL.

[image: image5.png]SigmaXL Activation Wizard (Exh

Welcome to the SigmaXt. Activation Wizard.
igmi
o “This wizard will connect to the internet and
contact our server. Enter your Serial Number
below and click Nlext to continue.

'GGGGG-RRRRR TTTTT-GGGGG-RRRRRTTTTT-0

Activation Help |  Cancel Next







3. Click Next. The activation process continues and is confirmed as shown:
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Click Finish.  The SigmaXL menu is added to Excel’s menu system as shown:

















Error Messages:
1. Incorrect Serial Number:

[image: image7.png][ e 4 [P —

You have entered an invalid serial number. Please very your serial number and
try again.

o






This is due to an incorrect serial number entry in the previous registration process – please re-enter your serial number.


2. Serial Number Used in Previous Activation:
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The serial number has been used in a previous activation.  If you are installing SigmaXL on a new computer, you will need to uninstall SigmaXL from your old computer while connected to the Internet. This will deactivate the license on your old computer.


3. Internet Connection Problem:
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If you do not have an Internet connection, please activate by e-mail or telephone.

Activation via E-Mail or Telephone:

If you have a serial number and wish to activate SigmaXL, but do not have internet access or have firewall restrictions that prohibit the above automated process, you can submit an Activation Request Code via e-mail or telephone.  You will receive an Activation Response Code to enter in order to activate SigmaXL.

1. After entering your serial number, click Next. An attempt will be made to activate via the internet. If this fails, the following dialog appears:
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Click OK


2. Select Activate by Email as shown. Click Next. 
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3. An email is created containing your serial number and request code.  This email is automatically sent to productactivations@sigmaxl.com using your email program.  You will receive a reply e-mail with the Activation Response Code.  Copy and paste the Activation Response Code into the dialog box shown below and click Finish to activate.
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4. To activate by phone, select Activate by Phone as shown:
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5. Click Next.
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6. Call SigmaXL at 1-888-SigmaXL (1-888-744-6295) or 1-416-236-5877 to provide your Activation Request Code. You will verbally receive the Activation Response Code which is then entered into the above dialog box. Click Finish to activate.

Installation Notes for Excel 2007/2010
1. The previous installation notes apply to Excel 2007/2010 as well, but there are differences in the security warning and menu access. 
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After starting SigmaXL for the first time (double-click on the SigmaXL desktop icon, or click Start > Programs > SigmaXL > V6 > SigmaXL), the following security warning dialog is given:
















3. Click Trust all from publisher.  This will then start the activation process as documented above.


4. In order to access the SigmaXL menu, click SigmaXL.  The SigmaXL Ribbon appears as shown:
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5. [image: image27.png]


If SigmaXL’s Ribbon is not available:
You may need to specify SigmaXL’s folder as a trusted location (these steps are not necessary if you see the SigmaXL Ribbon):

· [image: image28.png]


Click the Office Button:              (Excel 2010: File)


· [image: image29.png]Trust Center



Select Excel Options:                              (Excel 2010: Options)


· [image: image30.png]Trust Center Settings.



Select Trust Center: 
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Click Trust Center Settings: 


· [image: image32.png]Add new loation.



Select Trusted Locations: 


· Click Add New Location: 

· [image: image33.png]Microsoft Office Trusted Location,

‘Warning: This locaton wil be treated a5 a rusted source for opering fies. Ifyou
‘change or add 3 location, make sure that the new location i secure.
Pa

- Program Fies\SignaxL V6

Subfeiders of B location are aso usted)
Desaription:

Date and Time Created:  7/8/2009 1014 AM




Specify the folder location for SigmaXL.xla.  The default location is C:\Program Files\SigmaXL\V6.  Check Subfolders of this location are also trusted as shown:














· Click OK.  Click OK.
SigmaXL® Defaults and Menu Options
Clear Saved Defaults
Clear Saved Defaults will reset all saved defaults such as Pareto and Multi-Vari Chart settings, saved control limits, and dialog box settings.  All settings are restored to the original installation defaults.
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Click SigmaXL > Help > SigmaXL Defaults > Clear Saved Defaults.  A warning message is given prior to clearing saved defaults.





Data Selection Default
The Data Selection Default setting is:  Prompt me to select my data range and/or ‘Use Data Labels’.

This can be changed to:  Always use my pre-selected data range without prompting.  ‘Data Labels’ will be used.  This setting saves you from having to click Next at the start of every function, but the user is responsible to ensure that the proper data selection is made prior to starting any menu item.
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Click SigmaXL > Help > SigmaXL Defaults > Data Selection Default to make this change.  This will apply permanently unless you revert back to the Prompt me setting or click Clear Saved Defaults shown above.






Menu Options (Classical or DMAIC)
The default SigmaXL menu system groups tools by category, but this can be changed to the Six Sigma DMAIC format.
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Click SigmaXL > Help > SigmaXL Defaults > Menu Options – Set SigmaXL’s Menu to Classical or  DMAIC.  The Set Menu dialog allows you to choose between Classical (default) and DMAIC:







If you select the DMAIC format, the SigmaXL menu layout will be as shown:
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In Excel 2007/2010, the DMAIC Menu Ribbon appears as shown:






All SigmaXL tools are available with this menu format, but they are categorized using the Six Sigma DMAIC phase format.  Note that some tools will appear in more than one phase.

This workbook uses the classical (default) menu format, but the chapters are organized as Measure, Analyze, Improve and Control.
SigmaXL® System Requirements
 

Minimum System Requirements:

Computer and processor:  500 megahertz (MHz) processor or higher.
Memory:  512 megabytes (MB) of RAM or greater.
Hard disk:  70 MB of available hard-disk space.
Drive:  CD-ROM or DVD drive.
Display:  1024x768 or higher resolution monitor.
Operating system:  Microsoft Windows XP with Service Pack (SP) 2, or later operating system.
Microsoft Excel version:  Excel XP, Excel 2003, Excel 2007, or Excel 2010 with latest service packs installed.
Getting Help and Product Registration


To access the help system, please click SigmaXL > Help > Help.  

Technical support is available by phone at 1-866-475-2124 (toll-free in North America) or 1-416-236-5877 or e-mail support@sigmaxl.com.

Please note that registered users obtain free technical support and upgrades for one year from date of purchase.  Optional maintenance is available for purchase prior to the anniversary date.

To register by web, simply click SigmaXL > Help > Register SigmaXL.
Introduction to SigmaXL® 
Data Format and Tools Summary
Introduction

SigmaXL is a powerful but easy to use Excel Add-In that will enable you to Measure, Analyze, Improve and Control your service, transactional, and manufacturing processes.  This is the ideal cost effective tool for Six Sigma Green Belts and Black Belts, Quality and Business Professionals, Engineers, and Managers.

SigmaXL will help you in your problem solving and process improvement efforts by enabling you to easily slice and dice your data, quickly separating the “vital few” factors from the “trivial many”.  This tool will also help you to identify and validate root causes and sources of variation, which then helps to ensure that you develop permanent corrective actions and/or improvements.

The Y=f(X) Model 
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SigmaXL utilizes the “Y=f(X)” model in its dialog boxes.  Y denotes a key process output metric; X denotes a key process input metric.  This process is shown pictorially as:





















The mathematical expression Y = f(X) denotes that the variable Y is a function of X.  Y can also be viewed as the effect of interest and X is the cause.  For example, Y could be customer satisfaction as measured on a survey and X could be location or responsiveness to calls (also measured on a survey).  The goal is to figure out which X’s from among many possible are the key X’s and to what extent do they impact the Y’s of interest.  Solutions and improvements then focus on those key X’s.

Data Types: Continuous Versus Discrete


X and Y metrics can each be continuous or discrete.  A continuous measure will have readings on a continuous scale where a mid-point has meaning.  For example, in a customer satisfaction survey using a 1 to 5 score, the value 3.5 has meaning.  Other examples of continuous measures include cycle time, thickness, and weight.  A discrete measure is categorical in nature.  If we have Customer Types 1, 2, and 3, customer type 1.5 has no meaning.  Other examples of discrete measures include defect counts and number of customer complaints.

It is possible to have various combinations of discrete/continuous X’s and discrete/continuous Y’s.   Some examples are given below:

Examples of Discrete (Category) X and Discrete Y

· X = Customer Type, Y = Number of Complaints


· X = Product Type, Y = Number of Defects


· X = Day Shift vs. Night Shift, Y = Proportion of Defective Units

Examples of Discrete (Category) X and Continuous Y

· X = Customer Type, Y = Customer Satisfaction (1-5)


· X = Before Improvement vs. After Improvement, Y = Customer Satisfaction (1-5)


· X = Location, Y = Order to Delivery Time

Examples of Continuous X and Discrete Y

· X = Responsiveness to Calls (1-5), Y = Number of Complaints

· X = Process Temperature, Y = Number of Defects

Examples of Continuous X and Continuous Y

· X = Responsiveness to Calls (1-5), Y = Customer Satisfaction (1-5)

· X = Amount of Loan ($), Y = Cycle Time (Loan Application to Approval)

Note that in SigmaXL, a discrete X can be text or numeric, but a continuous X must be numeric.  Y’s must be numeric.  If Y is discrete, count data will be required.  If the data of interest is discrete text, it should be referenced as X1 and SigmaXL will automatically search through the text data to obtain a count (applicable for Pareto, Chi-Square and EZ-Pivot tools).

Stacked Data Column Format versus Unstacked Multiple Column Format

SigmaXL can accommodate two data formats:  stacked column and unstacked multiple column.  The stacked column format has an X column also referred to as the “Group Category” column and a Y column that contains the data of interest.  The following is an example of data in stacked column format, with three unique groups of Customer Type:
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If the data is in unstacked multiple column format, each unique group of X corresponds to a different column.  The above data is now shown in unstacked format with customer satisfaction scores for each customer type in separate columns:











[image: image42.emf]Tool  What  Type of Data  When to Use  Location in  SigmaXL   Pareto Chart  Plots a bar chart of the response  in  descending order with a cumulative  sum line.  Y=Discrete  (e.g.,  Defect Count) or  Continuous (e.g., Cost;  must be additive)   X=Discrete   (Category)  To sep arate the vital few from the trivial  many,  help  specify  a  problem statement, and  prioritize potential root causes.  This chart is  based on the Pareto principle, which states  that typically 80% of the defects in a process  or product are caused by only 20% of  the  possible causes .  SigmaXL > Templates & Calculators >  Basic Graphical Templates > Pareto Chart     SigmaXL > Graphical Tools > Basic Pareto  Chart (Single)     SigmaXL > Graphical Tools > Advanced  Pareto Charts (Multiple)   Pivot Chart  Plots a stacked (or clus tered) bar  chart from an Excel Pivot Table .  Y=Discrete or  Continuous   X = Discrete  (Category)  To easily ‘slice and dice’  your data, quickly  look at different X factors and their  contribution to the total.  It is similar to the  Pareto Chart, but without the  descending bar  order.   SigmaXL  > Graphical Tools > EZ - Pivot/Pivot Charts   Histogram  Visual display of one variable  showing data center, spread, shape  and outliers.  Y= Continuous   X=Discrete  (Category)  1.   Summarize large amounts of data   2.   To get a ‘feel for the da ta’   3.   To compare actual description to  customer spec ifications  SigmaXL > Templates & Calculators >  Basic Graphical Templates > Histogram     SigmaXL > Graphical Tools > Basic  Histogram (Single)     SigmaXL  >  Graphical Tools  > Histograms   & Descriptive Statistics     S igmaXL  >  Graphical Tools > Histograms  & Process Capability   Dotplots  Visual display of one variable  showing data center, spread, shape  and outliers.  Y=Continuous   X=Discrete  (Category)  1.   Small sample size (n < 30)   2.   To get a ‘feel for the data’  SigmaXL > Graphi cal Tools > Dotplots   Boxplots  Visual display of the summary of Y  data grouped by category of X.  Y=Continuous   X=Discrete   (Category)  Summary display to visualize differences in  data center, spread and outliers across  categories.  SigmaXL > Graphical Tools >  Boxplots   Normal  Probability Plot  Plots data in a straight line if the  data is normally distributed.  Y=Continuous   X=Discrete  (Category)  To check for Normality and Outliers.  SigmaXL > Graphical Tools > Normal  Probability Plots   Run Charts  Plots observations  in time sequence  Y=Continuous or  Discrete  To view process performance over time for  trends, shifts or cycles.     To test for Randomness using the   Nonparametric Runs Test  SigmaXL > Templates & Calculators >  Basic Graphical Templates >  Run Chart   SigmaX L > Gr aphical Tools > Run Chart   SigmaXL > Graphical Tools > Overlay Run  Chart   Multi - Vari Charts  Plots vertical lines with dots to allow   comparison of sub groups on one  variable.  Y=Continuous   X=Discrete   (Category)  To visually compare sub groups by individual  data  points and the mean.     To identify major sources of variation  (e.g.,  within a subgroup, between subgroups, or  over time ).  SigmaXL > Graphical Tools > Multi - Vari  Charts   Scatter Plot  (Diagram)  Plots a response Y versus a  predictor X.  Y=Continuous   X=Continuo us  To understand the possible relationships  between two variables.     To identify possible root causes which are  related to Y .  SigmaXL > Graphical Tools > Scatter Plot     SigmaXL > Graphical Tools > Scatter Plot  Matrix   Control Charts  Plots observations in tim e sequence  against a mean and control limits.  Y=Continuous or  Discrete  To monitor the process over time for trends,  shifts or cycles in order to  control and  improve process performance.     To identify special causes.  SigmaXL > Control Charts >   

 Summary of Graphical Tools
[image: image43.emf]Tool   What   Type of Data   When to Use   Location in SigmaXL   t - Test   Determine if there is a  significant  difference  between two group means or if the  true  mean of the data is equal to a standard  value.   Y=Continuous   X=Discrete  (Category)   1.   Test if  mean = specified  value   2.   Test if 2 sample means are equal   3.   Paired t:  to reduce variation when  comparing two sample means   4.   Multiple pairwise comparisons   SigmaXL > Templates & Calculators >  Basic Statistical Templates >   1  Sample t Confidence Interval   2 Sample t Test (Equal Vari ance)   2 Sample t Test (Unequal Variance)     SigmaXL > Statistical Tools >   1 Sample t - Test & Confidence Intervals   2 Sample t - Test   Paired t - Test   One - Way ANOVA & Means Matrix   One - Way  ANOVA (Analysis  of Variance)   Determine if there is a difference in mean  among  many groups.   Y=Continuous   X=Discrete  (Category)   Determine if there is a statistically significant  difference in means among the groups.   SigmaXL > Statistical Tools > One - Way ANOVA & Means Matrix   Nonparametric  Tests   Determine if there is a difference betw een  two or more group medians or if the median  of the data is equal to a standard value.   Y=Continuous   X=Discrete  (Category)   1.   Test if  median = specified value:    1 Sample Sign Test or Wilcoxon   2.   Test if 2 sample medians are equal:    2 Sample Mann - Whitney   3.   Test i f there is a difference in medians  among the groups:    Kruskal - Wallis or Mood’s Median   SigmaXL > Statistical Tools >  Nonparametric Tests   F - test /   Bartlett’s Test/  Levene’s Test     Determine if there is a difference between  two or more group variances.   Y=Cont inuous   X=Discrete  (Category)   1.   Test if 2 sample variances (standard  deviations) are equal.   2.   Determine if there is a statistically significant  difference for the variances among the  groups. Use Bartlett’s test for normal data.  Use Levene’s test  for non - normal  data.   SigmaXL > Templates & Calculators >  Basic Statistical Templates >   2 Sample F - Test ( Compare 2 StDevs)     SigmaXL > Statistical Tools > Two  Sample Comparison Tests     SigmaXL > Statistical Tools > Equal  Variance Tests >   Bartlett   Levene   Proportions Test   D etermine if there is a difference between  two proportions or  determine the confidence  interval of a single  proportion .   Y=Discrete   X=Discrete  (Category)   1.   Determine the confidence interval for a  single proportion.   2.   Determine if there is a statistically signifi cant  difference for two proportions.   SigmaXL > Templates & Calculators >  Basic Statistical Templates >   1 Proportion Confidence Interval    2 Proportions Test  & Fisher’s Exact   Χ 2   Chi Square   Determine if there is a difference for  observed frequencies of 2 discrete variables.   Y=Discrete   X=Discrete   Determine if there is a relationship between two  discrete variables.   SigmaXL > Statistical Tools >    Chi - Square   Chi - Square  -   Two - Way Ta ble Data   Anderson - Darling  Normality Test   Determine if the data is normally distributed.   Y=Continuous   Test if the sample data is normally distributed.   SigmaXL > Graphical Tools >  Histograms & Descriptive Statistics     SigmaXL > Statistical Tools >  Descriptiv e Statistics   Correlation   Quantify strength of relationships.   Y=Continuous   X=Continuous   Determine if there is evidence of a relationship  between Xs and Ys, quantify the relationship,  identify root causes.   SigmaXL > Statistical Tools >  Correlation Matrix   R egression  (Simple Linear &  Multiple)   Summarizes, describes, predicts and  quantifies relationships.   Y=Continuous   X=Continuous   1.   Determine if there is evidence of a  relationship between Xs and Ys.   2.   Model data to develop a mathematical  equation to quantify the r elationship.   3.   Identify root causes.   4.   Make predictions using the model.   SigmaXL > Statistical Tools >  Regression > Multiple Regression   Logistic  Regression   Summarizes, describes, predicts and  quantifies relationships.   Y=Discrete (Binary or Ordinal)   X=Continuo us   1.   Determine if there is evidence of a  relationship between Xs and Ys.   2.   Model data to develop a mathematical  equation to quantify the relationship.   3.   Identify root causes.   4.   Make predictions using the model.   SigmaXL > Statistical Tools >  Regression >    Binary Lo gistic Regression   Ordinal Logistic Regression   Design of  Experiments  (DOE)   Systematic and efficient proactive approach  to testing relationships.   Y=Continuous or Discrete   X=Continuous or Discrete   To establish cause and effect relationship  between Ys and Xs.  To identify ‘vital few’ Xs.   SigmaXL > Design of Experiments      

 Summary of Statistical Tools

SigmaXL: Measure Phase Tools 

Part A - Basic Data Manipulation 

Introduction to Basic Data Manipulation
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Open Customer Data.xls (to access, click SigmaXL > Help > Open Help Data Set Folder or Start > Programs > SigmaXL > Sample Data).  This data is in stacked column format.  This format is highly recommended for use with SigmaXL.  Note that all pertinent information is provided in each record (row).  Also note that only one row is used for column headings (labels) and there are no blank rows or columns.  Each column contains a consistent format of either numeric, text, or date.  This is also the data format used by other major statistical software packages.


Note that Loyalty, Overall Satisfaction, Responsive to Calls, Ease of Communications, and Staff Knowledge were obtained from surveys.  A Likert scale of 1 to 5 was used, with 1 being very dissatisfied, and 5 very satisfied.  Survey results were averaged to obtain non-integer results.

Category Subset
1. Click SigmaXL > Data Manipulation > Category Subset.
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If you are working with a portion of a dataset, specify the appropriate range, otherwise check  Use Entire Data Table.










3. Click Next.

4. Select Customer Type, 1, >> as shown:
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5. Click OK.
A new subset worksheet is created containing only Customer Type 1.
Note:  We could have chosen more than one Customer Type and had the option to create a subset which included or excluded these Customer Types.

Random Subset
1. Click Sheet 1 Tab of Customer Data.xls. 
2. Click SigmaXL > Data Manipulation > Random Subset.
3. Ensure that the entire data table is selected.  If not, check Use Entire Data Table.           Click Next.
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Enter Number of Rows in Random Subset as 30.  The default Sort Data selection is Original Order.








5. Click OK.  A new worksheet is created that contains a random subset of 30 rows.   
This feature is useful for data collection to ensure a random sample, e.g., given a list of transaction numbers select a random sample of 30 transactions.
Numerical Subset
1. Click Sheet 1 Tab of Customer Data.xls.
2. Click SigmaXL > Data Manipulation > Numerical Subset.
3. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, >=, Enter Value as 4. 


5. Click OK.
A new subset worksheet is created containing only those rows with Overall Satisfaction >= 4.

Date Subset
1. Click Sheet 1 Tab of Customer Data.xls.
2. Click SigmaXL > Data Manipulation > Date Subset.
3. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Order Date, select 1/9/2001, click Start Date, select 1/12/2001, click End Date.









5. Click OK.  A new subset worksheet is created containing only those rows with Order Date between 1/9/2001 to 1/12/2001.


Transpose Data
1. Open Catapult Data Row Format.xls.
2. Manually select the entire data table.
3. Click SigmaXL > Data Manipulation > Transpose Data.
4. This will transpose rows to columns or columns to rows.  It is equivalent to Copy, Paste Special, Transpose.

Stack Subgroups Across Rows
5. Now we will stack the subgroups across rows for the transposed data.  Ensure that the Transposed Data Sheet of Catapult Data Row Format.xls is active.
6. Click SigmaXL > Data Manipulation > Stack Subgroups Across Rows.
7. Check Use Entire Data Table, click Next.
8. Click on Shot 1.  Shift Click on Shot 3 to highlight the three columns of interest.
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Click Numeric Data Variables (Y) >> to select Shot 1 to Shot 3.  Enter Distance as the Stacked Data (Y) Column Heading and Shot No as the Category (X) Column Heading. Select Operator, click Additional Category Columns (X) >>:










Note that any selected column may be removed by highlighting and double-clicking or clicking the Remove button. 

10. [image: image52.png]Operator Shot No Distance

John
John
John
Moe
Moe
Mo
Sally
Sally
Sally
Sue
Sue
Sue
David
David
David

Shot 1
Shot 2
Shot 3
Shot 1
Shot 2
Shot 3
Shot 1
Shot 2
Shot 3
Shot 1
Shot 2
Shot 3
Shot 1
Shot 2
Shot 3

105
104
9
105
9
91
%
9%
9
102
105
103
100
9%
100



Click OK.  The resulting stacked data is shown:










Stack Columns
1. Open Customer Satisfaction Unstacked.xls. 

2. Click SigmaXL > Data Manipulation > Stack Columns.
3. Check Use Entire Data Table, click Next.
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Shift Click on Overall Satisfaction_3 to highlight all three column names.  Click Select Columns >>.  Enter the Stacked Data (Y) Column Name as Overall Satisfaction.  Enter the Category (X) Column Name as Customer Type.
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Click OK.  Shown is the resulting stacked column format: 













6. Data that is in stacked column format can be unstacked using Data Manipulation > Unstack Columns.

Random Data
The normal random data generator is used to produce normal random data.  Column headings are automatically created with Mean and Standard Deviation values (e.g. 1: Mean = 0; Stdev = 1).  This utility works with Recall SigmaXL Dialog (F3) to append columns to the current Normal Random Data worksheet.  An example is shown in Measure Phase Tools, Part G – Normal Probability Plots.
Additional random number generators include Uniform (Continuous & Integer), Lognormal, Exponential, Weibull and Triangular. The column headings show the specified parameter values.
Box-Cox Transformation

This tool is used to convert non-normal data to normal by applying a power transformation.  Examples of use are given in Measure Phase Tools, Part J – Process Capability for Non-Normal Data and Control Phase Tools, Part A – Individuals Charts for Non-Normal Data.
Standardize Data

This tool is used to Standardize ((Yi – Mean)/StDev) or Code (Ymax = +1, Ymin = -1) your data.  This is particularly useful when performing Multiple Regression.  Standardized Predictors have better statistical properties.  For example, the importance of model coefficients can be determined by the relative size because units are removed.  Another statistical benefit is reduced multicollinearity when investigating two-factor interactions.

1. Click Sheet 1 Tab of Customer Data.xls.
2. Click SigmaXL > Data Manipulation > Standardize Data.

3. Ensure that the entire data table is selected.  If not, check Use Entire Data Table.           Click Next.
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Select Responsive to Calls and Ease of Communications and click Numeric (Y) Columns to Standardize >>.
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Click OK.  The results are given on the Standardize sheet: 






Data Preparation – Remove Blank Rows and Columns
This data preparation utility is provided as a convenient way to prepare data for analysis by deleting any empty rows and/or columns.

1. Open Customer Data.xls.  Click Sheet 1 Tab.

2. Insert a new column in B; Click Column B heading, click Insert > Columns.
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Insert a new row in row 2.  Click Row 2 label, click Insert > Rows as shown:










4. This is now an example of a data set that requires deletion of empty rows and columns. Click SigmaXL >Data Manipulation >Data Preparation >Remove Blank Rows and Columns.
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Check Delete Empty Rows and Delete Empty Columns.







6. [image: image59.png]


Click OK.  A warning message is given prior to the deletion step.
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Click Yes.  The empty rows and columns are deleted automatically.










Data Preparation – Change Text Data Format to Numeric

This Data Preparation utility will convert data that represents numeric values but are currently in text format.  This sometimes occurs when importing data into Excel from another application or text file.
Recall SigmaXL Dialog
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Recall SigmaXL Dialog is used to activate the last data worksheet and recall the last dialog, making it very easy to do repetitive analysis.  To access, click the top level menu Recall SigmaXL Dialog located to the right of the SigmaXL menu: 


Alternatively, you can use the Hot Key F3.  This feature can also be accessed by clicking SigmaXL > Help > Hot Keys > Recall SigmaXL Dialog.

In Excel 2007/2010, the Recall SigmaXL Dialog menu button appears as:




Note that Recall SigmaXL Dialog may not be available for all functions.
Activate Last Worksheet

Activate Last Worksheet is used to activate the last data worksheet without recalling the dialog. To access, press hot key F4.  This feature can also be accessed by clicking SigmaXL > Help > Hot Keys > Activate Last Sheet.
Worksheet Manager
The Worksheet Manager is a powerful utility that allows you to list all open Excel workbooks, display all worksheets and chart sheets in a selected workbook and quickly select a worksheet or chart sheet of interest. To access, click SigmaXL > Worksheet Manager.
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Part B – Templates & Calculators 

Introduction to Templates & Calculators
To use SigmaXL templates, select the appropriate template, enter the inputs and the resulting outputs are produced immediately.  If the template does not automatically perform the calculations, click Tools > Options, select Calculation, Automatic, and click OK (Excel 2007: Office Button | Excel Options | Formulas, select Automatic, click OK; Excel 2010: File | Options…).  Templates and Calculators are protected worksheets by default, but this may be modified by clicking SigmaXL > Help > Unprotect Worksheet. Alternatively, you can click Excel Tools > Protection > Unprotect Sheet (Excel 2007/2010: Review | Changes | Unprotect Sheet).  Gage R&R is password protected, so it cannot be unprotected.
Click SigmaXL > Templates & Calculators to access the templates and calculators. Basic Graphical Templates can also be accessed by clicking SigmaXL > Graphical Tools > Basic Graphical Templates. Basic Statistical Templates can be accessed by clicking SigmaXL > Statistical Tools > Basic Statistical Templates. Basic MSA Templates can be accessed by clicking SigmaXL > Measurement Systems Analysis > Basic MSA Templates. Basic Process Capability Templates can be accessed by clicking SigmaXL > Process Capability > Basic Process Capability Templates. Basic DOE Templates can also be accessed by clicking SigmaXL > Design of Experiments > Basic DOE Templates. Basic Control Chart Templates can also be accessed by clicking SigmaXL > Control Charts > Basic Control Chart Templates.













	SigmaXL Templates & Calculators

	· DMAIC & DFSS Templates:

· Team/Project Charter

· SIPOC Diagram

· Flowchart Toolbar

· Data Measurement Plan

· Cause & Effect (Fishbone) Diagram and Quick Template

· Cause & Effect (XY) Matrix

· Failure Mode & Effects Analysis (FMEA)

· Quality Function Deployment (QFD)

· Pugh Concept Selection Matrix

· Control Plan


· Lean Templates:

· Takt Time Calculator

· Value Analysis/Process Load Balance

· Value Stream Mapping


· Basic Graphical Templates:

· Pareto Chart

· Histogram

· Run Chart

· Basic Statistical Templates:

· Sample Size – Discrete and Continuous

· 1 Sample t Confidence Interval for Mean**

· 2 Sample t-Test (Assume Equal and Unequal Variances)
· 1 Sample Confidence Interval for Standard Deviation

· 2 Sample F-Test (Compare 2 StDevs)

· 1 Proportion Confidence Interval (Normal and Exact)

· 2 Proportions Test & Fisher’s Exact


· Probability Distribution Calculators:

· Normal, Inverse Normal, Lognormal, Exponential, Weibull

· Binomial, Poisson, Hypergeometric


· Basic MSA Templates:

· Gage R&R Study – with Multi-Vari Analysis

· Attribute Gage R&R (Attribute Agreement Analysis)


· •Basic Process Capability Templates:

· Process Sigma Level – Discrete and Continuous

· Process Capability & Confidence Intervals


· Basic DOE Templates:

· 2 to 5 Factors

· Main Effects & Interaction Plots


· Basic Control Chart Templates:

· Individuals
· C-Chart




Team/Project Charter
Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > Team/Project Charter to access the Team/Project Charter template.
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SIPOC Diagram
Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > SIPOC Diagram to access the SIPOC Diagram template.
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Data Measurement Plan
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Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > Data Measurement Plan to access the Data Measurement Plan template.









Cause & Effect (Fishbone) Diagram
Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates  > Cause & Effect (Fishbone) Diagram to access the Cause & Effect Diagram form.
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Notes:

1. Overwrite the text in the Cause, Sub-Cause and Problem Statement/Effect as appropriate.

2. Use copy and paste to create additional causes or sub-causes.

3. The arrows with text are grouped. To ungroup use Excel's Draw > Ungroup tool.








Cause & Effect (Fishbone) Template
Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates  > Cause & Effect (Fishbone) Template to access the Cause & Effect Diagram template.
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Simply fill in the template table and click the Fishbone Diagram button to create the diagram.

Cause & Effect (XY) Matrix Example

Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates  > Cause & Effect (XY) Matrix to access the Cause & Effect (XY) Matrix template.

The following example is given in the file Template & Calculator Examples.xls.  Click on the worksheet named C&E Matrix.  This is a simple Cause and Effect Matrix example for a Call Center.  If prompted, please ensure that macros are enabled in order to allow Pareto Charts to be created.
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Notes for use of the Cause and Effect Matrix template, also known as the XY Matrix:

1. Weight the Output Variables (Y's) on a scale of 1 to 10 with 10 indicating most important to the Customer.

2. For Root Cause Analysis, assign the association/effect multiplier score for each X to Y using a scale of 0, 1, 3, 9, where 0 = None, 1 = Weak, 3 = Moderate, and 9 = Strong.  Initially this assignment will likely be a team subjective assessment. Data should be collected and the degree of association should be validated with Graphical and Statistical Tools.
3. For Project Selection or Solution Selection, assign the association multiplier score for each X to Y using a scale of 1 to 10, with 10 indicating strong association. 
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Failure Mode & Effects Analysis (FMEA) Example

Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > Failure Mode & Effects Analysis (FMEA) template.

 The following example is given in the file Template & Calculator Examples.xls.  Click on the worksheet named FMEA.  This is a simple Failure Mode and Effects example for Stocking Inventory.  If prompted, please ensure that macros are enabled in order to allow sort by RPN.
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If you hover the mouse cursor over the Severity, Occurrence or Detection heading the recommended scale will appear as a comment:
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The recommended scales for Severity, Occurrence, and Detection are shown below:





















Click Risk Priority Number (RPN) Sort to sort the rows by RPN in descending order.



Click Revised Risk Priority Number Sort to sort the rows by Revised RPN in descending order.



Click Row Number Sort to restore the FMEA worksheet to the original row order (ascending).





Quality Function Deployment (QFD) Example
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Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > Quality Function Deployment (QFD) > 10 by 10 QFD (or 20 by 20, 30 by 30) to access the Quality Function Deployment (QFD) template. Enter data as shown.
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Pugh Concept Selection Matrix Example
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Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > Pugh Concept Selection Matrix to access the Pugh Concept Selection Matrix template. Enter data as shown.































Control Plan
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Click SigmaXL > Templates & Calculators > DMAIC & DFSS Templates > Control Plan to access the Control Plan template.









Lean – Takt Time Calculator Example
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Category

Count

Difficult-to-order

Not-available

Ordertakes too-long

Return-calls
Wrong-color

Pareto Chart



Click SigmaXL > Templates & Calculators > Lean > Takt Time Calculator to access the Takt Time calculator. The template gives the following default example:









Lean – Value Analysis/Process Load Balance
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Click SigmaXL > Templates & Calculators > Lean > Value Analysis/Process Load Balance to access the Value Analysis/Process Load Balance template. The template gives the following default example:
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Lean – Value Stream Mapping
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Click SigmaXL > Templates & Calculators > Lean > Value Stream Mapping to access the Value Stream Mapping template.

































Open the file Template & Calculator Examples.xls.  Click on the worksheet named VSM Example.  This is a present state value stream map of a manufacturing operation. This example is courtesy and copyright of Strategos, Inc.  www.strategosinc.com.

[image: image88.png]Sample Size Calculator - Discrete Data

Sample Data (user inputs):

Estimate of Proportion P
Desired margin of error__delta/ half-interval
Population Size (optional) N
Confidence level (enter .95 for 95%) 100°(1-0)%
Resuits:
Minimum Sample Size n 1068
n (adjusted for small N)
np check (should be 2 5) 534












Basic Graphical Templates – Pareto Example
[image: image89.png]Sample Size Calculator - Continuous Data

Sample Data (user inputs):

Estimate of Standard Deviation s
Desired margin of error__delta  half-interval
Population Size (optional) N
Confidence level (enter .95 for 95%) 100°(1-0)%
Resuits:
Minimum Sample Size n 62

n (adjusted for small N)




Click SigmaXL > Templates & Calculators > Basic Graphical Templates > Pareto Chart. Enter data as shown:








Click the Pareto Chart button to produce the Pareto Chart:
[image: image90.png]1 Sample t - Confidence Interval for Mean

Sample Data (user inputs):

Sample Size

n_ ]

Sample Mean

x-bar

Sample Standard Deviation

s

Confidence level (enter .95 for 95%)

100" (1-0)%

Confidence Interval Results:

Two-Sided Limits

Upper Limit| 0.373406131

Lower Limit| -0.373406131

lies between -0.3734 and 0.3734

Interpretation: we are 95% confident that the true population mean

One-Sided Limit - Upper (select a priori)

Upper Limit[ 0.310216728

lies below 0.3102

Interpretation: we are 95% confident that the true population mean

One-Sided Limit - Lower (select a priori)

Lower Limit| -0.310216728

lies above 0.3102

Interpretation: we are 95% confident that the true population mean





Notes:


1. This Pareto Chart template should be used with count data like number of errors.  You can also create Pareto charts with cost data.

2. You can replace the Category and Count column headings with any headings that you wish.

3. Enter the Pareto categories in the Category column. These can be Name, Location, Error Type or other text information. Pareto categories are required and will appear on the horizontal X-Axis of the Pareto Chart.

4. Enter your count (or cost) data in the Count column.

5. Click the Pareto Chart button to create a Pareto Chart.
Basic Graphical Templates – Histogram Example
[image: image91.png]2 Sample t-Test Calculator

1 (Compare 2 Means; Hy: i1 = i2; Assume Equal Variance)

Standard Deviation|

Sample 2

Results:

Mean Difference] 1.0000

Std Error Difference (Using Pooled Variance) 02582
dff| 58

t-statistic| 38730

p-value (2-sided, Ha: i, # i) 0.0003

p-value (1-sided, Ha: i, < ) 0.0001

p-value (1-sided, Ha: i, > )| 09999




Click SigmaXL > Templates & Calculators > Basic Graphical Templates > Histogram. Enter data as shown:
















[image: image92.png]2 Sample t-Test Calculator
XL (Compare 2 Means; Hy: w1 = u2; Assume Unequal Variance)

Sample Data (user inputs):

Count]

Mean|

Standard Deviation|

Sample 2

Results:

Mean Difference] 1.0000

Std Error Difference| 04830

o 25.399

t-statistic| -2.0702

p-value (2-sided, Ha: i, # i) 0.0489
p-value (1-sided, Ha: i, < ) 0.0245
p-value (1-sided, Ha: i, > )| 09755





Click the Histogram button to produce the Histogram:















Notes:

1. This Histogram template should be used with continuous data like cycle time.

2. You can replace the Data column heading with any heading that you wish.

3. Enter your data in the Data column.

4. Click the Histogram button to create a Histogram.

Basic Graphical Templates – Run Chart Example
[image: image93.png]1 Sample Confidence Interval for a Standard Deviation

Sample Data (user inputs):

Sample Size n |

Sample Standard Deviation s

Confidence level (enter 95 for 95%) __100"(1-w)%

Confidence Interval Results:

Two-Sided Limits

Upper Limit| 1.344315175

Lower Limit| 0.796406933

Interpretation: we are 95% confident that the true standard deviation lies between 0.7964|
and 13443




Click SigmaXL > Templates & Calculators > Basic Graphical Templates > Run Chart. Enter the data as shown (copy and paste the histogram data):
















Click the Run Chart button to produce the Run Chart:


























[image: image94.png]2 Sample F-Test Calculator

Sample Data (user inputs):

Count]
Standard Deviation
Variance
Results:
Fstatistic] 4.0000
0.0341

p-value (Z-sided, Ha: o’ # o))




Notes:

1. This Run Chart template can be used with a variety of data types: continuous data like cycle time, count data like number of errors, or cost data. The data must be in chronological time-sequence order.

2. You can replace the X-Axis Label and Data column headings with any headings that you wish.

3. Enter your data in the Data column.

4. Enter labels in X-Axis Label column.  Labels can be Date, Time, Name, or other text information. These labels are optional and will appear on the horizontal X-Axis of the Run Chart.

5. Click the Run Chart button to create a Run Chart.

Basic Statistical Templates – Sample Size – Discrete Example
Click SigmaXL > Templates & Calculators > Basic Statistical Templates > Sample Size – Discrete to access the Sample Size – Discrete calculator. The template gives the following default example:
[image: image95.png]Confidence Interval for One Proportion

Sample Data (user inputs):

Number of elements in category of interest x

Size of Sample n

Confidence Level _ 100*(1-w)%

Results:

Estimated proportion (point estimate) __p=xin | 0.1000

Exact Limits (2-sided, based on binomial distr.)

Upper Limit] __0.1762

Lower Limit] 0.0490

Interpretation: we are 95% confident that the true proportion lies
between 0.0490 and 0.1762

Approximate Limits (2-sided, based on normal approx.)

Margin of Error (+/)] 0.0588

Upper Limit] __0.1588

Lower Limit] 0.0412

Interpretation: we are 95% confident that the true proportion lies
between 0.0412 and 0.1588
















Notes for use of the Sample Size – Discrete Calculator:

1. P is estimate of proportion for outcome of interest.  Use P = 0.5 if unknown.

2. Delta is desired proportion margin of error.  Enter as the half-width, i.e. if the desired margin of error is +/- 3%, enter 0.03. 

3. Enter population size N to adjust for small populations (N < 10000).

4. np should be >= 5.  If necessary, reduce delta to adjust.
5. Power (1 – Beta) is not considered in these calculations.  Power and Sample Size may be calculated using SigmaXL > Statistical Tools > Power & Sample Size Calculators.
This sample size calculator is based on a confidence interval approach, where you enter the desired half-interval value (delta). Let’s say that you desire the proportion margin of error to be +/- 3%. As noted above, you simply enter a delta (half-interval) value of .03. 
The challenge with this sample size calculator is that we need an estimate of the population proportion.  This is a bit of a chicken and egg situation – which comes first?  I want to calculate an appropriate sample size to determine an outcome, but I am being asked to enter an estimate of the population proportion.  First, keep in mind that this tool is a planning tool – the true confidence intervals will be determined after you collect your data. Estimating the population proportion can be done if you have good historical data to draw from, for example, in historical customer surveys the percentage of satisfied customers was 80%. In this case you could use P=0.8. If you do not have a priori knowledge, then leave P=0.5 which gives the most conservative value (i.e., largest estimate of sample size).  If you enter a value other than 0.5 it will result in a smaller sample size requirement. 
Basic Statistical Templates – Sample Size – Continuous Example

Click SigmaXL > Templates & Calculators > Basic Statistical Templates > Sample Size – Continuous to access the Sample Size – Continuous calculator. The template gives the following default example:

[image: image96.png]Hypothesis Test for the Equality of Two Proportions

Sample Data (user inputs)

Number of elements in sample #1 in category of interest: __x,
Size of Sample #1: __n,
Number of elements in sample #2 in category of interest: __x,

Size of Sample #2: __n,

Hypothesis Test Results:

Proportion (sample #1) 07000

Proportion (sample #2) 08000

1633

Normal approximation p-value (2-sided, Ha: 0102
Normal approximation p-value (1-sided, H: 0051
Normal approximation p-value (1-sided, Ha: 0949
Fisher's exact p-value (2-sided, H 0141
Fisher's exact p-value (1-sided, Ha: P, < P,)|  0.071
Fisher's exact p-value (1-sided, Ha: P, > P,)|0.964














Notes for use of the Sample Size – Continuous Calculator:

1. Delta uses the same units as the standard deviation.  Enter as the half-width, i.e., if the desired margin of error is +/- 0.25, enter 0.25. 

2. Enter (optional) population size N to adjust for small populations (N < 1000).
3. Power (1 – Beta) is not considered in these calculations.  Power and Sample Size may be calculated using SigmaXL > Statistical Tools > Power & Sample Size Calculators.


Similar to the Sample Size – Discrete calculator, this sample size calculator is based on a confidence interval approach, where you enter the desired half-interval value (delta). If a survey had responses that were on a continuous scale of 1 to 5, and you desired a margin of error on the mean to be +/- .25, then you would use .25 as the delta value.  Note that in this continuous case the units are not percentages but level of satisfaction.

Here we need an a priori estimate of the population standard deviation.  If you have no idea what the standard deviation will be, then you could take a small sample to get a rough estimate of the standard deviation.
Basic Statistical Templates – 1 Sample t Confidence Interval for Mean Example

[image: image97.png]Normal Distribution Probability Calculator

Input the following information:

Mean n

Standard Deviation o
Lower Bound (or LSL) X1
Upper Bound (or USL) X2

Select the Probability of Interest from
Areas: the following probabilities:

between X1 and X2 Prob(1sXs2) 0.135905122

outside X1 and X2

AN
/(1\

below X1 A Prob(X<1) 0.841344746
A

Prob(Xs1 AND X22) 0.864094878

above X1 Prob(X21) 0.158655254

below X2 Prob(Xs2) 0.977249868

above X2 ) Prob(X=2) 0022750132




Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 1 Sample t Confidence Interval for Mean to access the 1 Sample t Confidence Interval for Mean calculator. The template gives the following default example.


























Basic Statistical Templates – 2 Sample t-Test (Assume Equal Variance) Example
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Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 2 Sample t-Test (Assume Equal Variances) to access the 2 Sample t-Test calculator. The template gives the following default example.











Basic Statistical Templates – 2 Sample t-Test (Assume Unequal Variance) Example
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Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 2 Sample t-Test (Assume Unequal Variances) to access the 2 Sample t-Test calculator. The template gives the following default example.


Basic Statistical Templates – 1 Sample Confidence Interval for Standard Deviation Example 
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Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 1 Sample Confidence Interval for Standard Deviation  to access the 1 Sample Confidence Interval for Standard Deviation calculator. The template gives the following default example.













Basic Statistical Templates – 2 Sample F-Test (Compare 2 Stdevs) Example 
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Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 2 Sample F-Test (Compare 2 StDevs) to access the 2 Sample F-Test calculator. The template gives the following default example.










Basic Statistical Templates – 1 Proportion Confidence Interval Example

[image: image102.png]Process Sigma Level Calculator - Discrete Data

F\gma
< XL

Sample Data (user inputs):
Number of units n

Total number of defects observed d

Number of defect opportunities per unit___o

Sigma Shift (typically +1.5 for long term data)

Resuits:
Defects per Unit___dpu 001
Defects per Million Opportunities _dpmo. 10,000.0
Defects per Opportunity _dpo% 1.00%
Yield _yield% 99.00%
Process Sigma Level _sigma 3.826




Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 1 Proportion Confidence Interval to access the 1 Proportion Confidence Interval calculator.  The template gives the following default example.
























Note: The exact confidence interval limits should be used for any real world analysis.  The approximate limits based on the normal distribution are provided for instructional purposes, e.g., comparing to hand calculations.



Basic Statistical Templates – 2 Proportions Test & Fisher’s Exact Example

[image: image103.png]Process Sigma Level Calculator - Continuous Data
(Assumes that data are normally distributed)

Sample Data (user inputs):
Mean bar

Standard Deviation s

Upper Specification Limit___USL

Lower Specification Limit __ LSL

Sigma Shift (typically +1.5 for long term data)

Results:
Expected dpm > USL 1349.9
Expected % > USL| 043%
Expected dpm < LSL| 1349.9
Expected % < LSL| 043%
Expected dpm (overall 26998
Expected yield (overall) % 99.73%
Process Sigma Level| 4.282




Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 2 Proportions Test & Fisher’s Exact to access the 2 Proportions Test & Fisher’s Exact calculator.  Enter data as shown:



















Note: Fisher’s exact p-values should be used for any real world analysis.  The approximate p-values based on the normal distribution are provided for instructional purposes, e.g., comparing to hand calculations.









Probability Distribution Calculators – Normal Example

Click SigmaXL > Templates & Calculators > Probability Distribution Calculators > Normal to access the Normal Distribution Probability calculator. The template gives the following default example:
[image: image104.png]Process Capability Indices - Continuous Data
(Assumes that data are normally distributed)

Sample Data (user inputs):

Mean bar

Standard Deviation s

Upper specification limit __USL

Lower specification limit __LSL

Results:

Cp.Pp 1.00
Cpu, Ppu 1.00
Cpl. Ppl 1.00
Cpk, Ppk 1.00
































Basic MSA Templates – Gage R&R Study (MSA) Example

[image: image105.png]Process Capability Indices and Confidence Intervals - Continuous Data
(Assumes that data are normally distributed)

Sample Data (user inputs):

Mean _ x-bar | Upper Specification Limit__USL
Standard Deviation s Lower Specification Limit__LSL
Sample Size __n Confidence Level (enter 95 for 95%)

Sigma Shift (typically +1.5 for long term data))

Process Sigma Level Results: Process Capability Results:
Expected dpm> USL| 227501 Cp.Pp 1.00
Expected%> USL| _ 2.28% Lower Limit Cp, Pp| 074

Expected dpm<LSL| 317 Upper Limit Cp, Pp 126
Expected% <LSL| _ 0.00% Cpu.Ppu| 067

Expected dpm (overall)| 227818 Cpl. Ppl 133
Expected yield (overall)| _ 97.72% Cpk. Ppk| 067

Lower Limit Cpk, Ppk| 046

Process Sigma Level| 3499 Upper Limit Cpk, Ppk| 087
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Click SigmaXL > Templates & Calculators > Basic MSA Templates > Gage R&R Study (MSA) to access the Gage R&R Study template.  

The following example is given in the file Template & Calculator Examples.xls.  Click on the worksheet named Gage R&R.  If prompted, please ensure that macros are enabled.
















Notes for use of the Gage R&R Template:

1. The Automotive Industry Action Group (AIAG) recommended study includes 10 Parts, 3 Operators and 3 Replicates.  The template calculations will work with a minimum of 2 Operators, 2 Parts and 2 Replicates.  The data should be balanced with each operator measuring the same number of parts and the same number of replicates.  Use SigmaXL > Measurement Systems Analysis to specify up to 30 Parts, 10 Operators and 10 Replicates.
2. Enter process Upper Specification Limit (USL) and Lower Specification Limit (LSL) in the Process Tolerance window.  This is used to determine the % Tolerance metrics.  If the specification is single-sided, leave both entries blank.
3. The default StDev multiplier is 6.  Change this to 5.15 if AIAG convention is being used.
4. The cells shaded in light blue highlight the critical metrics Gage R&R % Total Variation (also known as %R&R) and %Tolerance: < 10% indicates a good measurement system; 
> 30% indicates an unacceptable measurement system.
Gage R&R: Multi-Vari & X-bar R Charts Example

Click SigmaXL > Templates & Calculators > Basic MSA Templates > Gage R&R: Multi-Vari & X-bar R Charts to access the Multi-Vari & X-bar R Charts template.  An example is given in the file Template & Calculator Examples.xls.  Click on the worksheets named Gage R&R - Multi-Vari and Gage R&R – X-Bar R:
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Notes for use of the Gage R&R: Multi-Vari & X-bar R Charts:
1. The Gage R&R Multi-Vari and X-bar & R charts can only be generated if a Gage R&R template has been completed and is the active worksheet.  Select the Gage R&R worksheet and click SigmaXL > Templates & Calculators > Gage R&R:  Multi-Vari & X-Bar R Charts to create the above charts.

2. The Multi-Vari chart shows each Part as a separate graph.  Each Operator’s response readings are denoted as a vertical line with the top tick corresponding to the Maximum value, bottom tick is the Minimum, and the middle tick is the Mean.  The horizontal line across each graph is the overall average for each part.

3. When interpreting the X-bar and R chart for a Gage R&R study, it is desirable that the X-bar chart be out-of-control, and the Range chart be in-control.  The control limits are derived from within Operator repeatability.

Basic MSA Templates – Attribute Gage R&R (MSA) Example

Click SigmaXL > Templates & Calculators > Basic MSA Templates > Attribute MSA to access the Attribute MSA Study template.  An example is given in the file Template & Calculator Examples.xls.  Click on the worksheet named Attribute MSA.
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Notes for use of the Attribute Gage R&R (MSA) Template:
1. Attribute Gage R&R is also known as Attribute Agreement Analysis.

2. Recommend for study:  3 Appraisers, 2 to 3 Replicates, Minimum of 10 Good Parts and 10 Bad Parts.  The data should be balanced with each appraiser evaluating the same number of parts and the same number of replicates.

3. Specify the Good Part or Unit as G or other appropriate text (P, Y, etc.).  Specify the Bad Part or Unit as NG or other appropriate text (F, N, etc.).  Be careful to avoid typing or spelling errors when entering the results.  A space accidentally inserted after a character will be treated as a different value leading to incorrect results.
Basic Process Capability Templates – Process Sigma Level – Discrete Data Example
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Click SigmaXL > Templates & Calculators > Basic Process Capability Templates > Process Sigma Level – Discrete to access the Process Sigma Level – Discrete calculator.  The template gives the following default example.














Notes for use of the Process Sigma Calculator for Discrete Data:

1. Total number of defects should include defects made and later fixed.
2. Sample size should be large enough to observe 5 defects.


Basic Process Capability Templates – Process Sigma Level – Continuous Data Example
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Click SigmaXL > Templates & Calculators > Basic Process Capability Templates > Process Sigma Level – Continuous to access the Process Sigma Level – Continuous calculator.  The template gives the following default example.

















Note: This calculator assumes that the Mean and Standard Deviation are computed from data that are normally distributed.

Basic Process Capability Templates – Process Capability Indices Example
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Click SigmaXL > Templates & Calculators > Basic Process Capability Templates > Process Capability to access the Process Capability Indices calculator.  The template gives the following default example.












Notes for use of the Process Capability Indices Calculator:
1. This calculator assumes that the Mean and Standard Deviation are computed from data that are normally distributed.

2. Reports Cp, Cpk if entered S is Within or Short Term (using a control chart).

3. Reports Pp, Ppk if entered S is Overall or Long Term.







Basic Process Capability Templates – Process Capability & Confidence Intervals Example
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Click SigmaXL > Templates & Calculators > Basic Process Capability Templates > Process Capability & Confidence Intervals to access the Process Capability Indices & Confidence Intervals calculator.  The template gives the following default example.












Notes for use of the Process Capability & Confidence Intervals Calculator:

1. This calculator assumes that the Mean and Standard Deviation are computed from data that are normally distributed.

2. Reports Cp, Cpk if entered S is Within or Short Term (using a control chart).

3. Reports Pp, Ppk if entered S is Overall or Long Term.








Basic Control Chart Templates – Individuals Chart Example
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Click SigmaXL > Templates & Calculators > Basic Control Chart Templates > Individuals Chart. Enter the data as shown (or copy and paste the “Before” data from the histogram data above):










Click the Individuals Control Chart button to produce the Individuals Chart (note that in actual application, one should use a minimum of 20 to 30 data points to compute the initial control limits).
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Now enter the data as shown (or copy and paste the “After” data from the histogram data used earlier):
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Click the Add Data button to add the “After” data to the Individuals chart.


















Notes:

1. This Individuals Control Chart template should be used with continuous data like cycle time. The data must be in chronological time-sequence order.

2. You can replace the X-Axis Label and Data column headings with any headings that you wish.

3. Enter your data in the Data column.

4. Enter labels in X-Axis Label column.  Labels can be Date, Time, Name, or other text information. These labels are optional and will appear on the horizontal X-Axis of the Individuals Control Chart.

5. Click the Individuals Control Chart button to create an Individuals Control Chart.

6. After the control chart has been created and additional new data entered into the Data column, click the Add Data button to add the data to the existing chart.
Part C – Descriptive/Summary Statistics

Descriptive Statistics

1. Open Customer Data.xls.  (to access, click SigmaXL > Help > Open Help Data Set Folder or Start > Programs > SigmaXL > Sample Data). Click Sheet 1 Tab.

2. Click SigmaXL > Statistical Tools > Descriptive Statistics.
3. Check Use Entire Data Table, click Next.
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Select Overall Satisfaction, click Numeric Data Variables (Y) >>.                                Select Customer Type, click Group Category (X1) >> as shown:











5. Click OK.
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Descriptive Statistics are given for Customer Satisfaction grouped by Customer Type:







Which Customer Type has the highest mean satisfaction score?  Clearly Type 2.  However, we have to be careful concluding that there is a significant difference in satisfaction solely by looking at the Means.  In the Analyze Phase, we will run tests of hypothesis to validate that Type 2 Customers are, in fact, significantly more satisfied.
Tip: Click on Column B, click Window > Split, Window > Freeze Panes  (Excel 2007/2010: View | Window | Split, Freeze Panes).  This freezes Column A and allows you to scroll across the Descriptive Statistics for each level of the Group Category. This is particularly beneficial when there are a large number of columns.
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Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.  Change the format selected to Column Format as shown:












8. Click OK.  Descriptive Statistics are given for Customer Satisfaction broken out by Customer Type in Column Format:
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Tip: This column format is useful to create subsequent graphs on the summary statistics.


Part D – Histograms

Basic Histogram Template
Click SigmaXL > Templates and Calculators > Basic Graphical Templates > Histogram or SigmaXL > Graphical Tools > Basic Graphical Templates > Histogram.  See Part B – Templates and Calculators for a Histogram Template example.

Single (Basic) Histogram

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet).
2. Click SigmaXL > Graphical Tools > Basic Histogram.
3. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >> as shown:
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Click Next. Ensure that Normal Curve is checked.  Set Start Point = 1.  Change the Bin Width to 0.5, and the Number of Bins to 8.  Click Update Chart to view the histogram.  (If the survey satisfaction data was pure integer format we would have checked the Integer Data option).









6. Click Finish.  A histogram of Overall Customer Satisfaction is produced.
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 Note that bin one is 1 to  < 1.5,  bin 2 is 1.5 to < 2, etc.

Tip:  Any graph produced by SigmaXL can be Copied/Pasted into Word.  It can also be enlarged by clicking on the graph and dragging the corner.  The number of decimal places displayed can be modified by clicking on the Axis Label and selecting the Number tab to adjust.  The text label alignment can also be modified by selecting the Alignment tab (Excel 2007/2010: Select Axis, Right Click, Format Axis…).
Multiple Histograms

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet).
2. Click SigmaXL > Graphical Tools > Histograms & Descriptive Statistics. 
3. Ensure that entire data table is selected. If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, click Numeric Data Variables (Y) >>, select Customer Type, click Group Category (X1) >> as shown:
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Click OK.  Multiple Histograms and Descriptive Statistics of Customer Satisfaction By Customer Type are produced:



























Clearly Customer Type 2 shows a higher level of overall satisfaction, with the data skewed left.  Note that Customer Type 1 and 3 have data that is normally distributed, but this is not desirable when the response is a satisfaction score!


6. Note that bin one is 1.72 to < 1.99,  bin 2 is 1.99 to < 2.26, etc.  The number of decimals displayed can be changed by double-clicking on the X axis, click Number tab, and adjust decimal places. 
Part E – Dotplots

Dotplots
1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet).  Click SigmaXL > Graphical Tools > Dotplots.
2. Ensure that entire data table is selected. If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>, select Customer Type, click Group Category (X1) >>:
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Click OK.  Multiple dotplots of Customer Satisfaction By Customer Type are produced:




5. Since all data points are shown, dotplots are a useful alternative to Histograms, particularly when the group sample sizes are small (n < 30). 
Part F – Boxplots

Boxplots

1. Click Sheet 1 Tab of  Customer Data.xls (or press F4 to activate last worksheet).  
2. Click SigmaXL > Graphical Tools > Boxplots.
3. Ensure that entire data table is selected.  If not, check Use Entire Data Table. Click Next.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>, select Customer Type, click Group Category (X1) >>, check Show Mean, check Show Legend:










5. Click OK.  A boxplot of Customer Satisfaction By Customer Type is produced:

[image: image15.png]





6. The legend indicates that the solid center line is the median. The dashed red line shows the sample mean.  The top of the box is the 75th percentile (Q3).  The bottom of the box is the 25th percentile (Q1). The height of the box is called the Inter-Quartile Range (IQR) and is a robust measure of spread or sample variability.  The data point highlighted for Customer Type 2 is a potential outlier (< Q1 – 1.5 * IQR or > Q3 + 1.5 * IQR).  Note that extreme outliers are highlighted with a solid dot (< Q1 – 3 * IQR or > Q3 + 3 * IQR).

Tip: If you hover your mouse cursor in the middle of any of the Boxplot lines as shown, you will see the balloon help indicating what the line is and its numeric Y value.
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Now we will modify the Y axis scale, showing 1 as minimum and 5 as maximum (given that the response data comes from a survey with 1-5 scale).  To do this double click on the Y axis, select Scale, modify the minimum value and maximum value Change Category (X) axis Crosses at:  to 1 as shown: 












Note, in Excel 2007/2010, right click on the Y-Axis and select “Format Axis". 
8. [image: image134.png]Format.

s

pattems  Sadle | Font | Number | Aignment |
Value (Y) axis scale
Ao

™ Minimum: 1
T magmum: |5
L
© Mo o

I Category () axs

Grossesat: [1
Display units:  [None ~ ¥

T Logarithmic scale:
T Valuesin reverse order
I~ Category () axs crosses at mainum value

= C==]




Click OK.  The Boxplot axis is modified as shown below:














9. Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X1) >>; select Size of Customer, click Group Category (X2) >>; check Show Mean; uncheck Show Legend:
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Click OK.  Boxplots of Customer Satisfaction By Customer Type and Size are produced:
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In order to adjust the Y-axis scale for both charts, click SigmaXL Chart Tools > Set Chart Y-Axis Max/Min.







13. Click OK.  The Y-axis scale maximum and minimum are now modified for both charts.

Part G – Normal Probability Plots

Normal Probability Plots
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Create 100 random normal values as follows:  Click SigmaXL > Data Manipulation > Random Data > Normal.  Specify 1 Column, 100 Rows, Mean of 100 and Standard Deviation of 25 as shown below:










2. Click OK.  Change Column heading to Normal Data.
3. Create a Histogram & Descriptive Statistics for this data.  Your data will be slightly different due to the random number generation:
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If the p-value of the Anderson-Darling Normality test is greater than or equal to .05, the data is considered to be normal (interpretation of p-values will be discussed further in Analyze).

4. Create a normal probability plot of this data: Click Normal Random Data (1) Sheet, Click SigmaXL > Graphical Tools > Normal Probability Plots.

5. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
6. Select Normal Data, click Numeric Data Variable (Y) >>.  Check Add Title.  Enter Example Normal Prob Plot. 


7. Click OK.  A Normal Probability Plot of simulated random data is produced (again, your plot will be slightly different due to the random number generation):
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The data points follow the straight line fairly well, indicating that the data is normally distributed.  Note that the data will not likely fall in a perfectly straight line.  The eminent statistician George Box uses a “Fat Pencil” test where the data, if covered by a fat pencil, can be considered normal!  We can also see that the data is normal since the points fall within the normal probability plot 95% confidence intervals (confidence intervals will be discussed further in Analyze).
8. Click Sheet 1 Tab of Customer Data.xls.
9. Click SigmaXL > Graphical Tools > Normal Probability Plots.
10. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction; click Numeric Data Variable (Y) >>.  Click OK.  A Normal Probability Plot of Customer Satisfaction data is produced:
















Is this data normally distributed?  See earlier histogram and descriptive statistics of Customer Satisfaction data.

12. Now we would like to stratify the customer satisfaction score by customer type and look at the normal probability plots.  
13. Click Sheet 1 of Customer Data.xls.  Click SigmaXL > Graphical Tools > Normal Probability Plots.  Ensure that Entire Table is selected, click Next.  (Alternatively, press F3 or click Recall SigmaXL Dialog to recall last dialog).
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type as Group Category (X) >>.  Click OK.  Normal Probability Plots of Overall Satisfaction by Customer Type are produced:







Reviewing these normal probability plots, along with the previously created histograms and descriptive statistics, we see that the satisfaction data for customer type 2 is not normal, and skewed left, which is desirable for satisfaction data!  Note that although the customer type 2 data falls within the 95% confidence intervals, the Anderson Darling test from descriptive statistics shows p < .05 indicating non-normal data.  Smaller sample sizes tend to result in wider confidence intervals, but we still see that the curvature for customer type 2 is quite strong. 

Tip:  Use the Normal Probability Plot (NPP) to distinguish reasons for nonnormality.  If the data fails the Anderson Darling (AD) test (with p < 0.05) and forms a curve on the NPP, it is inherently nonnormal or skewed.  Calculations such as Sigma Level, Pp, Cp, Ppk, Cpk assume normality and will therefore be affected.  Consider transforming the data using LN(Y) or SQRT(Y) or using the Box-Cox Transformation tool (SigmaXL > Data Manipulation > Box-Cox Transformation) to make the data normal.  Of course, whatever transformation you apply to your data, you must also apply to your specification limits. See also the Process Capability for nonnormal data tools.
If the data fails the AD normality test, but the bulk of the data forms a straight line and there are some outliers, the outliers are driving the nonnormality.  Do not attempt to transform this data!  Determine the root cause for the outliers and take corrective action on those root causes.

Part H– Run Charts

Run charts, also known as trend charts and time series plots, add the dimension of time to the graphical tools.  They allow us to see trends and outliers in the data.  Run Charts are a precursor to control charts, which add calculated control limits.  Note that Run Charts should be used only on unsorted data, in its original chronological sequence.

Basic Run Chart Template
Click SigmaXL > Templates and Calculators > Basic Graphical Templates > Run Chart or SigmaXL > Graphical Tools > Basic Graphical Templates > Run Chart.  See Part B – Templates and Calculators for a Run Chart Template example.

Run Charts

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet). Click SigmaXL > Graphical Tools > Run Chart. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>.  Select Show Mean. Uncheck Nonparametric Runs Test (to be discussed later in Part N of Analyze Phase).
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Click OK.  A Run Chart of Overall Satisfaction with Mean center line is produced.
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Double click on the Y axis to activate the Format Axis dialog.  Select the Scale tab, change Minimum to 1, Maximum to 5., Category X Axis Crosses at 1 (Excel 2007/2010: Select Axis, Right Click, Format Axis, Axis Options):













5. Click OK.

6. [image: image146.png]Gage R&R Multi-Vari Gage R&R Multi-Vari

Operator 8 Operator 8
Operator - Part 01 Operator - Part 02




Are there any obvious trends?  Some possible cycling, but nothing clearly stands out.  It may be interesting to look more closely at a specific data point.  Any data point value can be identified by simply moving the cursor over it: 
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A label can be added to a data point by two single-clicks (not a double-click) on the data point, followed by a right mouse click, and select Format Data Point.  Select Data Labels tab, check Value (Excel 2007/2010:  Single Click on data point, Right Click, Add Data Label). See also SigmaXL Chart Tools > Add Data Label in Control Phase Tools, Part B - X-Bar & Range Charts.
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Click OK.  Resulting Run Chart with label attached to data point:
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This label can be changed to a text comment. Single-click three times on the label and type in a comment as shown:







Overlay Run Charts
1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet). Click SigmaXL > Graphical Tools > Overlay Run Chart.

2. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, Responsive to Calls and Ease of Communications. Click Numeric Data Variable (Y) >>.
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Click OK.  An Overlay Run Chart of Overall Satisfaction, Responsive to Calls and Ease of Communications is produced.








Part I – Measurement Systems Analysis
Basic MSA Templates
Click SigmaXL > Templates and Calculators > Basic MSA Templates or SigmaXL > Measurement Systems Analysis > Basic MSA Templates.  See Part B – Templates and Calculators for MSA Template examples. If you wish to analyze the template data with the Gage R&R Analysis Tool, click Create Stacked Column Format for “Analyze Gage R&R” >>.
Create Gage R&R (Crossed) Worksheet
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To create a blank Gage R&R worksheet, click SigmaXL > Measurement Systems Analysis > Create Gage R&R (Crossed) Worksheet.  A crossed Gage R&R study means that every operator/appraiser will measure every part/sample.   





















2. The default settings are 10 Parts, 3 Operators, 3 Replicates with Parts and Operators randomized.  Clicking the Reset button will restore the dialog to these default settings. 

3. Part and Operator names can be edited.
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Click OK.  The following worksheet is produced: 


















5. Your worksheet order will be different due to the randomization.  The results of the Gage R&R study are entered in the yellow highlighted Measurement cells.
 
Analyze Gage R&R (Crossed)
1. Open the file Gage RR – AIAG.xls.  This is an example from the Automotive Industry Action Group (AIAG) MSA Reference Manual, 3rd Edition, page 101.  Note that parts were measured in random order, but the worksheet is given in standard order.
2. Click SigmaXL > Measurement Systems Analysis > Analyze Gage R&R (Crossed).  The data worksheet is recognized by SigmaXL and highlighted automatically.  Click Next.
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Select Part, Operator and Measurement as shown.  Check Display Multi-Vari & X-Bar R Charts.  Check Tolerance/Historical StDev (Optional) and enter 8 for the Process Tolerance Upper-Lower Spec.   





















4. Click OK.  The following Gage R&R Study Report is produced:   
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5. The first ANOVA table shows that the Operator * Part Interaction is not significant with the P-value = 0.9741 (greater than the alpha-to-remove value of 0.1).  The second ANOVA table shows the results excluding the Part * Operator Interaction.
6. The cells shaded in light blue highlight the critical metrics:  Gage R&R % Total Variation (also known as %R&R) and %Tolerance:  < 10% indicates a good measurement system; 
> 30% indicates an unacceptable measurement system.  The Number of Distinct Categories should be at least 5.  Initial analysis shows that this is a marginal measurement system.  (Traditionally NDC is truncated to an integer value, but SigmaXL reports a more informative one decimal place). 
7. SigmaXL also reports the confidence intervals for the Gage R&R metrics.  Note that when the confidence intervals are taken into account, it is possible that this measurement system is totally inadequate.  This strongly suggests that the measurement system needs to be improved but it also points out the weakness of the traditional Gage R&R study with 10 Parts, 3 Operators, and 3 Replicates.  These sample sizes will typically yield wide confidence intervals.  For statistical details of the Gage R&R confidence intervals see Burdick, R. K., Borror, C. M., and Montgomery, D. C., “Design and Analysis of Gauge R&R Studies: Making Decisions with Confidence Intervals in Random and Mixed ANOVA Models”, ASA-SIAM Series on Statistics and Applied Probability, 2005.
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 Click on the Gage R&R – Multi-Vari Sheet tab to view the Multi-Vari Chart:









The Multi-Vari chart shows each Part as a separate graph.  Each Operator’s response readings are denoted as a vertical line with the top tick corresponding to the Maximum value, bottom tick is the Minimum, and the middle tick is the Mean.  The horizontal line across each graph is the overall average for each part.
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Click on the Gage R&R – X-Bar R Sheet tab to view the X-Bar & R Chart:

















When interpreting the X-bar and R chart for a Gage R&R study, it is desirable that the X-bar chart be out-of-control, and the Range chart be in-control.  The control limits are derived from within Operator repeatability.  The Range chart indicates a problem with Operator B being inconsistent.
Attribute MSA (Binary)
Attribute MSA is also known as Attribute Agreement Analysis.  The response must be binary (e.g. Pass/Fail, Good/Bad, G/NG, Yes/No).

1. Open the file Attribute MSA – AIAG.xls.  This is an example from the AIAG MSA Reference Manual, 3rd Edition, page 127.  Note that the worksheet data must be in stacked column format
2. Click SigmaXL > Measurement Systems Analysis > Attribute MSA (Binary). Ensure that the entire data table is selected.  Click Next.
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Select Part, Appraiser, Assessed Result and Reference as shown.  Check Report Information and enter AIAG Example, Page 127: 
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Click OK.  The Attribute MSA report is produced as shown below












:






5. [image: image161.png]Process Capability Report: Shot 1 - Shot3

Count )
Mean | 100.37]
StDev (Overall, Long Term) | 4055
‘StDev (Within, Short Term) | 3.721
USL 08
Target 00
[55 9]
using Overall StDev
Pp 066
Ppu 063
Ppl 069
063
0566
Cp 077
Cpu 0563
3.00 Cpl 0.7
Cpk 0563
200

Expected Overall Performance
100 ppm > USL | 296740
w ppm < LSL | 195319
g ppm Total | 494059
g oo %> USL| 299%
2 %< LSL| 1.95%)
.00 % Total |_4.94%

200 Actual (Empirical] Performance

%> USL
300 %< LSL| 5009
S S e % Total |_500%)
Shot 1 - Shot

‘A-Squared | 0530165
pvalue | 0.1689]




The report includes a summary showing the original data in unstacked format.  This makes it easy to visually compare appraiser results by part:


















6. Fleiss’ Kappa statistic is a “correlation coefficient” for discrete data.  Kappa ranges from -1 to +1.  A Kappa value of +1 indicates perfect agreement.  If Kappa = 0, then agreement is the same as would be expected by chance.  If Kappa = -1, then there is perfect disagreement.  Kappa values > 0.9 indicate a very good measurement system; Kappa values > 0.7 indicate an acceptable measurement system.

7. The Between Appraiser Agreement and All Appraisers vs. Standard Agreement are also known as “System Effectiveness Scores”, with > 95% considered very good, 90-95% acceptable, 80 to < 90 % marginal, and < 80 % unacceptable.
8. Clearly this measurement system needs to be improved, but we should not be quick to judge Appraiser C.  The confidence intervals are quite wide and overlap.  It is a good practice to “blame the process not the people”.  Look for unclear or confusing operational definitions, inadequate training, operator distractions or poor lighting.  Consider the use of pictures to clearly define a defect.  Use Attribute MSA as a way to “put your stake in the ground” and track the effectiveness of improvements to the measurement system.
Part J – Process Capability

Process Capability Templates
Click SigmaXL > Templates and Calculators > Basic Process Capability Templates or SigmaXL > Process Capability > Basic Process Capability Templates.  See Part B – Templates and Calculators for Process Capability Template examples.

Histograms and Process Capability 
1. Open the file Delivery Times.xls.  This contains continuous data of hotel breakfast delivery times.  Deviation Time is the deviation around targeted delivery time in minutes.  The Critical Customer Requirements (CCR’s) are as follows:  USL = 10 minutes late, LSL = -10 minutes (early).

2. Let’s begin with a view of the data using Histograms and Descriptive Statistics.  Click SigmaXL > Graphical Tools > Histograms & Descriptive Statistics.

3. Ensure that entire data table is selected.  If not, check Use Entire Data Table.          Click Next.
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Select Delivery Time Deviation, click Numeric Data Variable (Y) >>.  Click OK.











Note that the data has an average of 6, so on average the breakfast delivery is 6 minutes late.  Also note the wide variation in delivery times (Stdev = 7.2 minutes).  With the AD p-value > .05, this data can be assumed to have a normal distribution.

5. Click Sheet 1 Tab.  Click SigmaXL > Process Capability > Histograms & Process Capability (or SigmaXL > Graphical Tools > Histograms & Process Capability).
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Select Delivery Time Deviation , click Numeric Data Variable (Y) >>.  Enter USL = 10, Target = 0, LSL = -10, check Normal Curve as shown below:
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Click OK.  Resulting Histogram & Process Capability report is shown below:














With the Process Performance indices Pp and Ppk < 1, this process is clearly in need of improvement.  Note that the difference between Pp and Ppk is due to the off-center process mean.  (Cp and Cpk indices are provided in the Capability Combination Report or optionally when creating Control Charts). 
Capability Combination Report (Individuals)
1. Open the file Delivery Times.xls.
2. Click SigmaXL >Process Capability > Capability Combination Report (Individuals).
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Select Delivery Time Deviation, click Numeric Data Variable (Y) >>.  Enter USL = 10, Target = 0, LSL = -10, as shown below:
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 Click OK.  The resulting Process Capability Combination report is shown below:
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To print this report, click SigmaXL Chart Tools > Print Charts.  Do not use Excel’s print function.

6. Cp is the “best case” potential capability index.  Ppk is the “worst case” actual performance.  If Cp is excellent (say Cp =2) and Ppk is poor (say Ppk < 1), this indicates that the process can be dramatically improved through centering and stabilizing.  If Cp is poor, you will have to implement fundamental improvements using DMAIC to address common cause variation.  If Ppk = Cp, this indicates that the process is centered and stable, and the short-term (within subgroup) variation is the same as the long-term (overall) variation.
7. Cpm is a similar statistic but it incorporates a penalty for deviation from target.

8. On a technical note regarding compatibility with other software tools, please be advised that SigmaXL does not use unbiasing constants when calculating Overall StDev, Pp, Ppk and Cpm.  This is done in order to ensure that the calculated Overall StDev matches the results given in Descriptive Statistics.  Note that Within StDev, Cp and Cpk are based on control chart techniques (MR-bar/d2 for Individuals Chart, R-bar/d2 for X-Bar & R, S-bar/c4 for X-Bar & S).

Capability Combination Report (Subgroups)
1. Open the file Catapult Data – Xbar Control Charts.xls.  Each operator fires the catapult ball 3 times.  The target distance is 100 inches.  The Upper Specification Limit (USL) is 108 inches.  The Lower Specification Limit (LSL) is 92 inches.

2. Select B2:F22; here, we will only use the first 20 subgroups to determine the process capability (subgroups 21 to 25 are studied later in Control Phase Tools: Statistical Process Control (SPC) Charts: Part B - X-Bar & Range Charts).
3. Select SigmaXL > Process Capability > Capability Combination Report (Subgroups).
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Click Next.  Select Subgroups across Rows, select Shot 1, Shot 2, Shot 3, click Numeric Data Variables (Y) >>.  Select Operator, click Optional X-Axis Labels >>.  Select X-Bar & R Charts. Check Tests for Special Causes. Enter USL = 108, Target = 100, LSL = 92, as shown:
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  Click OK.  The resulting Process Capability Combination report is shown below:



































Capability Combination Report (Individuals Nonnormal)

An important assumption for process capability analysis is that the data be normally distributed. The Capability Combination Report (Individuals Nonnormal) allows you to transform the data to normality or utilize nonnormal distributions, including:
· Box-Cox Transformation (includes an automatic threshold option so that data with negative values can be transformed)

· Johnson Transformation

· Distributions supported: 
· Half-Normal
· Lognormal (2 & 3 parameter)
· Exponential (1 & 2 parameter)
· Weibull (2 & 3 parameter)
· Beta (2 & 4 parameter)
· Gamma (2 & 3 parameter)
· Logistic
· Loglogistic (2 & 3 parameter)
· Largest Extreme Value
· Smallest Extreme Value

· Automatic Best Fit based on AD p-value

For technical details, see Appendix: Statistical Details for Nonnormal Distributions and Transformations.  Also see Andrew Sleeper, Six Sigma Distribution Modeling, for further information on these methods.
Note that these transformations and distributions are particularly effective for inherently skewed data but should not be used with bimodal data or where the nonnormality is due to outliers (typically identified with a Normal Probability Plot). In these cases, you should identify the reason for the bimodality or outliers and take corrective action.  Another common reason for nonnormal data is poor measurement discrimination leading to “chunky” data.  In this case, attempts should be made to improve the measurement system.
Box-Cox Transformation

SigmaXL’s default setting is to use the Box-Cox transformation which is the most common approach to dealing with nonnormal data.  Box-Cox is used to convert nonnormal data to normal by applying a  power transformation, Y^lambda, where lambda varies from -5 to +5.  You may select rounded or optimal lambda. Rounded is typically preferred since it will result in a more “intuitive” transformation such as Ln(Y) (lambda=0) or SQRT(Y) (lambda=0.5).  If the data includes zero or negative values, select Lambda & Threshold. SigmaXL will solve for an optimal threshold which is a shift factor on the data so that all of the values are positive.

1. Open the file Nonnormal Cycle Time2.xls.  This contains continuous data of process cycle times.  The Critical Customer Requirement is: USL = 1000 minutes.

2. Let’s begin with a view of the data using Histograms and Descriptive Statistics.  Click SigmaXL > Graphical Tools > Histograms & Descriptive Statistics.

3. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  Click OK.











Clearly this is a process in need of improvement.  To start, we would like to get a baseline process capability.  The problem with using regular Capability analysis is that the results will be incorrect due to the nonnormality in the data.  The Histogram and AD p-value < .05 clearly show that this data is not normal.

5. We will confirm the nonnormality by using a Normal Probability Plot.  Click Sheet 1 Tab (or F4).  Click SigmaXL > Graphical Tools > Normal Probability Plots.

6. Ensure that the entire data table is selected.  If not, check Use Entire Data Table.           Click Next.

7. Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  Click OK.  A Normal Probability Plot of Cycle Time data is produced:



















8. [image: image174.png]


 The curvature in this normal probability plot confirms that this data is not normal.

9. For now, let us ignore the nonnormal issue and perform a Process Capability study assuming a normal distribution.  Click Sheet 1 Tab. Click SigmaXL > Process Capability > Capability Combination Report (Individuals). 
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Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  Enter USL = 1000; delete previous Target and LSL settings.













11. Click OK.  The resulting Process Capability Report is shown below:
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Notice the discrepancy between the Expected Overall (Theoretical) Performance and Actual (Empirical) Performance.  This is largely due to the nonnormality in the data, since the expected performance assumes that the data is normal.  So why not just use the actual performance and disregard the expected?  This would not be reliable because the sample size, n = 30, is too small to estimate performance using pass/fail (discrete) criteria.

Also note that the process appears to be out-of-control on both the individuals and moving range charts.
12. We will now perform a process capability analysis using the Capability Combination Report for Nonnormal Individuals.  Click Sheet 1 Tab (or F4).  Click SigmaXL > Process Capability > Nonnormal > Capability Combination Report (Individuals Nonnormal).  Ensure that the entire data table is selected.  If not, check Use Entire Data Table.  Click Next. 
13. [image: image178.png]Reliability/Weibull Analysis

Numeric Response (¥) >> Time-to-Fal

(Time to Event)

Right Censor Column >> Censor Code

(Option:

<<Remove

Text or Numeric)

9 ensor Yalue 1
? Censor Yalue >>
Threshold: oo

Method of Estimatior

& Maximum Likelihood

 Least Squares Regression (% on Y) EnfliaEaierh

Estimate Additional Time Percentiles (enter percents separated by a space]

x>

Estimate Survival Probabilities (enter time values separated by a space):

1020130 4050 60 7080 90 100 150 200 250 300

Cancel

Help




Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  Enter USL = 1000.  We will use the default selection for Transformation/Distribution Options: Box-Cox Transformation with Rounded Lambda. Check Tests for Special Causes as shown:
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Click OK.  The resulting Process Capability Combination report is shown below:
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The AD Normality P-Value Transformed Data value of 0.404 confirms that the Box-Cox transformation to normality was successful.  The process capability indices and expected performance can now be used to establish a baseline performance.  Note that there are no out-of-control signals on the control charts, so the signals observed earlier when normality was assumed were false alarms.

The Individuals – Original Data chart displays the untransformed data with control limits calculated as:

UCL = 99.865 percentile 

CL = 50th percentile

LCL = 0.135 percentile

The benefit of displaying this chart is that one can observe the original untransformed data.  Since the control limits are based on percentiles, this represents the overall, long term variation rather than the typical short term variation. The limits will likely be nonsymmetrical.

The Individuals/Moving Range – Normalized Data chart displays the transformed z-values with control limits calculated using the standard Shewhart formulas for Individuals and Moving Range charts. The benefit of using this chart is that tests for special causes can be applied and the control limits are based on short term variation.  The disadvantage is that one is observing transformed data on the chart rather than the original data.

Automatic Best Fit

Now we will redo the capability analysis using the Automatic Best Fit option.
15. Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.  Select Automatic Best Fit as shown:
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Click OK.  The resulting Process Capability Combination report is shown below.  Please note that due to the extensive computations required, this could take up to 1 minute (or longer for large datasets):




















The 2 Parameter Loglogistic distribution was selected as the best fit distribution.  For details on how this selection was made, see Appendix: Statistical Details for Nonnormal Distributions and Transformations.

The Anderson Darling statistic for the Loglogistic distribution is 0.245 which is less than the 0.37 value for the AD Normality test of the Box-Cox transformation indicating a better fit.  (Note that published AD p-values for this distribution are limited to a maximum value of 0.25.  The best fit selection uses a p-value estimate that is obtained by transforming the data to normality and then using a modified Anderson Darling Normality test on the transformed data).
Distribution Fitting

Another helpful tool to evaluate transformations and distributions is Distribution Fitting.

17. Click Sheet 1 Tab (or F4).  Click SigmaXL > Process Capability > Nonnormal > Distribution Fitting.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table.  Click Next. 
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Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  We will use the default selection for Transformation/Distribution Options: All Transformations & Distributions as shown:
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Click OK.  The resulting Distribution Fitting report is shown below.  Please note that due to the extensive computations required, this could take up to 1 minute (or longer for large datasets):
































The distributions and transformations are sorted in descending order using the AD Normality p-value on the transformed z-score values. Note that the first distribution shown may not be the selected “best fit”, because the best fit procedure also looks for models that are close but with fewer parameters.  

The reported AD p-values are those derived from the particular distribution.  The AD p-value is not available for distributions with a threshold (except Weibull), so the AD Normality p-value on the transformed z-score values is used (labeled as Z-Score Est.).

Since the sort order is based on the AD p-values from Z-Score estimates, it is possible that the reported distribution based AD p-values may not be in perfect descending order.  However any discrepancies based on sort order will likely not be statistically or practically significant.

Some data will have distributions and transformations where the parameters cannot be solved (e.g., 2-parameter Weibull with negative values). These are excluded from the Distribution Fitting report.

The parameter estimates and percentile report includes a confidence interval as specified in the Distribution Fitting dialog, with 95% being the default.  Note that the wide intervals here are due to the small sample size, n = 30.
The control limits for the percentile based Individuals chart will be the 0.135% (lower control limit), 50% (center line, median) and 99.865% (upper control limit). Additional percentiles may be entered in the Distribution Fitting dialog.
After reviewing this report, if you wish to perform a process capability analysis with a particular transformation or distribution, simply select Specify Distribution from the Transformation/Distribution Options in the Capability Combination Report (Individuals - Nonnormal) dialog as shown below (using 2 Parameter Loglogistic):
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Box-Cox Transformation


This is a standalone tool that allows you to visually see how the Box-Cox transformation selects a rounded or optimal lambda value.  


1. Open the file Nonnormal Cycle Time2.xls. Select Sheet 1 Tab.  
2. Click SigmaXL > Process Capability > Nonnormal > Box-Cox Transformation (or SigmaXL > Data Manipulation > Box-Cox Transformation or SigmaXL > Control Charts > Nonnormal > Box-Cox Transformation).  Ensure that the entire data table is selected.  If not, check Use Entire Data Table.  Click Next. 
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Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  The selected variable must contain all positive values.











Tip:  Note that while this tool is often successful to transform the data to normality, there may not be a suitable transformation to make the data normal.  The output report indicates the Anderson-Darling p-value for the transformed data.  You may wish to check Do not store if transformed data is not normal.  Another option is Do not store transformed data if Lambda = 1 falls within 95%CI.  This latter option prevents you from using transformations that do not result in a statistically significant improvement towards normality.

4. Click OK.  The resulting report is shown:
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The fact that Lambda=1 falls outside of the 95% confidence interval tells us that the transformation is statistically significant.  The Anderson-Darling p-value of 0.4041 indicates that we cannot reject the null hypothesis that the transformed data is normal, so the Ln transformation has successfully converted the data to normality.

Part K – Reliability/Weibull Analysis
Reliability/Weibull Analysis
The Weibull distribution is a continuous distribution that was publicized by Waloddi Weibull in 1951.  It has become widely used, especially in the reliability field.  The Weibull distribution's popularity resulted from its ability to be used with small sample sizes and its flexibility.  See Dodson, B. “The Weibull Analysis Handbook” Second Edition, ASQ, for further information. For SigmaXL technical details, see Appendix: Statistical Details for Nonnormal Distributions and Transformations.
The Weibull distribution can also be used as an alternative to the Box-Cox Transformation to determine Process Capability Indices or Control Limits for non-normal data.

Weibull is particularly effective when the data are censored, with exact failure times unknown or suspension of test.  Suspension of test is also referred to as right censored. SigmaXL can analyze complete or right censored data.

1. Open the file Weibull Dodson.xls.  This contains right censored time-to-failure data from Dodson, page 28.  

2. Click SigmaXL > Reliability/Weibull Analysis.  Ensure that the entire data table is selected.  Click Next.

3. Select Time-to-Fail, click Numeric Response (Y) >>.  Note that the selected variable must contain all positive values.  Select Censor Code, click Right Censor Column >>.  The default censor value of 1 will be used.  We will use the default method of estimation, Maximum Likelihood (some reliability practitioners prefer Least Squares Regression (X on Y) for small sample sizes).  Other defaults include Threshold = 0, and Confidence Level = 90%.  Enter time values to estimate survival probabilities as shown: 
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The resulting Weibull analysis report is shown:  
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5. The Hollander-Proschan test is used when there are right censored observations (see Dodson).  If the p-value is less than 0.05, this indicates significant lack of fit, so Weibull would not be an appropriate distribution.  Given the p-value of 0.9771, there is no lack-of-fit with this time-to-fail data.  This is confirmed in the Weibull probability plot with the data roughly following a straight line.

6. If the data is uncensored then the Anderson-Darling unadjusted test is used.

7. The shape parameter, also referred to as Beta, is the slope of the line on the Weibull probability plot.  The Weibull distribution can be used in a wide variety of situations and dependent on the value of Beta, is equal to or can approximate several other distributions. For example, if Beta = 1, the Weibull distribution is identical to the exponential distribution; if Beta = 2.5, the Weibull distribution approximates the lognormal distribution; and if Beta = 3.6, the Weibull distribution approximates the normal distribution.  Because of this flexibility, there are few observed failure rates that cannot be accurately modeled by the Weibull distribution.  Furthermore if Beta is < 1, the system is suffering from infant mortality failures; if Beta is  = 1, failures are random – they are occurring at a constant failure rate and are independent of time; if Beta is > 1, components are wearing out with age.
8. The scale parameter is the characteristic life.  This is the point at which we could expect 63.2% of the population under study to have failed.  The survival probability report shows that the survival probability at time 200 = 0.386.  The cumulative failure probability at 200 is 1 – 0.386 = 0.614.

9. The percentile report tells us that we can expect a 50% failure rate (one-half of the population will fail) at time = 179.73, i.e. the Median = 179.73.

10. The percentile report can also be used to determine control limits for non-normal data. The lower control limit is the 0.135 % value = 22.052; the center line is the 50% value = 179.73; the upper control limit is the 99.865 % value = 383.55. 
SigmaXL: Analyze Phase Tools
Part A – Stratification with Pareto

SigmaXL’s Pareto tool allows you to create Basic (Single) or Advanced (Multiple) Pareto Charts.  Advanced Pareto charts are particularly useful in the Analyze Phase because of the ease with which you can slice and dice (or stratify) your data.  Of course, Pareto charts are not limited to the Analyze Phase – they can also be used to aid project selection and to prioritize in the Measure Phase.

Consider the following guidelines to help ensure that your Pareto analysis is successful:

· Your Pareto analysis will only be as good as the quality of the data collected.  Ensure that you have the right data and that the data is correct.  Use other graphs such as run charts to apply a sanity check to your data. 

· Check process stability using appropriate control charts.  If the process is not in control, your prioritization of defects and root causes could be invalid. 

· Avoid collecting data over too short a time period.  Your data may not be representative of the process as a whole. Also keep in mind that since the data is discrete, a minimum sample size of 500 is recommended with 1000 preferred.
· Conversely, data gathered over too long a time period may include process changes that could lead to incorrect conclusions.  SigmaXL provides a date subsetting feature that allows you to easily explore different time periods. 

· If your initial Pareto analysis does not yield useful results, explore other categories that may be important.  SigmaXL’s Advanced Charts makes it easy for you to 'slice and dice' your data with different X categories. 

· Consider Pareto charting measures such as cost and severity, in addition to defect counts. SigmaXL enables you to chart multiple Y responses.

Basic Pareto Chart Template
Click SigmaXL > Templates and Calculators > Basic Graphical Templates > Pareto Chart or SigmaXL > Graphical Tools > Basic Graphical Templates > Pareto Chart.  See Measure Phase Part B – Templates and Calculators for a Pareto Template example.

Basic (Single) Pareto Charts

1. Open the file Customer Data.xls.  Click SigmaXL>Graphical Tools >Basic Pareto Chart.

2. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Major-Complaint , click Pareto Category (X) >>.  










Tip:  SigmaXL will automatically count the number of unique items in the Pareto Category. If we had a separate column with a count (or cost), this count column would be selected as the Optional Numeric Count (Y).
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Click Next.  Set Basic Chart Options as follows:
Tab “Other” Bar/Cum Sum:  

Cum Sum Line – On Top of First Bar







Tab Chart Options:

Category (X) Font – Slanted

Data Labels – Check Bars, Cum Sum

Check Save Defaults.








Tip:  After you have saved your defaults, you can bypass the above options, by clicking Finish instead of Next at the original Basic Pareto Chart dialog box.  The saved defaults will automatically be applied.
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Click Finish. The Pareto Chart is produced:
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Advanced (Multiple) Pareto Charts

1. Click Sheet1 Tab of Customer Data.xls (or press F4 to activate last worksheet).
2. Click SigmaXL > Graphical Tools > Advanced Pareto Options.
Note that the Sample Charts have nothing to do with the data set being evaluated.  They are used to dynamically illustrate how your options affect the charts to be produced.

3. Set Order of Bars to Same Order on the “Other Bar”/Cum Sum options tab.
This is typically used for comparative purposes.  The Descending Order option makes each Chart a true Pareto Chart, but is less useful for comparison.
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Click Chart Options tab.  Set according to choice – in this case we have selected Data Labels for the Bars but not for the Cum Sum line.


5. Ensure that Save Defaults is checked.  Note that these options will be saved and applied to all Advanced Pareto Charts.  Click Finish.

6. SigmaXL automatically takes you to the next step of Chart Generation (This is equivalent to clicking SigmaXL > Graphical Tools > Advanced Pareto Charts).  If necessary, check Use Entire Data Table.
7. Click Next.  
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Select Major Complaint, click Pareto Category (X1) >>; select Customer Type, click Group Category (X2) >>.
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Click OK.  A Pareto Chart of Major Customer Complaints is produced for each Customer Type.









10. Click Sheet 1 Tab, Click SigmaXL > Graphical Tools > Advanced Pareto Charts.

11. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.  (Steps 10 and 11 can be bypassed with the Recall SigmaXL Dialog menu or by pressing F3 to recall last dialog).
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Select Major Complaintt, click Pareto Category (X1) >>; select Size of Customer, click Group Category (X2) >>; select Product Type, click Group Category (X3) >>.










If a Numeric Count (Y) variable is not specified, SigmaXL automatically determines the counts from the Pareto Category (X1). 

Normally we would use a text column of discrete Xs, but be aware that numeric columns are also allowed.  Be careful here – this could easily generate a very large number of charts. 

The total number of charts generated = (# of levels in X2) * (# of levels in X3) * (# of levels in X4) * (# of Y variables).

13. Click OK.  Multiple Paretos are generated:
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Part B - EZ-Pivot 

One of the most powerful features in Excel is the Pivot table.  SigmaXL’s EZ-Pivot tool simplifies the creation of Pivot tables using the familiar X and Y dialog box found in the previous Pareto tools.

Example of Three X’s, No Response Y’s

1. Open Customer Data.xls, click Sheet 1 (or press F4 to activate last worksheet).  Select SigmaXL > Graphical Tools > EZ-Pivot/Pivot Charts.
2. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.

3. Select Major Complaint, click Count Category (X1) >>.  Note that if Y is not specified, the Pivot Table Data is based on a count of X1, hence the name Count Category.
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Select Customer Type, click Group Category (X2) >>; select Size of Customer, click Group Category (X3) >> as shown.
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Click OK.  Resulting Pivot Table of Major Complaint by Customer Type is shown:







6. This Pivot table shows the counts for each Major Complaint (X1), broken out by Customer Type (X2), for all Sizes of Customers (X3).  (Grand Totals can be added to the Pivot Table by using Pivot Table Toolbar > Table Options.  Check Grand Totals for Columns, Grand Totals for Rows).
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To display counts for a specific Customer Size, click the arrow adjacent to Size of Customer (All).  Select Large.
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Click OK.  Resulting Pivot Table is:







Note that the Major Complaint “Not-Available” is not shown.  Pivot table only show rows where there is at least a count of one.

9. The Pivot Chart can be seen by clicking the EZ Pivot Chart (1) tab; reset Size of Customer to All as shown below:
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Drag the Size of Customer button adjacent to the left of the Major Complaint button and Excel will automatically split the Pivot Chart showing both Large and Small Customers (Excel 2007/2010: Drag Size of Customer from Report Filter to Axis Fields).















Example of Three X’s and One Y

1. Select Sheet 1 of Customer Data.xls; click SigmaXL > Graphical Tools > EZ-Pivot/Pivot Charts; click Next (alternatively, click Recall SigmaXL Dialog menu or press F3 to recall last dialog).
2. Select Customer Type, click Group Category (X1) >>; select Size of Customer, click Group Category (X2) >>; select Product Type, click Group Category (X3); select Overall Satisfaction, click Numeric Responses (Y) >>.  Note that the Label for X1 changed from Count Category to Group Category.  The Pivot Table data will now be based on Y data.
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The Response default uses a Sum of Y.  This however can be changed to Average or Standard Deviation. Select Average.  Uncheck Create Pivot Charts (Since we are looking at averages, the stacked bar Pivot Charts would not be very useful, unless they are changed to clustered column format using Chart > Chart Type).
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Click OK.  The resulting Pivot Table is:






5. Note that the table now contains Averages of the Customer Satisfaction scores (Y).  Again Product Type (X3) can be varied to show Consumer, Manufacturer, or All.  Double clicking on Average of Overall Satisfaction allows you to switch to Standard Deviation (StdDev).

Example of 3 X’s and 3 Y’s

1. Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.
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Select Customer Type, click Group Category (X1) >>; select Size of Customer, click Group Category (X2) >>; select Product Type, click Group Category (X3) >>.  Select Avg Days Order to Delivery, Loyalty – Likely to Respond, Overall Satisfaction, click Numeric Responses (Y) >>. Select Average and One Pivot Table (default is separate Pivot Tables for each Y). Uncheck Create Pivot Charts.
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Click OK.  Resulting Pivot Table:









Again, Product Type (X3) can be varied.

Part C – Confidence Intervals

Confidence Interval Templates
Click SigmaXL > Templates and Calculators > Basic Statistical Templates > 
1 Sample t Confidence Interval for Mean or
1 Sample Confidence Interval for Standard Deviation or
1 Proportion Confidence Interval. 

These confidence interval templates are also located at SigmaXL > Statistical Tools > Basic Statistical Templates.
See Measure Phase Part B – Templates and Calculators for Confidence Interval template examples.
Confidence Intervals – Descriptive Statistics
1. Open Customer Data.xls.  Click Sheet 1 Tab (or press F4 to activate last worksheet).

2. Click SigmaXL > Statistical Tools > Descriptive Statistics.
3. Check Use Entire Data Table, click Next.
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Select Overall Satisfaction, click Numeric Data Variables (Y) >>.  Select Customer Type, click Group Category (X1) >>; Confidence Level default is 95%:
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Click OK.  Descriptive Statistics are given for Customer Satisfaction grouped by Customer Type:













We are given the 95% confidence interval for each sample Mean (95% CI Mean) as well as the 95% confidence interval for the Standard Deviation (95% CI Sigma – do not confuse this with Process Sigma Quality Level).
These confidence intervals are very important in understanding our data and making decisions from the data.  How often are we driven by sample estimates only and fail to consider the confidence interval or margin of error?  For example, newspapers will often fail to take into account the confidence interval when reporting opinion poll results.  (To calculate confidence intervals for discrete proportion data, use SigmaXL > Templates and Calculators > Basic Statistical Templates > 1 Proportion Confidence Interval).
Note that a confidence interval of 95% implies that, on average, the true population parameter (Mean, Median, Standard Deviation, or Proportion) will lie within the interval 19 times out of 20.
A confidence interval or margin of error does not take into account measurement error or survey bias, so the actual uncertainty may be greater than stated.  This should be addressed with good data collection, reliable measurement systems, and good survey design.
Confidence Intervals for the Mean can be obtained in several ways with SigmaXL:  Descriptive Statistics, Histograms & Descriptive Statistics, 1-Sample t-test & Confidence Intervals, One-Way ANOVA, and Multi-Vari Charts. 
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To illustrate confidence intervals for the mean of Overall Satisfaction graphically, we have generated a Multi-Vari Chart (with 95% CI Mean Options) using the Customer Data.xls data. This chart type will be covered later (Part P).


















The dots correspond to individual data points.  The tick marks show the 95% upper confidence limit, mean, and 95% lower confidence limit.  Clearly we can see that Customer Type 2 has a significantly higher level of mean satisfaction; the lower limit does not overlap with the upper limit for Types 1 and 3.  On the other hand, we see overlap of the CI’s when comparing types 1 and 3.  Hypothesis testing will now be used to compare the mean satisfaction scores more precisely and determine statistical significance for the results.

Part D – Hypothesis Testing – One Sample t-Test

Hypothesis Testing – One Sample t-Test

1. Open Customer Data.xls, select Sheet 1 tab (or press F4 to activate last worksheet).  Click SigmaXL > Statistical Tools > 1 Sample t-Test & Confidence Intervals.  If necessary, check Use Entire Data Table, click Next.

2. Ensure that Stacked Column Format is selected.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>, select Customer Type, click Optional Group Category (X) >>.

3. Historically, our average customer satisfaction score has been 3.5.  We would like to see if this has changed, with the results grouped by customer type.  Null Hypothesis H0: μ=3.5; Alternative Hypothesis Ha: μ≠3.5
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 Enter 3.5 for the Null Hypothesis H0: Mean value.  Keep Ha as Not Equal To.


















5. Click OK.  Results:
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6. Note the p-values.  Customer Type 2 shows a significant change (increase) in Satisfaction Mean (p-value < .05), whereas Customer Types 1 and 3 show no change (p-value ≥ .05).  Also note the confidence intervals around each mean match the results from Descriptive Statistics.

7. In the Measure Phase we determined that Overall Satisfaction for Customer Type 2 has non-normal data but this does not imply that the p-value for the 1 Sample t-test is wrong.  The Central Limit Theorem applies here:  the distribution of averages tends to be normal, even if the individual observations are not-normal.  With a sample size of 42, the t-test is fairly robust against skewed data.

Part E – Power and Sample Size

Power and Sample Size – One Sample t-Test – Customer Data
Using the One Sample t-Test, we determined that Customer Types 1 and 3 resulted in “Fail to reject  H0: μ=3.5”.  A failure to reject H0 does not mean that we have proven the null to be true.  The question that we want to consider here is “What was the power of the test?”  Restated, “What was the likelihood that given Ha: μ≠3.5 was true, we would have rejected H0 and accepted Ha?”  To answer this, we will use the Power and Sample Size Calculator.

1. Click SigmaXL > Statistical Tools > Power and Sample Size Calculators > 1 Sample t-Test Calculator.  We will only consider the statistics from Customer Type 3 here.  We will treat the problem as a two sided test with Ha: Not Equal To  to be consistent with the original test.  
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Enter 27 in Sample Size (N).  The difference to be detected in this case would be the difference between the sample mean and the hypothesized value i.e. 3.6411 – 3.5 = 0.1411.  Enter 0.1411 in Difference.  Leave Power value blank, with Solve For Power selected (default).  Given any two values of Power, Sample size, and Difference, SigmaXL will solve for the remaining selected third value.  Enter the sample standard deviation value of 0.6405 in Standard Deviation.  Keep Alpha and Ha at the default values as shown:
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Click OK.  The resulting report is shown:








4. A power value of 0.1968 is very poor.  It is the probability of detecting the specified difference.  Alternatively, the associated Beta risk is 1-0.1968 = 0.8032 which is the probability of failure to detect such a difference.  Typically, we would like to see Power > 0.9 or Beta < 0.1.  In order to detect a difference this small we would need to increase the sample size.  We could also set the difference to be detected as a larger value.
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First we will determine what sample size would be required in order to obtain a Power value of 0.9.  Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.  Select the Solve For Sample Size button as shown.  It is not necessary to delete the entered sample size of 27 – it will be ignored.  Enter a Power Value of .9:








 





6. Click OK.  The resulting report is shown:
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7. A sample size of 219 would be required to obtain a power value of 0.9.  The actual power is rarely the same as the desired power due to the restriction that the sample size must be an integer.  The actual power will always be greater than or equal to the desired power.
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Now we will determine what the difference would have to be to obtain a Power value of 0.9, given the original sample size of 27.  Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.  Select the Solve For Difference button as shown:
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Click OK.  The resulting report is shown:







10. A difference of 0.415 would be required to obtain a Power value of 0.9, given the sample size of 27.

Power and Sample Size – One Sample t-Test – Graphing the Relationships between Power, Sample Size, and Difference

In order to provide a graphical view of the relationship between Power, Sample Size, and Difference, SigmaXL provides a tool called Power and Sample Size with Worksheets.  Similar to the Calculators, Power and Sample Size with Worksheets allows you to solve for Power (1 – Beta), Sample Size, or Difference (specify two, solve for the third).  You must have a worksheet with Power, Sample Size, or Difference values.  Other inputs such as Standard Deviation and Alpha can be included in the worksheet or manually entered.
1. Open the file Sample Size and Difference Worksheet.xls, select the Sample Size & Diff sheet tab. Click SigmaXL > Statistical Tools > Power & Sample Size with Worksheets > 1 Sample t-Test.  If necessary, check Use Entire Data Table.  Click Next. 
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Ensure that Solve For Power (1 – Beta) is selected.  Select Sample Size (N) and Difference columns as shown.  Enter the Standard Deviation value of 1.  Enter .05 as the Significance Level value:















3. Click OK.  The output report is shown below:
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To create a graph showing the relationship between Power, Sample Size and Difference, click SigmaXL > Statistical Tools > Power & Sample Size Chart.  Check Use Entire Data Table.  Click Next.
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Select Power (1 – Beta), click Y Axis (Y); select Sample Size (N), click X Axis (X1); select Difference, click Group Category (X2).  Click Add Title.  Enter Power & Sample Size: 1 Sample t-Test:
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Click OK.  The resulting Power & Sample Size Chart is displayed:











Part F – One Sample Nonparametric Tests

Introduction to Nonparametric Tests
Nonparametric tests make fewer assumptions about the distribution of the data compared to parametric tests like the t-Test.  Nonparametric tests do not rely on the estimation of parameters such as the mean or the standard deviation.  They are sometimes called distribution-free tests.

Nonparametric tests use Medians and Ranks, thus they are robust to outliers in the data.  If, however, the data are normal and free of outliers, nonparametric tests are less powerful than normal based tests to detect a real difference when one exists.
Nonparametric tests should be used when the data are non-normal, data cannot be readily transformed to normality, and sample size is small (n < 30).  If the sample sizes are large, the Central Limit Theorem says that parametric tests are robust to non-normality.

One Sample Sign Test

The sign test is the simplest of the nonparametric tests, and is similar to testing if a two-sided coin is fair.  Count the number of positive values (larger than hypothesized median), the number of negative values (smaller than the hypothesized median), and test whether there are significantly more positives (or negatives) than expected.  The One Sample Sign Test is a nonparametric equivalent to the parametric One Sample t-Test.
Historically, our Median customer satisfaction score has been 3.5.  We would like to see if this has changed, with the results grouped by customer type  (H0: Median=3.5, Ha: Median≠3.5, α = 0.05).
1. Open Customer Data.xls, select Sheet 1 tab.  Click SigmaXL > Statistical Tools > Nonparametric Tests>1 Sample Sign.  If necessary, check Use Entire Data Table, click Next.

2. Ensure that Stacked Column Format is selected.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Optional Group Category (X) >>.

3. Enter 3.5 for the Null Hypothesis H0: Median value.  Set Ha as Not Equal To.  
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Click OK.  Results:










5. Note the p-values.  Customer Type 2 shows a significant change (increase) in Satisfaction Median (p-value < .05), whereas Customer Types 1 and 3 show no change (p-value ≥ .05).  While the p-values are not the same as those given by the 1 sample t-Test, the conclusions do match. we discussed that requires a nonparametric test.

One Sample Wilcoxon Signed Rank Test

The Wilcoxon Signed Rank test is a more powerful nonparametric test than the Sign Test, but it adds an assumption that the distribution of values is symmetric around the median.  An example of a symmetric distribution is the uniform distribution.  Symmetry can be observed with a histogram, or by checking to see if the median and mean are approximately equal.

The One Sample Wilcoxon Test is a nonparametric equivalent to the parametric One Sample t-Test.

Historically, our Median customer satisfaction score has been 3.5.  We would like to see if this has changed, with the results grouped by customer type (H0: Median=3.5, Ha: Median≠3.5, α = 0.05).

1. Open Customer Data.xls, select Sheet 1 tab (or press F4 to activate last worksheet).  Click SigmaXL > Statistical Tools > Nonparametric Tests > 1 Sample Wilcoxon.  If necessary, check Use Entire Data Table, click Next.

2. Ensure that Stacked Column Format is selected.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Optional Group Category (X) >>.
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Enter 3.5 for the Null Hypothesis H0:Median value.  Keep Ha as Not Equal To.
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Click OK.  Results:









Note the p-values. Customer Type 2 shows a significant change (increase) in Satisfaction Median (p-value < .05), whereas Customer Types 1 and 3 show no change (p-value ≥ .05).  Although the p-values are not identical to the sign test and t-Test, the conclusions match.  (Note, in the case of Customer Type 2, the Sign Test is preferred since the data is not symmetrical but skewed).
Part G – Two Sample t-Test

Two Sample t-Test Templates
Click SigmaXL > Templates and Calculators > Basic Statistical Templates > 
2 Sample t-Test (Assume Equal Variances) or
2 Sample t-Test (Assume Unequal Variances). 

These confidence interval templates are also located at SigmaXL > Statistical Tools > Basic Statistical Templates.
See Measure Phase Part B – Templates and Calculators for Two Sample t-Test template examples.

Two Sample t-Test

1. Open Customer Data.xls, click Sheet 1 tab (or press F4 to activate last worksheet).  We will look at comparing means of Customer Satisfaction by Customer Type ( 2 vs. 3), using the Two Sample t-test.  H0: μ2=μ3, Ha: μ2≠μ3

2. Click SigmaXL > Statistical Tools > 2 Sample t-test.  If necessary, check Use Entire Data Table, click Next.
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With stacked column format checked, select Overall Satisfaction, click Numeric Data Variable Y >>; select Customer Type, click Group Category X >>; H0: Mean Diff = 0; Ha:  Not Equal To; Confidence Level:  95%; ensure that Assume Equal Variances is checked:
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Click OK.  Select Customer Type 2 and 3.








5. Click OK.  Resulting output:
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Given the p-value of .0007 we reject H0 and conclude that Mean Customer Satisfaction is significantly different between Customer type 2 and 3.  This confirms previous findings.

Paired t-Test

1. Open the file Dietcola.xls.  These are the results of a Before and After taste test on sweetness for diet cola.  Ten tasters were used and one month elapsed with the cola in warm storage between the before and after results.  Do a one sample t-test on the column of differences.
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Click SigmaXL > Statistical Tools > 1-Sample t-test & Confidence Intervals.  Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.  Select Difference, click Numeric Data Variable (Y) >>, set H0: Mean μ= 0, Ha:  Less Than (this is a one-sided or one-tail test – sweetness cannot increase):
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Click OK.  Result:











Given the p-value of .012, we reject H0 and conclude that the sweetness has in fact decreased.
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Now redo the analysis using the paired t-test:  Click Sheet 1 Tab; Click SigmaXL > Statistical Tools > Paired t-Test; Click Next; Select After, click Numeric Data Variable 1 >>, select Before as Numeric Data Variable 2 >>, H0: Mean Diff = 0, Ha:  Less Than.
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Click OK.  Results are identical to the One sample t-test analysis of difference column:











Unpaired 2 Sample t-Test vs. Paired t-Test

1. Open the Dietcola.xls file, click the Sheet 1 tab (or press F4 to activate last worksheet).
2. Click SigmaXL > Statistical Tools > 2 Sample t-test.  Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Check Unstacked Column Format.  Select After, Before and click Numeric Data Variables (Y) >>.  H0: Mean Diff = 0, Ha:  Less Than; check Assume Equal Variances:
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Click OK.  Results:
 












Now the p-value is .07, indicating a fail to reject H0.  What changed?  Hint:  Compare the SE Mean of the Paired t-test to the Std Error Difference of the unpaired two-sample t-test.  Where does the additional variability come from in the two-sample t-test?  The paired t-test is the appropriate test to use here.
Power & Sample Size for 2 Sample T-Test

To determine Power & Sample Size for a 2 Sample t-Test, you can use the Power & Sample Size Calculator or Power & Sample Size with Worksheet.  

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > 2 Sample t-Test Calculator. 
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Select Solve For Power (1 – Beta).  Enter Sample Size and Difference as shown:













Note that we are calculating the power or likelihood of detection given that Mean1 – Mean2 = 1, with sample size for each group = 30, standard deviation = 1, significance level = .05, and Ha: Not Equal To (two-sided test).
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Click OK.  The resulting report is displayed:







A power value of 0.97 is good, hence we have the basis for the “minimum sample size n=30” rule of thumb used for continuous data.

4. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > Power & Sample Size with Worksheet > 2 Sample t-Test.

5. A graph showing the relationship between Power, Sample Size and Difference can then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart. See Part E for an example using the 1 Sample t-Test.
Part H – Two Sample Comparison Test

We will now do a full comparison test of Customer Satisfaction for Customer Type 1 and 2.  This test checks each sample for normality, equal variance (F-test and Levene’s), 2 sample t-test (assuming equal and unequal variance), and Mann Whitney test for equal Medians.  Depending on the normality, variance, and sample size results, the appropriate p-values are highlighted in yellow.

Two Sample Comparison Test

1. Open Customer Data.xls, click on Sheet 1 Tab.
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Click SigmaXL > Statistical Tools > 2 Sample Comparison Tests.  Click Next.  Check Stacked Column Format.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>, select Customer Type, click Group Category (X) >>.
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Click OK.  Select Customer Type 1 and 2.
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Click OK.

























Customer Type 2 has non-normal data.  This makes Levene’s test the appropriate test for unequal variance.  Levene’s test indicates that Customer type 2 has a significantly lower variance, or standard deviation.  The lower standard deviation translates to a consistent level of satisfaction.  
Since Levene’s test indicates unequal variance, the appropriate t-test assumes unequal variance. The t-test indicates that Customer Type 2 has a significantly higher mean satisfaction.

Clearly the next step would be to determine a root cause or best practices to reduce the variability in overall satisfaction and increase the mean for all customer types.
Two Sample F-Test Template
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Click SigmaXL > Templates and Calculators > Basic Statistical Templates > 
2 Sample F-Test (Compare 2 StDevs) or SigmaXL > Statistical Tools > Basic Statistical Templates > 2 Sample F-Test (Compare 2 StDevs) to access the 2 Sample F-Test calculator. The template gives the following default example.











Part I – Two Sample Nonparametric Test: 
Mann-Whitney

Two Sample Mann-Whitney Rank Test

We will look at comparing medians of Customer Satisfaction by Customer Type, using the Two Sample Mann-Whitney Rank test.  (H0: Median2 = Median3, Ha: Median2 ≠ Median3.)  The Two Sample Mann-Whitney Test is the nonparametric equivalent to the parametric Two Sample t-Test.
1. Open Customer Data.xls, click Sheet 1 tab (or press F4 to activate last worksheet).

2. Click SigmaXL > Statistical Tools > Nonparametric Tests > 2 Sample Mann-Whitney.  If necessary, check Use Entire Data Table, click Next.
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With Stacked Column Format checked, select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X) >>;  and Ha:  Not Equal To:










4. [image: image263.png]Nonparametric Runs Test: Oscillation
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Click OK.  Select Customer Type 2 and 3.
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Click OK.  Resulting output:









Given the p-value of .0008 we reject H0 and conclude that Median Customer Satisfaction is significantly different between Customer types 2 and 3.  This confirms previous findings and matches the results of the 2 Sample t-Test.

Part J – One-Way ANOVA & Means Matrix
One-Way ANOVA & Means Matrix

1. One-Way ANOVA and Means Matrix allows you to quickly do multiple pairwise comparisons.  The One-Way ANOVA tests H0: μ1 = μ2 = μ3; Ha: at least one pairwise set of means are not equal.

2. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet).
3. Click SigmaXL > Statistical Tools > One-Way ANOVA & Means Matrix.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 
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Click Next.  Ensure that Stacked Column Format is checked.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X) >>.











5. Click OK.  The results are shown below:
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The ANOVA p-value of 0.0000 tells us that at least one pairwise set of means are not equal. From the means matrix, we conclude that Mean Overall Satisfaction is significantly different between Customer Type 2 and 3, as well as 1 and 2.
7. A graphical view of the Overall Satisfaction Mean and 95% Confidence Intervals are given to complement the Means Matrix.  The fact that the CI’s for Customer Type 2 do not overlap those of Type 1 or 3, clearly shows that Customer Type 2 has a significantly higher mean satisfaction score.  The overlap of CI’s for Type 1 and 3 shows that the mean satisfaction scores for 1 and 3 are not significantly different.
8. The R-Square (R-Sq) value of 20.95% indicates that Customer type “explains” approximately 21% of the variation in Overall Satisfaction.  We need to “drill down” to understand the root causes and best practices associated with Customer Type 2.
9. Note that the p-value for 2-3 is slightly different than the previous two sample test result because the variances from all 3 customer types are “pooled” here.  This also results in slightly different confidence intervals.  One-Way ANOVA & Means Matrix assume equal variance, but analysis above in Part H indicates that this assumption is not true, so this analysis should be treated with caution.  An alternative nonparametric test is the Kruskal-Wallis test for Medians (SigmaXL > Statistical Tools > Nonparametric Tests > Kruskal-Wallis Median Test) or Mood’s Median (SigmaXL > Statistical Tools > Nonparametric Tests > Mood’s Median Test).  These are discussed in Part M.

Note also that the means matrix p-values could easily trigger type I errors when the number of X levels gets large.  You should only consider the results of the Means Matrix if the ANOVA p-value is < .05.















Power & Sample Size for One-Way ANOVA

To determine Power & Sample Size for a One-Way ANOVA, you can use the Power & Sample Size Calculator or Power & Sample Size with Worksheet.  

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > One-Way ANOVA Calculator. 
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Select Solve For Power (1 – Beta).  Enter Sample Size and Maximum Difference as shown:
















Note that we are calculating the power or likelihood of detection given that the maximum difference between group means = 1, with sample size for each group = 30, 3 groups, standard deviation = 1, significance level = .05, and Ha: Not Equal To (two sided test).
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Click OK.  The resulting report is displayed: 







A power value of 0.94 is acceptable.  Note that this value is less than the power value of 0.97 obtained with the two-sample t-Test.  

4. Press F3 or click Recall SigmaXL Dialog to recall last dialog.  Change the number of groups to 4.  Note that the power value is 0.907.  If the number of groups (levels) increases, you will have to increase the sample size in order to maintain statistical power.

5. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > Power & Sample Size with Worksheet > One-Way ANOVA.

6. A graph showing the relationship between Power, Sample Size and Maximum Difference can then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart.  See Part E for an example using the 1 Sample t-Test.

Part K – Two-Way ANOVA

Two-Way ANOVA

Two-Way ANOVA tests the following:

H0 (Factor X1): μ1 = μ2 = …= μk
Ha (Factor X1): at least one pairwise set of means are not equal (μi ≠ μj);

H0 (Factor X2): μ1 = μ2 = …= μk
Ha (Factor X2): at least one pairwise set of means are not equal (μi ≠ μj);

H0 (Interaction): There is no interaction between factors X1 and X2
Ha (Interaction): There is an interaction between factors X1 and X2.


Typically a Two-Way ANOVA analysis requires that you have balanced data, with an equal number of observations for each combination level of X1 and X2. In practice, this is often not the case and it is therefore not possible to perform a Two-Way ANOVA test.  SigmaXL, however, accommodates unbalanced data. The minimum requirement is one observation per combination level of X1 and X2.  An error message will be produced if this minimum requirement is not met.
1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet).
2. Click SigmaXL > Statistical Tools > Two-Way ANOVA.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 

3. Click Next.  Select Avg No of Orders per Mo, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category Factor (X1) >>; select Size of Customer, click Group Category Factor (X2) >>.  Remove Interaction (Fit Additive Model) should remain unchecked. 

Tip: If the Two-Way ANOVA report gives a p-value for the interaction that is high (> 0.1), you should then press F3 or click Recall SigmaXL Dialog to recall this dialog, check Remove Interaction (Fit Additive Model) and rerun the analysis.
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Click OK.  The results are shown below:
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Scroll down to view the Main Effects (with confidence intervals) and Interaction Plots:
















Note that the mean values shown are fitted (predicted) means not data means.  
6. From the ANOVA table, we can see that the Size of Customer term is significant with a p-value less than .05.  Customer Type is not significant by itself, but the Interaction term is significant.  This indicates that the effect of Size of Customer on Average Number of Orders per Month depends on Customer Type (we could also equivalently say that the effect of Customer Type depends on Size of Customer).
7. This is also confirmed looking at the Main Effects and Interaction plots.  Customer Type by itself is not significant.  Size of Customer is obviously significant.  Looking at the Interaction plot, the different slopes illustrate that the change in Average Number of Orders per Month across Customer Types depends on Customer Size. This interaction effect is particularly evident for Customer Types 2 and 3.
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Click the Two-Way Residuals sheet to view the residual graphs:







Residuals are the unexplained variation from the ANOVA model (Actual – Predicted/Fitted values).  We expect to see the residuals approximately normally distributed with no obvious patterns in the above graphs, which is the case here.

The Residuals versus Size of Customer graph is not shown because Size of Customer is text.  In order to display this plot, Size could be coded numerically with 1 = Small and 2 = Large.  Simply create a new column called Size-Coded and use the following Excel formula to create the coded values for the first record:

=IF(K2="Small",1,IF(K2="Large",2))

Copy and Paste this formula to obtain coded values for all 100 records.  Rerun the Two-Way ANOVA analysis to create the residual graphs 
Part L – Tests for Equal Variance & 
Welch’s ANOVA

Bartlett’s Test

Bartlett’s Test is similar to the 2 sample F-Test (SigmaXL > Statistical Tools > 2 Sample Comparison Test) but allows for multiple group comparison of variances (or standard deviations).  Like the F-Test, Bartlett’s requires that the data from each group be normally distributed but is more powerful than Levene’s Test.
1. Open Delivery Times.xls, click on Sheet 1 tab.
2. Click SigmaXL > Statistical Tools > Equal Variance Tests > Bartlett.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 
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Click Next.  Ensure that Stacked Column Format is checked.  Select Delivery Time Deviation, click Numeric Data Variable (Y) >>; select Floor, click Group Category (X) >>.
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Click OK.  The results are shown below:







5. With the p-value = 0.63 we fail to reject H0; we do not have evidence to show that the group variances are unequal (practically speaking we will assume that the variances are equal).

6. All 10 Anderson-Darling Test P-values are > .05 indicating that all group data are normal.  Since the assumption of normality is met, Bartlett’s is the appropriate test to use.  If any one of the groups have a low p-value for the Normality test, then Levene’s test should be used.

Levene’s Test

Levene’s Test for multiple group comparison of variances is less powerful that Bartlett’s Test, but is robust to the assumption of normality.  (This is a modification of the original Levene’s Test, sometimes referred to as the Browne-Forsythe Test). 

1. Open Customer Data.xls, click on Sheet 1 tab.
2. Click SigmaXL > Statistical Tools > Equal Variance Tests > Levene.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 
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Click Next.  Ensure that Stacked Column Format is checked.  Select Responsive to Calls, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X) >>.











4. Click OK.  The results are shown below:


















[image: image278.png]Power and Sample Size: 2 Proportions Test Calculator

Solve For

Power (1-Beta)

Sample Size (N) for Each Group

Proportion 1.(P1)

Proportion 2 (P2)

icance Level (alpha) 005

i NotEqual To v





5. [image: image279.png]Power and Sample Size: 2 Proportions Test

Ho: P1- P2
Ha: P12P2
Solve For: Power (1 - Beta)

[Sample Size (N) [Proportion 1 (P1) [Proportion 2 (P2) [Significance Level (Alpha) [Power (1 - Beta)

300 06 05 0.05 0693021232




The Levene’s Test p-value of 0.0144 tells us that we reject H0.  At least one pairwise set of variances are not equal.  The normality test p-values indicate that all 3 groups have non-normal data (p-values < .05).  Since Levene’s Test is robust to the assumption of normality, it is the correct test for equal variances (rather than Bartlett’s Test).

6. Now that we have determined that the variances (and standard deviations) are not equal, we are presented with a problem if we want to apply classical One-Way ANOVA to test for equal group means.  ANOVA assumes that the group variances are equal.  A modified ANOVA called Welch’s ANOVA can be used as an alternative here.

Welch’s ANOVA Test

Welch’s ANOVA is a test for multiple comparison of means.  It is a modified One-Way ANOVA that is robust to the assumption of equal variances.  Welch’s ANOVA is an extension of the 2 sample t-test for means, assuming unequal variance (SigmaXL > Statistical Tools > 2 Sample Comparison Tests).  Nonparametric methods could also be used here but they are not as powerful as Welch’s ANOVA.

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet).
2. Click SigmaXL > Statistical Tools > Equal Variance Tests > Welch’s ANOVA.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 
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Click Next.  Ensure that Stacked Column Format is checked.  Select Responsive to Calls, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X) >>.
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Click OK.  The results are shown below:
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5. The p-value for Welch’s ANOVA is 0.0135, therefore we reject H0 and conclude that the group means for Responsive to Calls are not equal.  We will explore the relationship between Overall Satisfaction and Responsive to Calls later.
Part M – Nonparametric Multiple Comparison

Kruskal-Wallis Test

The Kruskal-Wallis test is an extension of the Mann-Whitney Rank test, allowing for more than 2 samples.  It is a nonparametric equivalent to the parametric One-Way ANOVA.  The Null Hypothesis is:  H0: Median1 = Median2 = … = MedianK.  Ha: At least two Medians are different.

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet).
2. Click SigmaXL > Statistical Tools > Nonparametric Tests > Kruskal-Wallis Median Test.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 
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Click Next.  Ensure that Stacked Column Format is checked.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X) >>.










4. Click OK.  The results are shown below: 






































The p-value of 0.0000 tells us that we reject H0.  At least one pairwise set of medians are not equal.
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The Kruskal-Wallis Statistic is based on comparing mean ranks for each group versus the mean rank for all observations.  The Z value for Customer Type 3 is , the smallest absolute Z-value.  This size indicates that the mean rank for Type 3 differed least from the mean rank for all observations.  The Z value for Customer Type 2 is 4.53, the largest absolute Z-value.  This size indicates that the mean rank differed most from the mean rank for all observations.
6. A graphical view of the Overall Satisfaction Median and 95% Confidence Intervals are given to complement the Z scores.  The fact that the CI’s for Customer Type 2 do not overlap those of Type 1 or 3, clearly shows that Customer Type 2 has a significantly higher median satisfaction score.  The overlap of CI’s for Type 1 and 3 shows that the median satisfaction scores for 1 and 3 are not significantly different.

Mood’s Median Test

Mood’s Median Test is an extension of the One Sample Sign Test, using Chi-Square as the test statistic.  Like the Kruskal-Wallis test, Mood's median test can be used to test the equality of medians from multiple samples.  It provides a nonparametric alternative to the one-way analysis of variance.  The Null Hypothesis is:  H0: Median1 = Median2 = … = MedianK.  Ha: At least two Medians are different.
Mood's median test is more robust to outliers than the Kruskal-Wallis test, but is less powerful in the absence of outliers.  You should first look at your data with Boxplots.  If there are extreme outliers, then Mood’s Median should be used rather than Kruskal-Wallis.

1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet).
2. Click SigmaXL > Statistical Tools > Nonparametric Tests > Mood’s Median Test.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table. 
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Click Next.  Ensure that Stacked Column Format is checked.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>; select Customer Type, click Group Category (X) >>.










4. Click OK.  The results are shown below:
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The p-value of 0.0012 tells us that we reject H0.  At least one pairwise set of medians are not equal.
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A graphical view of the Overall Satisfaction Median and 95% Confidence Intervals are given. This is the same graph provided in the Kruskal-Wallis test report.

Part N – Nonparametric Runs Test
Nonparametric Runs Test for Randomness
The nonparametric runs test provides a test for randomness or independence.  The null hypothesis is H0:  The data is random (or independent).  The alternative hypothesis is Ha:  The data is not random (or independent).  Note that this test is also provided as an option in Run Charts (SigmaXL > Graphical Tools > Run Chart).  In addition to providing an overall test for randomness, 4 tests are performed to detect Clustering, Mixtures, Trends, and Oscillations.  If any of these patterns are significant (typically using α = 0.01), we would need to take corrective action before proceeding with further statistical analysis.  (Note that SigmaXL will highlight any p-values < .05 in red.)
1. Open Customer Data.xls, click on Sheet 1 tab (or press F4 to activate last worksheet).
2. Click SigmaXL > Statistical Tools > Nonparametric Tests > Runs Test.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table.
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Click Next.  Select Overall Satisfaction, click Numeric Data Variable (Y) >>:











4. Click OK.  The resulting report is shown:
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With all of the p-values being greater than 0.01, we fail to reject H0, and conclude that the data is random (or statistically independent).  Recall from the run chart of this data that there were no obvious trends or patterns. 
6. Examples of Clustering, Mixtures, Trends, and Oscillations are given below using the Run Chart to illustrate.  The data for these examples are given in the file Runs Test Example Data.xls.  (Use SigmaXL > Graphical Tools > Run Charts to create the run charts).
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Clustering appears as a group of points in one area of the chart.  It may indicate special cause variation such as sampling or measurement problems.
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Mixtures appear as an absence of data points near the center line.  A mixture may indicate a bimodal distribution due to a regular change of shift, machinery, or raw materials.



















Note that the p-value for Mixtures = 1 – p-value for Clustering.  They are mutually exclusive.  The p-value for Lack of Randomness = 2 * minimum of (p-value Clustering, p-value Mixtures). 
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[image: image298.emf]Histogram of Standardized Residuals  for: Overall Satisfaction
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Trends appear as an upward or downward drift in the data and may be due to special causes such as tool wear.
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Oscillations appear as rapid up/down fluctuations indicating process instability. 




















Note that the p-value for Trends = 1 – p-value for Oscillation. They are mutually exclusive.
Part O – Attribute/Discrete Data Tests

1 Proportion Confidence Interval Template
Click SigmaXL > Templates and Calculators > Basic Statistical Templates > 
1 Proportion Confidence Interval or SigmaXL > Statistical Tools > Basic Statistical Templates > 1 Proportion Confidence Interval.
See Measure Phase Part B – Templates and Calculators for an example of the 1-Proportion Confidence Interval template.
2 Proportions Test & Fisher’s Exact Template
1. We begin with a scenario where Day Shift is running at 80% Yield and Night Shift has 70% Yield.  This data is based on a random sample of 100 units for each Shift, each unit is either good or bad.  Question:  Is Day Shift running differently than Night Shift?  Statistically, we call the Null Hypothesis, H0:  Proportion P1 = Proportion P2; the alternative hypothesis, Ha is:  P1≠P2.  If the calculated p-value < .05, then we reject the null hypothesis and conclude that Day Shift and Night Shift are different. 

2. Click SigmaXL > Templates & Calculators > Basic Statistical Templates > 2 Proportions Test & Fisher’s Exact.
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Enter x1 = 80, n1 = 100, x2 = 70, n2 = 100 as shown:











Since the Fisher’s exact p-value of 0.141 is greater than .05, we fail to reject H0.  We do not have enough evidence to show that there is a significant difference between Day Shift and Night shift. This does not mean that we have proven that they are the same.  In practice however, we either assume that they are the same or we collect more data.

Note: Fisher’s exact p-values should be used for any real world problem.  The approximate p-values based on the normal distribution are provided for instructional purposes, e.g., comparing to hand calculations.
4. Now enter x1 = 160, n1 = 200, x2 = 140, n2 = 200.  Note that the Fisher’s exact p-value is now .028, so we reject H0.

Chi-Square Test – Two-Way Table Data
1. Open the file Attribute Data.xls, ensure that Example 1 Sheet is active.  This data is in Two –Way Table format, or pivot table format.  Note that cells B2:D4 have been pre-selected.

2. Click SigmaXL > Statistical Tools > Chi-Square Test – Two-Way Table Data.  Note the selection of data includes the Row and Column labels (if we had Row and Column Totals these would NOT be selected).

3. Click Next.  Results:
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The p-value matches that of the 2 proportion test.  Since the p-value of 0.1 is greater than .05, we fail to reject H0.  
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Now click Example 2 Sheet tab.  The Yields have not changed but we have doubled the sample size.  Repeat the above analysis.  The resulting output is:











Since the p-value is < .05,  we now reject the Null Hypothesis, and conclude that Day Shift and Night Shift are significantly different.  The Residuals tell us that Day Shift failures are less than expected (assuming equal proportions), and Night Shift failures are more than expected.

Note, by doubling the sample size, we improved the power or sensitivity of the test.
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Click the Example 3 Sheet tab.  In this scenario we have 3 suppliers, and an additional marginal level.  A random sample of 100 units per supplier is tested.  The null hypothesis here is:  No relationship between Suppliers and Pass/Fail/Marginal rates, but in this case we can state it as No difference across suppliers.  Redoing the above analysis (for selection B2:E5) yields the following:












The p-value tells us that we do not have enough evidence to show that there is a difference across the 3 suppliers. 
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Click the Example 4 Sheet tab.  Here we have doubled the sample size to 200 per supplier. Note that the percentages are identical to example 3.  Redoing the above analysis yields the following:
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With the p-value < .05 we now conclude that there is a significant difference across suppliers.  Examining the residuals tells us that Supplier A has fewer failures than expected (if there was no difference across suppliers) and Supplier C has more failures than expected.  Supplier B has more marginal parts than expected and Supplier C has fewer marginal parts than expected. 
Chi-Square Test (Stacked Column Format Data)
1. Open Customer Data.xls.  Click Sheet 1 tab.  The discrete data of interest is Complaints and Customer Type, i.e., does the type of complaint differ across customer type?  Formally the Null Hypothesis is that there is no relationship (or independence) between Customer Type and Complaints.
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Click SigmaXL > Statistical Tools > Chi-Square Test.  Select Major-Complaint, click Count Category (X1) >>; select Customer Type, click Group Category (X2) >>. 
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Click OK.  Results:


















With the p-value = 0.142 we fail to reject H0, so we do not have enough evidence to show a difference in customer complaints across customer types.

Note:  If more than 20% of Fitted Cells are Sparse - cells whose expected value is less than 5 – consider collecting more data, consolidation of levels, or removal of columns. 

Tip:  Use Chi-Square Analysis to complement Advanced Pareto Analysis.
Power & Sample Size for One Proportion Test

To determine Power & Sample Size for a 1 Proportion Test, you can use the Power & Sample Size Calculator or Power & Sample Size with Worksheet.  

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > 1 Proportion Test Calculator.
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Select Solve For Power (1 – Beta).  Enter Sample Size and Alternative Proportion as shown:
















Note that we are calculating the power or likelihood of detection given that the hypothesized proportion is 0.5, but the alternative proportion is 0.6, sample size = 300, significance level = .05, and Ha:  Not Equal To (two sided test).
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Click OK.  The resulting report is displayed:






A power value of 0.94 is acceptable, but note that the sample size n = 300, and the difference in proportion value is 0.1 or 10%!  The sample size requirements for discrete data are much higher than those for continuous data.

4. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > Power & Sample Size with Worksheet > 1 Proportion Test.

5. A graph showing the relationship between Power, Sample Size and Proportion Value can then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart.  See Part E for an example using the 1 Sample t-Test.

Power & Sample Size for Two Proportions Test

To determine Power & Sample Size for a 2 Proportions Test, you can use the Power & Sample Size Calculator or Power & Sample Size with Worksheet.  

1. Click SigmaXL > Statistical Tools > Power & Sample Size Calculators > 2 Proportions Test Calculator.
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Select Solve For Power (1 – Beta).  Enter Sample Size and  Proportion 1 values as shown:
















Note that we are calculating the power or likelihood of detection given that P1 = 0.5 and P2 = 0.6, sample size for each group = 300, significance level = .05, and Ha: Not Equal To (two sided test).

3. [image: image325.png]


Click OK.  The resulting report is displayed:






A power value of 0.69 is unacceptable.  Note that this value is much less than the power for the one proportion test (0.94).  

4. To compensate, we will double the sample size per group.  Press F3  or click Recall SigmaXL Dialog to recall last dialog.  Change the sample size per group from 300 to 600. Note that the power value is now 0.94.

5. To determine Power & Sample Size using a Worksheet, click SigmaXL > Statistical Tools > Power & Sample Size with Worksheet > 2 Proportions Test.

6. A graph showing the relationship between Power, Sample Size and Proportion Values can then be created using SigmaXL > Statistical Tools > Power & Sample Size Chart.  See Part E for an example using the 1 Sample t-Test.

Part P – Multi-Vari Charts

Multi-Vari Charts

The Multi-Vari chart is a powerful tool to identify dominant Sources of Variation (SOV).  The three major “families” of variation are:  Within Unit, Between Unit, and Temporal (Over Time).  We will look at examples of each type of SOV and then use the Multi-Vari Chart to study Overall Satisfaction in the Customer Data.xls file.
1. Open Multi-Vari Data.xls, click Sheet Within.  Select SigmaXL > Graphical Tools > Multi-Vari Options.
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The charts shown will be updated as options are selected.  Note that they are for demonstration purposes and are not based on the Multi-Vari Data.xls data.  Ensure that all general Options are selected (Range Line, Individual Data Points, Min and Max, Standard Deviation Chart).  Select Mean Options, ensure that Show Means, Connect Means, and Group Means are checked.  Ensure that Save Defaults is checked.  These settings would be typical for a Multi-Vari chart.  (The Median options provide the ability to display percentiles as an alternative to the Means).









Tip:  Multi-Vari Charts can be used to display Confidence Intervals (as we did earlier in Part C).  To do this, check the 95% Confidence Interval.
3. Click Finish.  SigmaXL automatically starts the Multi-Vari Chart procedure (this is equivalent to clicking SigmaXL > Graphical Tools > Multi-Vari Charts).

4. Check Use Entire Data Table.  Click Next.
5. Note that the input X’s can be text or numeric but should be discrete.  Y’s must be numeric - typically continuous, but can also be count or proportion data. 
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Select Measurement, click Numeric Response (Y) >>; select unit, click Group Category (X1) >>; select time, click Group Category (X2) >>.
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Click OK.  Resulting Multi-Vari Chart illustrating dominant “Within Unit” Source of Variation:














8. Using Multi-Vari Data.xls, click Sheet Between.  Select SigmaXL > Graphical Tools > Multi-Vari Charts.  Check Use Entire Data Table.  Click Next.

9. Select Measurement, click Numeric Response (Y) >>; select unit, click Group Category (X1) >>; select time, click Group Category (X2) >>.
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Click OK.  Resulting Multi-Vari Chart illustrating dominant “Between Unit” Source of Variation:












11. Using Multi-Vari Data.xls, click Sheet OverTime.  Select SigmaXL > Graphical Tools > Multi-Vari Charts.  Check Use Entire Data Table.  Click Next.

12. Select Measurement, click Numeric Response (Y) >>; select unit, click Group Category (X1) >>; select time, click Group Category (X2) >>.
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Click OK.  Resulting Multi-Vari Chart illustrating dominant “Over Time” Source of Variation:











.  

14. Open Customer Data.xls, click Sheet 1.  Select SigmaXL > Graphical Tools > Multi-Vari Charts.
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Select Overall Satisfaction, click Numeric Response (Y) >>; select Customer Type, click Group Category (X1) >>; select Size of Customer, click Group Category (X2) >>; select Product Type, click Group Category (X3) >>.
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Click OK.  Resulting Multi-Vari chart:













Examining this Multi-Vari chart reveals that the dominant Source of Variation is “within” Customer Type, followed by “between” Customer Type.  Furthermore, it would be worthwhile to examine the combination of Customer Type 2, Customer Size Large, and Product Type Consumer.

Other tools that can help us identify potential X factors that may explain some of the large “Within” variability are the Scatter Plot, Scatter Plot Matrix and Correlation Matrix.
Part Q – Scatter Plots

Scatter Plots

1. Open Customer Data.xls.  Click Sheet 1 Tab.  Click SigmaXL > Graphical Tools > Scatter Plots; if necessary, click Use Entire Data Table, click Next.
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Select Overall Satisfaction, click Numeric Response (Y) >>; select Avg Days Order Time to Delivery, click Numeric Predictor (X1) >>.
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Click OK.  The resulting Scatter Plot is shown with equation, trend line, 95% confidence interval (blue lines – for a given X value this is the 95% confidence interval for predicted mean Overall Satisfaction) and 95% prediction interval (red lines – for a given X value this is the 95% confidence interval for predicted individual values of Overall Satisfaction).











The equation is based on linear regression, using the method of least squares.   R-squared * 100 is the percent variation of Y explained by X (here 10.3%).

4. Now we want to redo the Scatter Plot and stratify by Customer Type.  Press F3  or click Recall SigmaXL Dialog to recall last dialog.  (Or, Click Sheet 1 Tab; Click SigmaXL > Graphical Tools > Scatter Plots; click Next.)
5. [image: image335.png]Predicted Output for

Erter
Actal
Factor  [Factor
Factor [seting - [seting
Factor Factor Name|Low__|High tame _|uncoded [cosed |V-hat: |S-hat:
B 59l 068191
o




Select Overall Satisfaction, click Numeric Response (Y) >>; select Average Days Order Time to Delivery, click Numeric Predictor (X1) >>; select Customer Type, click Group Category (X2) >>, Uncheck 95% Confidence Interval and 95% Prediction Interval.  Click OK:







Clearly, according to the analysis, Customer Type 3 is happier if orders take longer!  But, does this make sense?  Of course not!  Customer Sat scores should not increase with Order to Delivery time.  What is happening here?  This is a coincidental situation.  Something else is driving customer satisfaction.  We will now look at the Scatter Plot Matrix to help us investigate other factors influencing Customer Satisfaction.

Tip:  Be careful when interpreting scatter plots (and other statistical tools):  Y versus X correlation or statistical significance does not always mean that we have a causal relationship.  Umbrella sales are highly correlated to traffic accidents, but we cannot reduce the rate of traffic accidents by purchasing fewer umbrellas!  The best way to validate a relationship is to perform a Design of Experiments (see Improve Phase).  
Scatter Plot Matrix

1. Click Sheet 1 Tab of Customer Data.xls (or press F4 to activate last worksheet).  Click SigmaXL > Graphical Tools > Scatter Plot Matrix. 

2. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select the variable Avg No. of orders per month; shift-click on Staff Knowledge and click Numeric Data Variables (Y) >> as shown:
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 Click OK.  Resulting Scatter Plot Matrix:


















Of particular interest is Overall Satisfaction versus Responsiveness to Calls and Ease of Communications.  These will be explored further with Multiple Linear Regression.
Part R – Correlation Matrix

The correlation matrix complements the scatterplot matrix by quantifying the degree of association.  The following table shows the approximate relationship between r, R-squared, and degree of association:


	Pearson Correlation Coefficient (r) 
	R-Squared (%)
	Degree of association

	0.9 <= |r| <=1
	> 80 %
	Strong

	0.7 <= |r| < 0.9
	50 % to 80 %
	Moderate

	|r| < 0.7
	< 50 %
	Weak

	Pearson Probability, p > 0.05
	
	None


Correlation Matrix

1. Open Customer Data.xls.  Click Sheet 1 tab (or press F4 to activate last worksheet).  Click SigmaXL > Statistical Tools > Correlation Matrix.  Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select the variable Avg No. of orders per month; shift-click on Staff Knowledge and click Numeric Data Variables (Y) >> as shown:
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Click OK.  Resulting Correlation Matrix is shown:













Correlations highlighted in red are considered significant (p-values < .05).  The corresponding correlation coefficients above the p-values are also highlighted in red.  (Compare these to the Scatterplot Matrix.)
Note that Spearman’s Rank Correlation complements Pearson’s Correlation, in that it provides a robust measure of association.  Spearman’s rank is based on correlated ranks, which are not sensitive to outliers.

Part S – Multiple Regression

Multiple Regression

Multiple Regression analyzes the relationship between one dependent variable (Y) and multiple independent variables (X's).  It is used to discover the relationship between the variables and create an empirical equation of the form: 

Y = b0 + b1*X1 + b2*X2 + ... + bn*Xn

This equation can be used to predict a Y value for a given set of input X values.  SigmaXL uses the method of least squares to solve for the model coefficients and constant term.  Statistical tests of hypothesis are provided for the model coefficients.  

1. Open Customer Data.xls.  Click Sheet 1 Tab (or press F4 to activate last worksheet).  Click SigmaXL > Statistical Tools > Regression > Multiple Regression.  If necessary, click Use Entire Data Table, click Next.
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Select Overall Satisfaction, click Numeric Response (Y) >>, select Responsive to Calls and Ease of Communications, click Continuous Predictors (X) >>.  Fit Intercept is checked by default.  Check Display Residual Plots as shown: 















Note:  Fit Intercept is optional.  If unchecked the model will not fit an intercept (constant) for the model.  This is useful when you have strong a priori reasons to believe that Y = 0 when the X or X’s are equal to 0 and the relationship is linear.  An example would be Y=automobile fuel consumption, X=automobile weight.
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Click OK.  The resulting Multiple Regression report is shown:














This model of Overall Satisfaction as a function of Responsiveness to Calls and Ease of Communications looks very good with an R-Square value of 90%.  Both Predictors are shown to be significant with their respective p-values < .05.  Clearly we need to focus on these two X factors to improve customer satisfaction.
4. The variance inflation factor (VIF) and Tolerance scores are used to measure multicollinearity or correlation among predictors.  VIF = 1 indicates no relation among predictors (which is highly desirable – you will see examples of this in Design of Experiments); VIF > 1 indicates that the predictors are correlated; VIF > 5 indicates that the regression coefficients are strongly correlated and this will lead to poor estimates of the coefficients.  Tolerance = 1/VIF.
5. The Durbin-Watson Test is used to determine if the residuals are autocorrelated.  If either p-value is < .05, then there is significant autocorrelation.  This is likely due to an external bias factor affecting your process over time (e.g. “warm-up” effect, seasonality).  This will also be evident in the plot of residuals versus observation order.  Autocorrelation in the residuals is not a problem for this model.
6. If the Fit Intercept option is unchecked, the following diagnostics are not reported due to statistical issues associated with the removal of the constant.  These are:  R-Square, R-Square Adjusted, VIF (Variance Inflation Factor) and Tolerance collinearity diagnostics, DW (Durbin-Watson) autocorrelation report, Anova report for Discrete factors (discrete factors will not be permitted when "Fit Intercept" is unchecked).  All other tests including residual diagnostics are reported.  Users can run the model with the "Fit Intercept" on to get the above statistics and then run with "Fit Intercept" off.

7. [image: image345.png]available Responses

Available Model Terms:

ABC

Responses (1) >>

Model Terms >>

B

<<Remove all

Alpha for Pareto Chart: | 0.05

% Show Residual Plots

Selected Responses:

x>

Distance

Selected Model Terms:

B Stop Pin
C: Pin Height

Includs

Default Al Terms

o

A: Pull Back Angle

Cancel

Help




A predicted response calculator allows you to enter X values and obtain the predicted response value, including the 95% confidence interval for the long term mean and 95% prediction interval for individual values:
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 Click the Mult Reg Residuals Sheet and scroll right to view the Residual Plots shown below:






















Residuals are the unexplained variation from the regression model (Y - Ŷ).  We expect to see the residuals normally distributed with no obvious patterns in the above graphs.  Clearly this is not the case here, with the Residuals versus Predicted Values indicating there is likely some other X factor influencing the Overall Satisfaction.  It would be appropriate to consider other factors in the model. 
9. SigmaXL also provides Standardized Residuals and Studentized (Deleted t) Residuals.  The standardized residual is the residual, divided by an estimate of its standard deviation. This makes it easier to detect outliers.  Standardized residuals greater than 3 and less than -3 are considered large (these outliers are highlighted in red).  Studentized deleted residuals are computed in the same way that standardized residuals are computed, except that the ith observation is removed before performing the regression fit.  This prevents the ith observation from influencing the regression model, resulting in unusual observations being more likely to stand out.
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Click Recall Last Dialog (or press F3).  Change the Residual type to Standardized.  Click OK.  The resulting Standardized Residual plots are displayed:






















11. Other diagnostic measures reported but not plotted include Leverage, Cook's Distance (Influence), and DFITS.  Leverage is a measure of how far an individual X predictor value deviates from its mean.  High leverage points can potentially have a strong effect on the estimate of regression coefficients.  Leverage values fall between 0 and 1.  Cook's distance and DFITS are overall measures of influence.  An observation is said to be influential if removing the observation substantially changes the estimate of coefficients.  Cook’s distance can be thought of as the product of leverage and the standardized residual; DFITS as the product of leverage and the studentized residual.  

12. The easiest way to identify observations with high leverage and/or influence is to plot the measures on a run chart. 
Multiple Regression with Continuous and Categorical Predictors
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Click Recall Last Dialog (or press F3).  Select Customer Type, click Categorical Predictor (X) >>.  We will not discuss residuals further so you may wish to uncheck Display Residual Plots. Keep Overall Satisfaction as the Numeric Response (Y) and Responsive to Calls and Ease of Communications as the Continuous Predictors (X):
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Click OK.  The resulting Multiple Regression report is shown:














15. The parameter estimates table now includes Customer Type 2 and Customer Type 3, but where is Customer Type 1?  Since Customer Type is a discrete predictor, SigmaXL applies “dummy coding” (i.e. Customer Type 1 corresponds to Coded Variable 1 = 0  and Coded Variable 2 = 0; Customer Type 2 has Coded Variable 1 = 1 and Coded Variable 2 = 0; and Customer Type 3 has Coded Variable 1 = 0 and Coded Variable 2=1).  Hence Customer Type 1 becomes the “hidden” or reference value.  Other statistical software packages may use a different coding scheme based on -1,0,+1 instead of 0,1.  The advantage of a 0,1 coding scheme is the relative ease of interpretation when making predictions with the model.
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In the Predicted Response Calculator enter the settings as shown: 




 Note that for Customer Type 1, you would enter Customer Type 2 = 0 and Customer Type 3 = 0; for Customer Type 2, as shown, you entered Customer Type 2 = 1 and Customer Type 3 = 0; for Customer Type 3 you would enter Customer Type 2 = 0 and Customer Type 3 = 1. 

17. Note the addition of the Analysis of Variance for Categorical (Discrete) Predictors.  The Customer Type p-value is .08, so we do not have strong evidence to keep this term in the model.  However, many practitioners will use an alpha value of 0.1 as a criteria for removal.  You are probably wondering why the p-value for Customer Type is not lower given the results we saw earlier using ANOVA.  The change in p-value is due to the inclusion of Responsive to Calls and Ease of Communications in the model.  We have higher scores for Ease of Communications and Responsive to Calls with Customer Type 2.  Statistically, Customer Type is somewhat correlated to Responsive to Calls and Ease of Communications (VIF for Customer Type = 1.66 and 1.39).
Part T – Logistic Regression

Binary Logistic Regression

Binary Logistic Regression is used to analyze the relationship between one binary dependent variable (Y) and multiple independent numeric and/or discrete variables (X's).  It is used to discover the relationship between the variables and create an empirical equation of the form: 

Ln(Py/(1-Py)) = b0 + b1*X1 + b2*X2 + ... + bn*Xn

This equation can be used to predict an event probability Y value for a given set of input X values.  SigmaXL uses the method of maximum likelihood to solve for the model coefficients and constant term.  Statistical tests of hypothesis and odds-ratios are provided for the model coefficients.  The odds-ratios identify change in likelihood of the event for one unit change in X.

An example application from medical research would be Y=Disease (Yes/No) and X’s = Age, Smoker (Yes/No), Number Years of Smoking and Weight.  The model coefficient p-values would indicate which X’s are significant and the odds-ratios would provide the relative change in risk for each unit change in X.
We will analyze the familiar Customer Satisfaction data using Y=Discrete Satisfaction where the values have been coded such that an Overall Satisfaction score >= 3.5 is considered a 1, and scores < 3.5 are considered a 0.  Please note, we are not advising that continuous data be converted to discrete data in actual practice, but simply using the Discrete Satisfaction score for continuity with the previous analysis.

1. Open Customer Data.xls.  Click Sheet 1 Tab (or press F4 to activate last worksheet).  Click SigmaXL > Statistical Tools > Regression > Binary Logistic Regression.  If necessary, click Use Entire Data Table, click Next.

2. Select Sat-Discrete, click Binary Response (Y) >>; select Responsive to Calls and Ease of Communications, click Continuous Predictors (X) >>; select Customer Type, click Categorical Predictors (X) >>.
















Note that Response Count (Y)/Sample Size (Trials) should be used when each record contains both the number of occurrences along with associated sample size.  This is common when tracking daily quality data or performing design of experiments where each run contains a response of the number of defects and sample size. 
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Click OK.  The resulting Binary Logistic report is shown:



















4. The Likelihood Ratio p-value < .05 tells us that the model is significant.  The p-values for the coefficients in the Parameter Estimates table confirm that Responsive to Calls and Ease of Communications are significant. 

5. The p-value in Wald Estimates for Categorical (Discrete) Predictors table tells us that Customer Type is not significant here. 
Tip:  Significance for categorical predictors should be based on the Wald Estimates not the p-values given in the Parameter Estimates table.

6. Note that Customer Type 1 is not displayed in the Parameter Estimates table.  This is the “hidden” reference value for Customer Type.  Categorical predictors must have one level selected as a reference value.  SigmaXL sorts the levels alphanumerically and selects the first level as the reference value.
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Now we will rerun the binary logistic regression but remove Customer Type as a predictor.  Press F3  or click Recall SigmaXL Dialog to recall last dialog.  Remove Customer Type by highlighting Customer Type and double-clicking (or press the Remove button).












8. Click OK.  The resulting Binary Logistic report is shown: 
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9. The Odds Ratios in the Parameter Estimates table tell us that for every unit increase in Responsive to Calls we are 11.7 times more likely to obtain a satisfied customer.  For every unit increase in Ease of Communications we are 13.3 times more likely to obtain a satisfied customer.

10. McFadden’s Pseudo R-Square mimics the R-square found in linear regression.  This value varies between 0 and 1 but is typically much lower than the traditional R-squared value.  A value less than 0.2 indicates a weak relationship; 0.2 to 0.4 indicates a moderate relationship; greater than 0.4 indicates a strong relationship.  Here we have an R-square value of 0.66 indicating a strong relationship.  This is also confirmed with the Percent Correctly Predicted value of 96%.
11. The Pearson, Deviance and Hosmer-Lemeshow Goodness of Fit tests are used to confirm if the binary logistic model fits the data well.  P-values < .05 for any of these tests indicate a significant lack of fit.  Here the Hosmer-Lemeshow test is indicating lack of fit.  Residuals analysis will help us to see where the model does not fit the data well.

12. The measures of association are used to indicate the relationship between the observed responses and the predicted probabilities.  Larger values for Goodman-Kruskal Gamma, Somers’ D and Kendall’s Tau-a indicate that the model has better predictive ability.
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The residuals report is given on the Sheet Binary Logistic Residuals.  Three types of residuals are provided:  Pearson, Standardized Pearson and Deviance.  The Standardized Pearson Residual is most commonly used and is shown here plotted on a Run Chart.  To create, click SigmaXL > Graphical Tools > Run Chart, check Use Entire Data Table to select the Residuals data, click Next, select Std. Pearson Residual as the Numeric Data Variable (Y).  Click OK.









Any Standardized Pearson Residual value that is less than -3 or greater than +3 is considered extreme and should be investigated.  There are 3 such outliers here: rows 24, 67, and 77 in the residuals table.  The +3.4 value indicates that the predicted event probability was low (.08) but the actual result was a 1.  The -6.6 value indicates that the predicted event probability was high (.98) but the actual result was a 0.  The large negative residuals have high Responsive to Calls and Ease of Communications but dissatisfied customers.  The reasons for these discrepancies should be explored further but we will not do so here. 
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Reselect the Binary Logistic Report sheet.  Scroll over to display the Event Probability calculator:





This calculator provides a predicted Event Probability for given values of X (in this case the probability of a satisfied customer).  Enter the values 3,3; 4,4; 5,5 as shown:













If Responsive to Calls and Ease of Communications are both equal to 3, the probability of a satisfied customer is only .07 (7%); if Responsive to Calls and Ease of Communications are both equal to 5, the probability of a satisfied customer is .9995 (99.95%)
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Note that if the calculator includes predictors that are categorical (discrete), enter a 0 or 1 to denote the selected level as shown below (using the original analysis which included Customer Type):





If we wanted to select Customer Type 1, enter a 0 for both Customer Types 2 and 3.  Customer Type 1 is the hidden reference value.
Ordinal Logistic Regression

Ordinal Logistic Regression is used to analyze the relationship between one ordinal dependent variable (Y) and multiple independent continuous and/or discrete variables (X's).

We will analyze the Customer Satisfaction data using Y=Loyalty –Likely to Recommend score which contains ordinal integer values from 1 to 5, where 5 indicates that the customer is very likely to recommend us and 1 indicates that they are very likely to not recommend us.
1. Open Customer Data.xls.  Click Sheet 1 Tab (or press F4 to activate last worksheet).  Click SigmaXL > Statistical Tools > Regression > Ordinal Logistic Regression.  If necessary, click Use Entire Data Table, click Next.
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Select Loyalty – Likely to Recommend, click Numeric Ordinal Response (Y) >>; select Responsive to Calls and Ease of Communications, click Continuous Predictors (X) >>. 













3. Click OK.  The resulting Ordinal Logistic report is shown: 
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The Likelihood Ratio p-value < .05 tells us that the model is significant.  The low p-values for the coefficients confirm that Responsive to Calls and Ease of Communications are significant.

5. The Odds Ratios tell us that for every one-unit increase in Responsive to Calls the chance of a Loyalty score of 1 versus 2  (or 2 versus 3, etc.) is reduced by a multiple of 0.36.  This is not very intuitive but will be easy to see when we use the Response Outcome Probability calculator. 
6. McFadden’s Pseudo R-Square value is 0.185 indicating that this is a weak (but close to moderate) degree of association.  This is also confirmed with the Percent Correctly Predicted value of 48%.

7. The Pearson and Deviance Goodness of Fit (GOF) tests are used to confirm if the ordinal logistic model fits the data well.  P-values < .05 would indicate a significant lack of fit.  Given that the GOF p-values are greater than .05, we conclude that there is no significant lack of fit.
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Scroll across to the Response Outcome Probability calculator.  This calculator provides predicted outcome (event) probabilities for given values of X (in this case the probability of a satisfied customer).  Enter the values 3,3; 4,4; 5,5 as shown:


















9. Referring to the Predicted Probability for each Level, if Responsive to Calls and Ease of Communications are both equal to 3, we would expect to see typical loyalty scores of 3 (57%) with some at 2 (20%) and 4 (20%); if Responsive to Calls and Ease of Communications are both equal to 5, we would expect typical loyalty scores of 4 (53 %) with some at 3 (34%) and 5 (9%).

SigmaXL: Improve Phase Tools: Design of Experiments (DOE)
Part A – Overview of Basic Design of Experiments (DOE) Templates
The DOE templates are similar to the other SigmaXL templates:  simply enter the inputs and resulting outputs are produced immediately.  The DOE templates provide common 2-level designs for 2 to 5 factors.  These basic templates are ideal for training, but use SigmaXL > Design of Experiments > 2-Level Factorial/Screening Designs to accommodate up to 19 factors with randomization, replication and blocking.
Click SigmaXL > Design of Experiments > Basic DOE Templates to access these templates:

· Two-Factor, 4-Run, Full-Factorial

· Three-Factor, 4-Run, Half-Fraction, Res III

· Three-Factor, 8-Run, Full-Factorial

· Four-Factor, 8-Run, Half-Fraction, Res IV

· Four-Factor, 16-Run, Full-Factorial

· Five-Factor, 8-Run, Quarter-Fraction, Res III

· Five-Factor, 16-Run, Half-Fraction, Res V

After entering the template data, main effects and interaction plots may be created by clicking SigmaXL > Basic DOE Templates > Main Effects & Interaction Plots.  The DOE template must be the active worksheet.
DOE Templates are protected worksheets by default, but this may be modified by clicking SigmaXL > Help > Unprotect Worksheet.
Advanced analysis is available, but this requires that you unprotect the DOE worksheet.  The following example shows how to use Excel’s Equation Solver and SigmaXL’s Multiple Regression in conjunction with a DOE template.  Caution: If you unprotect the worksheet, do not change the worksheet title (e.g. Three-Factor, Two-Level, 8-Run, Full-Factorial Design of Experiments).  This title is used by the Main Effects & Interaction Plots to determine appropriate analysis.  Also, do not modify any cells with formulas.
Part B – Three Factor Full Factorial Example Using DOE Template
1. Open the file DOE Example - Robust Cake.xls.  This is a Robust Cake Experiment adapted from the Video Designing Industrial Experiments, by Box, Bisgaard and Fung.

2. The response is Taste Score (on a scale of 1-7 where 1 is "awful" and 7 is "delicious").

3. The five Outer Array Reps have different Cooking Time and Temperature Conditions.

4. The goal is to Maximize Mean and Minimize StDev of the Taste Score.
5. The X factors are Flour, Butter, and Egg.  Actual low and high settings are not given in the video, so we will use coded -1 and +1 values.  We are looking for a combination of Flour, Butter, and Egg that will not only taste good, but consistently taste good over a wide range of Cooking Time and Temperature conditions.
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Scroll down to view the Pareto of Abs. Coefficients for Average (Y).














7. The BC (Butter * Egg) interaction is clearly the dominant factor.  The bars above the 95% confidence blue line indicate the factors that are statistically significant; in this case only BC is significant.  Keep in mind that this is an initial analysis.  Later, we will show how to do a more powerful Multiple Regression analysis on this data.  (Also, the Rule of Hierarchy states that if an interaction is significant, we must include the main effects in the model used.)
8. The significant BC interaction is also highlighted in red in the table of Effects and Coefficients:
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The R-Square value is given as 27%.  This is very poor for a Designed Experiment.  Typically, we would like to see a minimum of 50%, with > 80% desirable.




The reason for the poor R-square value is the wide range of values over the Cooking Temperature and Time conditions.  In a robust experiment like this, it is more appropriate to analyze the mean response as an individual value rather than as five replicate values.  The Standard Deviation as a separate response will also be of interest.
10. If the Responses are replicated, SigmaXL draws the blue line on the Pareto Chart using an estimate of experimental error from the replicates.  If there are no replicates, an estimate called Lenth’s Pseudo Standard Error is used.
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If the 95% Confidence line for coefficients were to be drawn using Lenth’s method, the value would be 0.409 as given in the table:





This would show factor C as significant.


12. Scroll down to view the Pareto of Coefficients for StdDev(Y).  













13. The A (Flour) main effect is clearly the dominant factor, but it does not initially appear to be statistically significant (based on Lenth’s method).  Later, we will show how to do a more powerful Regression analysis on this data.[image: image366.png]Individuals: Overall Satisfaction
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14. The Pareto chart is a powerful tool to display the relative importance of the main effects and interactions, but it does not tell us about the direction of influence.  To see this, we must look at the main effects and interaction plots.  Click SigmaXL > Basic DOE Templates > Main Effects & Interaction Plots.  The resulting plots are shown below: 
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The Butter*Egg two-factor interaction is very prominent here.  Looking at only the Main Effects plots would lead us to conclude that the optimum settings to maximize the average taste score would be Butter = +1, and Egg = +1, but the interaction plot tells a very different story.  The correct optimum settings to maximize the taste score is Butter = -1 and Egg = +1.

16. Since Flour was the most prominent factor in the Standard Deviation Pareto, looking at the Main Effects plots for StdDev, we would set Flour = +1 to minimize the variability in taste scores.  The significance of this result will be demonstrated using Regression analysis.
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Click on the Sheet Three-Factor 8-Run DOE.  At the Predicted Output for Y, enter Flour = 1, Butter = -1, Egg = 1 as shown:








The predicted average (Y-hat) taste score is 5.9 with a predicted standard deviation (S-hat) of 0.68.  Note that this prediction equation includes all main effects, two-way interaction, and the three-way interaction.


Multiple Regression and Excel Solver (Advanced Topics):

18. In order to run Multiple Regression analysis we will need to unprotect the worksheet.  Click SigmaXL > Help > Unprotect Worksheet.
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In the Coded Design Matrix, highlight columns A to ABC, and the calculated responses as shown:







20. Click SigmaXL > Statistical Tools > Regression > Multiple Regression.  Click Next.
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Select Average (Y), click Numeric Response (Y) >>; holding the CTRL key, select B, C, and BC; click Continuous Predictors (X) >> as shown:
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Click OK.  The resulting regression report is shown:














Note that the R-square value of 92.85% is much higher than the earlier result of 27%.  This is due to our modeling the mean response value rather than considering all data in the outer array.  Note also that the C main effect now appears as significant.

23. Click on the Sheet Three-Factor 8-Run DOE.  

24. With the Coded Design Matrix highlighted as before, click SigmaXL > Statistical Tools > Regression > Multiple Regression.  Click Next.
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Select StdDev (Y), click Numeric Response (Y) >>; select A, click Continuous Predictors (X) >> as shown:
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Click OK.  The resulting regression report is shown:












Note that Factor A (Flour) now shows as a statistically significant factor affecting the Standard Deviation of Taste Score.


27. Now we will use Excel’s Equation Solver to verify the optimum settings determined using the Main Effects and Interaction Plots.
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Click on the Sheet Three-Factor 8-Run DOE.  At the Predicted Output for Y, enter 1 for Flour.  We are setting this as a constraint, because Flour = +1 minimizes the Standard Deviation.  Reset the Butter and Egg to 0 as shown:
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Click Tools > Add-Ins  (Excel 2007:  Office Button | Excel Options | Add-Ins > Manage Excel Add-Ins, click Go; Excel 2010: File | Options…).  Ensure that the Solver Add-in is checked.  If the Solver Add-in does not appear in the Add-ins available list, you will need to re-install Excel to include all add-ins. 
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Click OK.  Click Tools > Solver  (Excel 2007/2010:  Data | Analysis | Solver).  Set the Solver Parameters as shown:









Cell J11 is the Y-hat, predicted average taste score.  Solver will try to maximize this value.  Cells H11 to H13 are the Actual Factor Settings to be changed.  Cells I11 to I13 are the Coded Factor settings where the following constraints are given:  I11=1; I12 >= -1; I12 <= 1; I13 >= -1; I13 <=1.
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Click Solve.  The solver results are given in the Predicted Output for Y as Butter = -1 and Egg = 1.
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Solver indicates that a solution is found: 









33. Click OK to keep the solution.  
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Part C – Design and Analysis of Catapult Full Factorial Experiment
Catapults are frequently used in Six-Sigma or Design of Experiments training.  They are a powerful teaching tool and make the learning fun.  If you have access to a catapult, we recommend that you perform the actual experiment and use your own data.  Of course, you can also follow along using the data provided.  The response variable (Y) is distance, with the goal being to consistently hit a target of 100 inches.
1. Click SigmaXL > Design of Experiments > 2-Level Factorial/Screening > 2-Level Factorial/Screening Designs.

2. The Number of X Factors can be 2 to 19.  Using process knowledge, we will limit ourselves to 3 factors:  Pull Back Angle, Stop Pin and Pin Height.  Pull Back will be varied from 160 to 180 degrees, Stop Pin will be positions 2 and 3 (count from the back), and Pin Height will be positions 2 and 3 (count from the bottom).

3. Select Number of Factors = 3.

4. The available designs are then given as:  4-Run, 2**(3-1), 1/2 Fraction,  Res III and 8-Run, 2**3, Full-Factorial.  If we had more than 5 factors, a Resolution III or Plackett-Burman Screening design would typically be used.  Here we will choose the 8-Run, 2**3, Full-Factorial design.
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Next we will review the Power Information to help us determine the number of replicates. This design currently shows the following: 

These power calculations assume 3 center points:
Very Low Power to detect Effect = 1*StDev (1-Beta < 0.5);
Very Low Power to detect Effect = 2*StDev (1-Beta < 0.5);
Medium Power to detect Effect = 3*StDev (0.8 <= 1-Beta < 0.95).

Note:  the power calculations require an estimate of experimental error, hence an assumption of 3 center points is used.
 
We would like to have a reasonable chance (medium power) to detect an Effect = 2*StDev.  Change the Number of Replicates to 2.  The Power Information is now:
Very Low Power to detect Effect = 1*StDev (1-Beta < 0.5);
Medium Power to detect Effect = 2*StDev (0.8 <= 1-Beta < 0.95);
Very High Power to detect Effect = 3*StDev (1-Beta >= 0.99).
We will therefore choose two replicates.  The number of replicates will always be a tradeoff between the desired power and the cost of the experimental runs.

Specify 2 or more blocks if there are constraints such as the number of runs per day or some other known external “nuisance” variable (like 2 different catapults or 2 operators).  Here we will keep Blocks = 1 (i.e. no Blocking). 
Center Points are useful to provide an estimate of experimental error with unreplicated designs, and allow detection of curvature.  Typically 3 to 5 center points are used.  Here we will not use center points because we have replicated the design twice and do not expect significant curvature in the distance response.  Furthermore, center points could not be set for Pin Height and Stop Pin (without drilling additional holes!).
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Complete the Factor Names, Level Settings and Response Name as shown: 
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Click OK.  The following worksheet is produced:














8. You can enter information about the experiment in the fields provided.  If you have access to a catapult, perform the experimental runs in the given randomized sequence, and enter the distance values in the Distance column.
9. If you are not able to perform the catapult experiment, open the file Catapult DOE V6.xls.
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Click SigmaXL > Design of Experiments > 2-Level Factorial/Screening > Analyze 2-Level Factorial/Screening Design. 
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We will use the default analyze settings (all terms in the model) to start.  Click OK.  The resulting Analysis report is shown: 













[image: image385.png]X-Bar&R =)

Please select your data

$B$2:$F$22

Data Table Format
¥ Use Data Labels.

I” Use Entire Data Table

nep | concel [[hoans






 




















[image: image386.png]X-Bar and Range Chart

Subgroup No
erator

Shot 2
Shot 3

€ Stacked Column Format (1 Numeric Data Column & Subgroup Size or Column)
& Subgroups across Rows (2 or More Numeric Data Columns)

. . o> | [ShotT
_Mumeric Data Variables (V) >> | | giot 2 oK>>
Shot 3
cancel
Help
ptional X s Labels 55 ]| | Opertor
<<Remove
X-Bar R
e
F“""“f‘; " va
¥ Tests for Special Causes «
a


















12. The model looks very good with an R-Square value of 99.9%!  The standard deviation (experimental error) is only 1.03 inches.  Clearly Pull Back Angle is the most important predictor (X factor), but all the main effects and two way interaction are significant. However, the three-way interaction is not significant, so it should be removed from the model.  
13. Click Recall Last Dialog (or press F3).
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Remove the ABC interaction term as shown:

















15. Click OK.  The revised report is shown below:
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16. All the terms in the model are now significant, and there is no evidence of lack of fit (P-value for lack-of-fit is 0.128 which is > .05).
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The Residual Plots also look very good:



















18. [image: image391.png]X-Bar and Range Chart

Subgroup No  Stacked Column Format (1 Numeric Data Column & Subgroup Size or Column)
erator
oo & Subgroups across Rows (2 or More Numeric Data Columns)
Shot 2
Shot 3 Numeric Data Variables () >> | | Shot 1
fumericData Variables > 1| shot 2 ox>>
Cancel
telp
Optional X-Axis Labels >>
<< Remove
X-Bar R
c ——
 tastoren it 106812 ya | 1621776
w0367 @ |63

0392135 1 [0

Advanced Options
r add Title
Process Capabiity Report
s [ Target | 100 v |08
Calculate Control Limits:

 Specify Subgroup Number for Calculation of Control Limits
& Specify Historical Group Column (Split Limits)




Scroll up to the Predicted Response Calculator.  Enter the predicted values shown.  These initial settings were determined by trial and error.
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Excel’s Solver may also be used to get a more exact solution: 



















20. The model prediction must then be confirmed with actual experimental runs at the given settings of Pull Back Angle = 179.5, Stop Pin = 2, and Pin Height = 2.
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Alternative settings to achieve the target distance may be obtained with Contour/Surface Plots.  Click SigmaXL > Design of Experiments > 2-Level Factorial/Screening > Contour/Surface Plots.  Set the Pin Height to 2 as shown (after clicking OK, you can use Recall SigmaXL Dialog to create another Contour/Surface plot with Pin Height set to 3) :
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Click OK. The following Contour and Surface Plots are displayed (with Pin Height = 2). Note the contour line with Catapult target distance = 100 inches.  Although pin settings are discrete, they appear as continuous, so this will be a constraint in our selection of alternative settings.  In addition to Pull Back Angle = 179.5, Stop Pin = 2, Pin Height = 2, we see that  Pull Back Angle = 171.4, Stop Pin = 3, Pin Height = 2 is also a valid setting.  Alternative setting options are valuable in a designed experiment because they allow you to select lowest cost optimum settings, or settings that are easier to control.

























Tip: Use the contour/surface in conjunction with the predicted response calculator to determine optimal settings.


Part D – Design and Analysis of Response Surface Experiment – Cake Bake
1. We will illustrate the use of response surface methods using a layer cake baking experiment.  The response variable is Taste Score (on a scale of 1-7 where 1 is "awful" and 7 is "delicious"). Average scores for a panel of tasters have been recorded.  The X Factors are A: Bake Time (20 to 40 minutes) and B: Oven Temperature (350 to 400 F). The experiment goal is to find the settings that maximize taste score. Other factors such as pan size need to be taken into consideration. In this experiment, these are held constant.
2. Click SigmaXL > Design of Experiments > Response Surface > Response Surface Designs.

3. The Number of X Factors can be 2 to 5.  Select Number of Factors = 2.

4. The available designs are sorted by number of runs.  Increasing the number of runs allows for uniform precision or blocking, but we will select the design with fewest runs, the 10-Run, Central Composite Design (2 Ctr Pts).  
5. As discussed earlier with the catapult experiment, it is a good practice to replicate an experiment if affordable to do so.  Here we will select Number of Replicates = 2 and check Block on Replicates.  Blocking on replicates allows us to perform the experiment over a two week period, with each block corresponding to week number.  
6. Change the Alpha Axial Value option to Face Centered (Alpha = 1.0).  This simplifies the design to a 3 level design, rather than a 5 level design with alpha = 1.414. (The trade-off is that we lose the desirable statistical property of rotatability for prediction).  

Tip: This alpha is the distance from the center point to the end of the axial (star) point. Do not confuse this with Alpha for Pareto Chart which is the p-value used to determine statistical significance.  Unfortunately the term “alpha” has been chosen by statisticians to define two completely different things. 
7. Enter Factor Names and Level Settings and Response Name as shown:
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 Click OK.  The following worksheet is produced:




















9. Open the file RSM Example – Cake Bake to obtain response values.
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Click SigmaXL > Design of Experiments > Response Surface > Analyze Response Surface Design. 



















11. We will use the default analyze settings (all terms in the model, including the block term) to start.  Click OK.  The resulting Analysis report is shown: 
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12. The model looks very good with an R-Square value of 99.09%  The standard deviation (experimental error) is only 0.19 on a 1 to 7 taste scale.  All of the model terms are statistically significant (P < .05), but the Block term is not, so it should be removed from the model.  Note that AA and BB denote the quadratic model terms.
13. Click Recall Last Dialog (or press F3).

14. Uncheck Include Blocks as shown:
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Click OK.  The revised report is shown below:
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To create a contour and surface plot, click SigmaXL > Design of Experiments > Response Surface > Contour/Surface Plots.
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 Click OK. The following Contour and Surface Plots are displayed
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Scroll across to the Predicted Response Calculator.  Enter the predicted values shown.  These initial settings were determined from the contour plot as an estimate to yield a maximum taste score.
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Excel’s Solver may also be used to get a more exact solution: 
















20. Although the model is predicting values that exceed the maximum taste score of 7, this is expected to give us the best possible settings for cook time and bake temperature.  To quote the eminent statistician George Box, “All models are wrong, some are useful”.  Additional experimental runs carried out at Time = 23.4 minutes and Temperature = 367.7 F. confirm that these are ideal settings.




 

SigmaXL: Control Phase Tools: Statistical Process Control (SPC) Charts
Part A - Individuals Charts

Individuals Charts

1. Open Customer Data.xls, click on Sheet 1.  Click SigmaXL>Control Charts>Individuals. Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>.  Ensure that Calculate Limits is selected.
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 Click OK.  Resulting Individuals control chart:













4. We have seen this data earlier as a run chart.  The Control Chart adds calculated control limits.  Note that the Upper Control Limit exceeds the survey upper limit of 5.  Here it would be appropriate to change the UCL to 5.0.  Click Recall SigmaXL Dialog menu or press F3 to recall last dialog.
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Select Overall Satisfaction, click Numeric Data Variable (Y) >>, change UCL to 5.














6. Click OK.  Resulting Individuals chart with modified UCL:
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Tip: You should not change the calculated control limits unless you have a legitimate reason such as a boundary condition.  Do not replace the control limits with specification limits – the control chart will lose its statistical ability to detect assignable causes.  We will redo the Individuals chart for Overall Satisfaction later using the Individuals Nonnormal tool.

7. Open Delivery Times.xls.  Click Sheet 1 Tab.  This data set contains room service delivery time deviations in minutes.  The Critical Customer Requirement is target time +/- 10 minutes.

8. Click SigmaXL > Control Charts > Individuals.  Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.

9. Select Delivery Time Deviation, click Numeric Data Variable (Y) >>, check Tests for Special Causes, check Sigma Zone Lines. Ensure that Calculate Limits is selected.
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Select Advanced Options, specify LSL = -10, Target = 0, USL = 10 as shown:
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Click OK.  The resulting chart is shown:









Some tests for special causes are indicated on the chart.  If more than one test fails, the number corresponds to the first failed test.
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 There are no points that exceed the +/- 3 sigma limits on this chart, but we see some indication of instability with tests for special causes.  The Tests for Special Causes report below the chart provides detailed information about each observation identified as a special cause.  Note that the control chart also shows the +/- 1 sigma and +/- 2 sigma lines to aid in viewing these tests.
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These tests for special causes can have defaults set to apply any or all of Tests 1-8.  Test 2 can be set to 7, 8, or 9 points in a row on same side of CL.  Test 3 can be set to 6 or 7 points in a row all increasing or decreasing.  Test 7 can be set to 14 or 15 points in a row within 1 standard deviation from CL.  Click Sheet 1 Tab.  Click SigmaXL > Control Charts > “Tests for Special Causes” Defaults to run selected tests for special causes: 















Note that these defaults will apply to Individuals and X-bar charts.  Test 1 to 4 settings will be applied to Attribute Charts.
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Click on the Tab Display Options for Tests.







15. If you prefer to create a separate worksheet for each Tests for Special Causes report, choose Create a new sheet option.  The default is to display Tests for Special Causes on the same sheet as the Control Chart.  Note that this report will be overwritten when you add data or recalculate control limits. 

16. Click Save.
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Click on Indiv Proc Cap Tab to view the Process Capability Report, which includes potential (short term) capability indices Cp and Cpk:
























18. While this process demonstrated some slight instability on the control charts, the bigger issue was being late 6 minutes on average and having a Standard Deviation of 7.2 minutes!  One improvement implemented was rescheduling the service elevators so that Room Service and Maintenance were not both trying to use them during peak times.
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 Click on the Indiv sheet.  With 725 data points, you may want to have a closer look at the most recent data.  To do this, click SigmaXL Chart Tools > Show Last 30 Points.  (If this menu item does not appear, click on any cell adjacent to the chart.)  The resulting chart is shown:











20. To reset the chart, click SigmaXL Chart Tools > Show All Data Points.
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To enable scrolling, click SigmaXL Chart Tools > Enable Scrolling.  A warning message is given:








Scrolling will clear user custom formats, but does not affect Tests for Special Causes.
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Click OK.  A scroll dialog appears allowing you to specify the Start Subgroup and Window Width:






23. At any point, you can click Restore/Show All Data Points or Freeze Chart.  Freezing the chart will remove the scroll and unload the dialog.  The scroll dialog will also unload if you change worksheets.  To restore the dialog, click SigmaXL Chart Tools > Enable Scrolling.
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Click OK.  The control chart appears with the scroll bar beneath it.  You can also change the Start Subgroup and Window Width and Update.









Individuals Charts: Advanced Limit Options – Historical Groups
1. Open Catapult Data Before After Improvement.xls.  Click Sheet 1 Tab.  This data set contains Catapult firing distances.  Before_After denotes before improvement and after improvement.  The target distance is 100 inches, with the goal being to hit the target and minimize variation about the target.  We would like to use an individuals control chart with historical groups to split the limits demonstrating the before versus after improvement.

2. Click SigmaXL > Control Charts > Individuals.  Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.

3. Select Distance, click Numeric Data Variable (Y) >>; select Operator, click Optional X-Axis Labels >>. 
4. Click Advanced Options.  Select Specify Historical Groups.  Select Before_After, click Historical Groups >>.


























Note:  Process Capability analysis is not permitted when Historical Groups are used.   
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Click OK.  The resulting Individuals Control Chart with split limits based on historical groups is shown, demonstrating a clear process improvement:












Individuals Charts for Nonnormal Data 
(Box-Cox Transformation) 

An important assumption for Individuals Charts is that the data be normally distributed (unlike the X-Bar Chart which is robust to nonnormality due to the central limit theorem).  If the data is nonnormal, the Box-Cox Transformation tool can be used to convert nonnormal data to normal by applying a power transformation.  The Johnson transformation and other distributions may also be used with Automatic Best Fit (see Measure Phase Tools, Part J – Process Capability, Capability Combination Report Individuals Nonnormal).
1. Open the file Nonnormal Cycle Time2.xls.  This contains continuous nonnormal data of process cycle times.  We performed a Process Capability study with this data earlier in the Measure Phase, Part H.

2. Initially, we will ignore the nonnormality in the data and construct an Individuals Chart.   Click SigmaXL > Control Charts > Individuals.  Ensure that entire data table is selected.  If not, check Use Entire Data Table.  Click Next.
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Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  Select Calculate Limits. Check Tests for Special Causes.













4. The resulting Individuals Chart is shown:











This chart clearly shows that the process is “out-of-control”.  But is it really?  Nonnormality can cause serious errors in the calculation of Individuals Chart control limits, triggering false alarms (Type I errors) or misses (Type II errors).
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We will now construct Individuals Control Charts for nonnormal data.  Select Sheet 1 Tab (or press F4).  Click SigmaXL > Control Charts > Nonnormal > Individuals Nonnormal.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table.  Click Next. 
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Select Cycle Time (Minutes), click Numeric Data Variable (Y) >>.  We will use the default selection for Transformation/Distribution Options: Box-Cox Transformation with Rounded Lambda. Check Tests for Special Causes as shown:
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Click OK.  The resulting control charts are shown below:

































Note that there are no out-of-control signals on the control charts, so the signals observed earlier when normality was assumed were false alarms.

The Individuals – Original Data chart displays the untransformed data with control limits calculated as:

UCL = 99.865 percentile 

CL = 50th percentile

LCL = 0.135 percentile

The benefit of displaying this chart is that one can observe the original untransformed data.  Since the control limits are based on percentiles, this represents the overall, long term variation rather than the typical short term variation. The limits will likely be nonsymmetrical.

The Individuals/Moving Range – Normalized Data chart displays the transformed z-values with control limits calculated using the standard Shewhart formulas for Individuals and Moving Range charts. The benefit of using this chart is that tests for special causes can be applied and the control limits are based on short term variation.  The disadvantage is that one is observing transformed data on the chart rather than the original data.

Part B - X-Bar & Range Charts

X-Bar & R Charts

1. Open the file Catapult Data – Xbar Control Charts.xls.  Each operator fires the ball 3 times.  The target distance is 100 inches.  The Upper Specification Limit (USL) is 108 inches.  The Lower Specification Limit (LSL) is 92 inches.

2. Select B2:F22; here, we will only use the first 20 subgroups to determine the control limits.

3. Select SigmaXL > Control Charts > X-Bar & R.
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Do not check Use Entire Data Table!
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Click Next.  Select Subgroups across Rows, select Shot 1, Shot 2, Shot 3, click Numeric Data Variables (Y) >>; select Operator, click Optional X-Axis Labels >>.  Check Tests for Special Causes as shown:
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Click OK.  Resulting X-bar & R charts:
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This is currently a stable catapult process.  Subgroups 21 to 25 were added afterwards.  To add the additional data to this chart, click SigmaXL Chart Tools > Add Data to this Control Chart as shown.  In Excel 2007/2010 click:                                               















8. Note that the Add Data button does NOT recalculate the control limits.  Once control limits are established, they should only be recalculated when a deliberate process change or improvement is introduced.  (Control Limits can be recalculated using SigmaXL Chart Tools > Recalculate Control Limits, but a warning message Are you sure that you want to recalculate control limits? is given.)
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The Tests for Special Causes report gives us more detail on the recent instability:





The X-bar chart and Tests for Special Causes report clearly shows that this process is now out of control with an unstable mean. The process must be stopped, and the Out-of-Control Action Plan must be followed to determine and fix the root cause.  In this case, the assignable cause was a change of rubber band requiring a reset of the pull back angle.  The use of tests for special causes gave us an early warning of this at observation number 22.
 
Note that the Range chart is in-control even though the X-Bar chart is out-of-control.
10. The tests for special causes can have defaults set to apply any or all of Tests 1-8.  Test 2 can be set to 7, 8, or 9 points in a row on same side of CL.  Click SigmaXL > Control Charts > “Tests for Special Causes” Defaults to run selected tests for special causes.  (Note that these defaults will apply to Individuals and X-bar charts.  Test 1 to 4 settings will be applied to Attribute Charts.)
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To add a comment to a data point, select SigmaXL Chart Tools > Add Data Label.  Select Text Label. Enter a comment as shown.  Click on the data point to add the comment. Click Done.








12. Now we will look at Process Capability Indices for this process.  Click on Sheet 1 (or press F4 to activate last worksheet).  Click SigmaXL > Control Charts > X-Bar & R.  Check Use Entire Data Table.  Click Next.  (Alternatively select B2:F27, press F3.)
13. Select Shots 1-3, click Numeric Data Variables (Y) >>.  Select Historical Limits.  These are the limits calculated with the original 20 subgroups.

14. Click Advanced Options.  Enter LSL = 92, Target = 100, USL = 108.
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The resulting dialog box settings are shown:







Tip:  Another approach to using Historical Limits, would be to select Specify Subgroup Number for Calculation of Control Limits and specify Subgroup Numbers 1 to 20 for calculation of the control limits.  
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Click OK.  Click X-Bar & R – Proc Cap sheet for the Process Capability report:

























Note the difference between Pp and Cp; Ppk and Cpk.  This is due to the process instability.  If the process was stable, the actual performance indices Pp and Ppk would be closer to the Cp and Cpk values.




X-Bar & R Charts – Exclude Subgroups
After creating a control chart, you can specify subgroups (or rows) to exclude by using the Exclude Data tool.   

17. Click on Sheet 1 (or press F4 to activate last worksheet).  Click SigmaXL > Control Charts > X-Bar & R.  Check Use Entire Data Table.  Click Next.
18. Select Shots 1-3, click Numeric Data Variables (Y) >>.  Ensure that Calculate Limits is selected.  Click OK.
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The resulting X-bar & R charts are displayed:


















The control limits here were calculated including subgroups 21 to 25 which have a known assignable cause.

20. To calculate the control limits excluding subgroups 21 to 25, click SigmaXL Chart Tools > Exclude Subgroups.  Select Show Highlighted Points for Excluded Subgroups.  Enter 21,22,23,24,25 as shown:
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Click Exclude Subgroups. The control chart limits are recalculated and the excluded points are highlighted:


















Tip: You can also choose to show gaps for excluded subgroups or delete excluded subgroups from the charts.


Part C - P-Charts

P-Charts

1. Open New York Daily Cycle Time – Discrete.xls.  This is data from the Sigma Savings and Loans Company, New York location.  Each day, the cycle time (in days) for completed loans and leases was recorded.  N indicates the number of loans counted.  A Fail was recorded if the cycle time exceeded the critical customer requirement of 8 days.  Note that we are not recommending that continuous data be converted to discrete data in this manner, but rather using this data to illustrate the use of P charts for Discrete or Attribute data. 
2. Select SigmaXL > Control Charts > Attribute Charts> P.  Ensure that B3:E23 are selected, click Next.
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Select Fail, click Numeric Data Variable (Y) >>; select N, click Subgroup Column or Size >>.  If we had a fixed subgroup size, the numerical value of the subgroup size could be entered instead of Column N.













4. Click OK.  The resulting P-Chart is shown:















The moving limits are due to the varying sample sizes.  While this P-chart shows stability, a much bigger concern is the average 41% failure rate to deliver the loans/leases in 8 days or less!
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Part D – P’ Charts (Laney)
P' and U' (Laney) Control Charts are attribute control charts that should be used when the subgroup/sample size is very large (i.e. > 5,000) and assumptions are not met.  Typically you will see that the control limits do not “look right”, being very tight with many data points appearing to be out-of-control.  This problem is also referred to as “overdispersion”.  This occurs when the assumption of a Binomial distribution for defectives or Poisson distribution for defects is not valid.  Individuals charts are often recommended in these cases, but Laney’s P’ and U’ charts are a preferred alternative.

References:
· Laney, David B., P-Charts and U-Charts Work (But Only Sometimes), Quality Digest, http://www.qualitydigest.com/currentmag/departments/what_works.shtml
· Laney, David B., Improved Control Charts for Attribute Data, Quality Engineering 2002;14:531–7.
· M A Mohammed and D Laney, Overdispersion in health care performance data: Laney’s approach, Qual. Saf. Health Care 2006;15;383-384.
P’-Charts

1. Open Laney – Quality Digest – Defectives.xls.  This data is used with permission from David Laney.


2. We will begin with the creation of a regular P-Chart for this data.  Select SigmaXL > Control Charts > Attribute Charts > P.  Ensure that the entire data table is selected.  If not, check Use Entire Data Table.  Click Next.


3. [image: image447.png]In(x)



Select Defectives as the Numeric Data Variable (Y), N as the Subgroup Column (Size).  Click OK.  The resulting P-Chart is shown:













This chart suggests that the process is out of control.  The problem here is actually due to the large sample size with Binomial assumptions not being valid (also known as overdispersion).
4. Select Sheet Defectives (or press F4).  Click SigmaXL > Control Charts > Attribute Charts > P’ (Laney).  Click Next.
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Select Defectives, click Numeric Data Variable (Y) >>; select N, click Subgroup Column  or Size >>.  (If we had a fixed subgroup size, the numerical value of the subgroup size could be entered instead of Column N.)
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Click OK.  The resulting P’-Chart is shown:















7. Now we see that the process is actually “in-control”.   Laney’s Sigma (Z) is a measure of the overdispersion.  See referenced articles for further details.




Part E – Control Chart Selection Tool
The Control Chart Selection Tool makes it easy for you to select the correct statistical process control chart depending on data type and subgroup/sample type and size. 

Data Types and Definitions
Continuous/Variable:  Data that is measured on a continuous scale where a mid-point (or other subdivision) has meaning.  For example, when measuring cycle time, 2.5 days has meaning. Other examples include distance, weight, thickness, length and cost.  Customer Satisfaction on a 1 to 5 scale can be considered as continuous in that a satisfaction score of 3.5 has meaning.  Continuous data is always in numeric format.

Discrete/Attribute:  Data that is categorical in nature.  If we have defect types 1, 2, and 3, defect type 1.5 has no meaning.  Other examples of discrete data would be customer complaints and reasons for product return.  Discrete data can be text or integer numeric format.

Defective:  An entire unit that is nonconforming to customer requirements.  A unit may be defective because of one or more defects.  For example, an application form is good only if all critical entry fields are correct.  Any error in a critical field is a defect, resulting in a defective form.  A single form can have more than one defect.

Defect:  Any specific nonconformity to customer requirements.  There can be more than one defect per unit or area of opportunity, such as the entry errors described above.

Subgroup/Sample:  Data for a subgroup are usually collected within a short period of time to ensure homogeneous conditions within the subgroup (common cause variation), in order to detect differences between subgroups (special cause variation).

Subgroup/Sample Size:  The number of observations within your sample, not the number of samples.  Subgroup sizes of 3 to 5 are common for continuous measures in parts manufacturing, while individual measurements are common in chemical processes (temperature, pH) and transactional areas (financial).  Subgroup size for discrete data should be a minimum of 50.

Subgroup/Sample Size is constant:  The number of observations within your sample remains fixed over time.

Subgroup/Sample Size varies:  The number of observations within your sample varies over time. 

Subgroup/Sample Size is very large and assumptions not met:  This applies to discrete data when the subgroup sizes are approximately 5,000 or higher and the control limits do not “look right,” being very tight with many data points appearing to be out-of-control.  This problem is also referred to as “overdispersion”.  This occurs when the assumption of a Binomial distribution for defectives or Poisson distribution for defects is not valid.  (Note:  If the problem of overdispersion is apparent with your continuous data, use SigmaXL > Control Charts > Advanced Charts > I-MR-R or I-MR-S).

Control Chart Selection Tool – Individuals Chart
1. Open Customer Data.xls, click on Sheet 1.  Click SigmaXL > Control Charts > Control Chart Selection Tool.
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We would like to create a control chart of the Overall Satisfaction data.  Since this can be considered as continuous data, the data type is Continuous/Variable Data.  The subgroup/sample size is 1 (i.e. there is no subgrouping), so select Individuals (subgroup/sample size = 1).  At this point, we can choose Individuals or Individuals and Moving Range.  We will keep the simpler Individuals selection as shown.  (Note that the above data types and definitions can be viewed by clicking the Data Types and Definitions tab):












3. Click OK.  This starts up the Individuals Chart dialog (see Part A – Individuals Charts for continuation).

Control Chart Selection Tool – X-Bar & R Chart
1. Open the file Catapult Data – Xbar Control Charts.xls.  Each operator fires the ball 3 times.  The target distance is 100 inches.  Select B2:F22; here we will only use the first 20 subgroups to determine the control limits.

2. Click SigmaXL > Control Charts > Control Chart Selection Tool.
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Since catapult shot distance measurement is continuous, we keep the default selection Continuous/Variable Data.  The catapult shot data are in subgroups, so select Subgroups (subgroup/sample size > 1).  The subgroup/sample size is small (3), so we will use the X-Bar & Range Chart as shown:



















4. Click OK.  This starts up the X-Bar & Range dialog (see Part B – X-Bar & Range Charts for continuation).






Control Chart Selection Tool – P-Chart
1. Open New York Daily Cycle Time – Discrete.xls.  This is data from the Sigma Savings and Loans Company, New York location.  Each day, the cycle time (in days) for completed loans and leases was recorded.  N indicates the number of loans counted.  A Fail was recorded if the cycle time exceeded the critical customer requirement of 8 days.
2. Click SigmaXL > Control Charts > Control Chart Selection Tool.
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Since this data is discrete, select Discrete/Attribute Data.  We are looking at Defectives data since each loan is a pass or fail, so select Defectives (unit is good/bad, pass/fail).  The subgroup/sample size varies day to day so Subgroup/Sample Size varies is selected as shown.  The recommended chart is the P-Chart (proportion defective):






















4. Click OK.  This starts up the P-Chart dialog (see Part C – P-Charts for continuation).
Part F – Advanced Charts: I-MR-R/S
I-MR-R Charts

If the within-subgroup variability is much smaller than between subgroup, the classical X-bar & R (or S) chart will not work, producing numerous (false) alarms.  The correct chart to use, in this case, is the I-MR-R (or S) chart.  The subgroup averages are treated as individual values (I-MR) and the within subgroup ranges are plotted on the Range chart.

1. Open Multi-Vari Data.xls. Select Sheet Between.  We saw this data previously using Multi-Vari charts.  First, we will incorrectly use the X-bar & R chart, and then apply the correct I-MR-R chart.
2. Click SigmaXL > Control Charts > X-bar & R.  Check Use Entire Data Table.
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Click Next.  Select Stacked Column Format.  Select Measurement, click Numeric Data Variable (Y) >>; select unit, click Subgroup Column or Size >>.















4. Click OK.  Resulting X-bar & R chart:
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Almost all of the data points in the X-bar chart are out-of-control!  This is due to the small within-subgroup variability (the control limits are calculated from the within-subgroup variability).

6. Click Sheet Between.  Select SigmaXL > Control Charts > Advanced Charts > I-MR-R.
7. [image: image455.png]Process Capability Report (Nonnormal): Cycle Time (Minutes)

Box.Cox Transformation: Z =Ln( Y ) e it et PG
ust=1000
Sample Count] D
w | Sample Wean| 70317
ust | 1000
s | Target]
Y | L]
Lambda (Rounded) o
= | Mean (Transformed) 5520}
2 Sibey (Transformed Overall Long Term)| 106103070
- | Stbey (Transformed Within, Short Term)| 1 00437519
| USL (Transformed)| 5509
0 Target (Transformed)|
. LSL (Transformed)
o “Capabilty Indices using Transformed Overail StDev
8 ¢ 3 g g8 B § § 8 % 8 Po
S & 8 - g £ a2 E 2 Ppul 031
yele Time (Minutes) Pol
Ppi [E]
Box-Cox Transformation: 2 =Ln(Y) Potential Capabilty Indices sing Transformed Within Stbev
246 cpl
196 Cpu o5
col
Lo Cpk] [ER
g oss
2 Expected Overall Performance
8 oss
H ppm > USL] 17602611
£ oo pom <Lst|
2 o5 ppm Total] 176025 1
ros %>ust] 1760
b %<is]
s % Towl| __1760%
208
s 2 A 2 2 2 = ‘Actual [Empirical) Performance
- H 2 B = H H %>UsL]  10.00%]
Lolcyee Time (Winutes) %<is]
% Totall 10,005
‘Anderson-Dariing Normaity Tests.
AD Hormaity Transformed Data] 036955
AD Hormaity P-Value Transformed Data| 0 40¢1
AD Hormaity Original Data] 5357
AD Normality P-Value Original Datal ___0.0000)




Click Next.  Select Stacked Column Format.  Select Measurement, click Numeric Data Variable (Y) >>; select unit, click Subgroup Column or Size >>.
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 Click OK.  Resulting I-MR-R chart:

























This chart is much cleaner, showing a stable Individuals and Range chart.  The MR chart may be trending up, but we would want to collect more data before making this conclusion.  Typically, you want at least 20 (30 preferred) subgroups before calculating final control limits.






SigmaXL Appendix: Statistical Details for Nonnormal Distributions and Transformations
Statistical Details for Nonnormal Distributions and Transformations
Maximum Likelihood Estimation (MLE)

Maximum likelihood estimates of the parameters are calculated by maximizing the likelihood function with respect to the parameters. The likelihood function is simply the sum of the log of the probability density function (PDF) for each uncensored observation, and the log of the complement of the cumulative density function (CDF) for each right censored observation (in Reliability/Weibull Analysis).  Initial estimates are derived using a branch and bound algorithm. 

The maximum likelihood estimates are then calculated using the Newton-Raphson method.  This is an iterative process that uses both the first and second derivatives to move to a point at which no further improvement in the likelihood is possible. 

The standard errors of the parameter estimates are derived from the Hessian matrix. This matrix, which describes the curvature of a function, is the square matrix of second-order partial derivatives of the function.

For some data sets, the likelihood function for threshold models is unbounded, and the maximum likelihood methodology fails.  In this context, a threshold is estimated using a bias correction method.  This is an iterative methodology that evaluates the threshold based on the difference between the minimum value of the variate and the prediction for the minimum value, conditional on the current values of the parameters.

References for MLE and Distributions:

Greene, W.H.  Econometric Analysis 4th Ed Prentice Hall, New Jersey.
Johnson, N. L., and Kotz, S. (1990). "Use of moments in deriving distributions and some characterizations", Mathematical Scientist, Vol. 15, pp. 42-52. 
Johnson, N.L., Kotz, S. and Balakrishnan, N. (1994). Continuous Univariate Distributions-Volume 1, Second Ed., Wiley, New York. 
Johnson, N.L., Kotz, S. and Balakrishnan, N. (1995). Continuous Univariate Distributions-Volume 2, Second Ed., Wiley, New York. 
Nocedal, J. and Wright, S.J. (1999). Numerical Optimization, Springer-Verlag, New York.
Sleeper, A. (2006). Six Sigma Distribution Modeling, McGraw-Hill, New York.

Distributions
Beta Distribution
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where B is the Beta function:




Range 0  (  x  ( 1. 
Shape1 parameter ( > 0. 
Shape2 parameter ( > 0. 
Γ(β) is the Gamma function and is described below under Gamma distribution.

Beta Distribution with Lower/Upper Threshold
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where B is the Beta function. 
Range 0  (  x  ( 1. 
Shape1 parameter ( > 0. 
Shape2 parameter ( > 0. 
Lower threshold ( 1
Upper threshold ( 2
Notes: Estimation of the 4 parameter Beta distribution is undertaken in two parts. In the first part, initial parameter estimates are derived using the method of moments. The threshold parameters are then held using these values, and the shape parameters are then estimated using maximum likelihood. 

Reference for Beta Distribution with Lower/Upper Threshold – Parameter Estimation:

Wang, J.Z. (2005). "A note on Estimation in the Four Parameter Beta Distribution", Comm in Stats Simulation and computation, Vol. 34 pp. 495- 501. 
Box-Cox Distribution with Threshold
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Range < x - (  <(. 
Location parameter, µ, the mean. 
Scale parameter, ( > 0, the standard deviation. 
Shape parameter (. 
Threshold parameter (  <  min(x). 
Notes: The concentrated likelihood is used in the ML estimation. This implies that the location and scale parameters are not estimated freely, but are derived as the mean and standard deviation of the BoxCox transformed variate. The estimated parameters ( and ( are then used in the Box-Cox (Power) transformation. See Transformations below.

Exponential Distribution 
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CDF

Range 0( x <(. 
Scale parameter, ( > 0,  the mean. 
Exponential Distribution with Threshold
PDF

CDF

Range 0( x <(. 
Scale parameter, ( > 0,  the mean. 
Threshold parameter (  <  min(x). 
Gamma Distribution 
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where  Γ(β) is the Gamma function:


Range 0( x <(. 
Scale parameter ( > 0. 
Shape parameter ( > 0. 
Gamma Distribution with Threshold
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Range 0( x - (  <(. 
Scale parameter ( > 0. 
Shape parameter ( > 0. 
Threshold parameter (  <  min(x). 
Half Normal Distribution 
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Range 0( x <(. 

Scale parameter, ( > 0, the standard deviation

Reference for Application of Half Normal Distribution:

Chou, C., & H. Liu, (1998). "Properties of the half-normal distribution and its application to quality control", Journal of Industrial Technology Vol. 14(3)  pp. 4-7 
Largest Extreme Value Distribution 
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Range(( < x <(. 
Location parameter, µ, the mode. 
Scale parameter ( > 0. 
Logistic Distribution 
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Range(( < x <(. 
Location parameter, µ, the mean. 
Scale parameter ( > 0. 
Loglogistic Distribution 
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Range 0 < x <(. 

Location parameter, µ, the mean. 
Scale parameter ( > 0. 
Loglogistic Distribution with Threshold
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Range 0 < x <(. 

Location parameter, µ, the mean. 
Scale parameter ( > 0. 
Threshold parameter (  <  min(x). 
Lognormal Distribution 
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Range 0 < x <(. 

Scale parameter, µ, the mean of ln(x) . 
Shape parameter, ( > 0, the standard deviation of ln(x) . 
Lognormal Distribution with Threshold
PDF

CDF

Range 0 < x <(. 

Scale parameter, µ, the mean of ln(x) . 
Shape parameter, ( > 0, the standard deviation of ln(x) . 
Threshold parameter (  <  min(x). 
Reference for Lognormal Distribution with Threshold – Parameter Estimation:

Giesbrecht, F. and A.H. Kempthorne (1966). "Maximum Likelihood Estimation in the Three-parameter Lognormal Distribution", Journal of the Royal Statistical Society, B 38, pp. 257-264. 
Normal Distribution 
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Range(( < x <(. 
Location parameter, µ, the mean.
Scale parameter, ( > 0, the standard deviation.

Note: For consistency with other reports in SigmaXL such as Descriptive Statistics, the standard deviation is estimated as the sample standard deviation using n-1 (rather than n).
Smallest Extreme Value Distribution 
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Range(( < x <(. 
Location parameter, µ, the mode. 
Scale parameter ( > 0. 
Weibull Distribution 
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Range 0( x <(. 
Scale parameter, ( > 0, the characteristic life. 
Shape parameter ( > 0. 
Weibull Distribution with Threshold
PDF
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Range 0( x <(. 
Scale parameter, ( > 0, the characteristic life. 
Shape parameter ( > 0. 
Threshold parameter (  <  min(x). 
Reference for Weibull Distribution with Threshold – Parameter Estimation: 

Lockhart, R.A. and M.A. Stephens (1994)."Estimation and Tests of Fit for the Three-parameter Weibull Distribution", Journal of the Royal Statistical Society, Vol.56(3), pp. 491-500.
Transformations
Box-Cox (Power) Transformation



(. ≠ 0

(. = 0

Range < x <(. 
Shape parameter (. 
Note: The optimum shape parameter,(, is derived using a grid search in which the criteria function is the  standard deviation of the  standardized transformed variable.

Box-Cox (Power) Transformation with Threshold



(. ≠ 0

(. = 0


Range < x - ( <(. 
Shape parameter (.
Threshold parameter (  <  min(x). 
Note: The parameters ( and ( are estimated using MLE as described above in Box-Cox Distribution with Threshold.

Johnson Transformation
The Johnson Transformation selects one of the three families of distribution: SB (bounded), SL (lognormal), and SU (unbounded) and the associated parameters so as to transform the data to be normally distributed. The methodology follows Chou et al (1998) and uses the Anderson Darling p-value as the normality criteria. 
Johnson Transformation - SB 












z is N (0, 1) 
Range ε < x < ε + (. 
Location parameter ( > 0. 
Scale parameter ( > 0. 
Shape parameter (  unbounded. 
Shape parameter ε unbounded. 
Johnson Transformation - SL 


z is N (0, 1) 
Range x > ε
Location parameter ( > 0. 
Shape parameter (  unbounded. 
Shape parameter ε unbounded. 
Johnson Transformation - SU 








z is N (0, 1) 
Range(( < x <(. 
Location parameter ( > 0. 
Scale parameter ( > 0. 
Shape parameter (  unbounded. 
Shape parameter ε unbounded.
References for Johnson Transformation:
Chou,Y., A.M. Polansky, and R.L. Mason (1998). "Transforming Non-Normal Data to Normality in Statistical Process Control," Journal of Quality Technology, Vol. 30(2), pp. 133-141.

David, H.A. (1981). Order Statistics, John Wiley & Sons, New York 
Tadikamalla,P.,R. (1980). "Notes and Comments: On Simulating Non-Normal Distributions", Psychometrika,, Vol. 45(2), pp. 273-279. 
Automatic Best Fit
SigmaXL uses the Anderson Darling p-value as the criteria to determine best fit.  All distributions and transformations are considered and the model with the highest AD p-value is initially selected (denoted as adpvalmax).  A search is then carried out for models that are close, having an AD p-value greater than adpvalmax - 0.1 (with an added criteria that AD pvalue be > 0.2), but having fewer parameters than the initial best fit model. If a simpler model is identified, then this is selected as the best fit. 

Since AD p-values are not available for distributions with thresholds (other than Weibull), an estimate is obtained by transforming the data to normality and then using a modified Anderson Darling Normality test on the transformed data.  The transformed z-values are obtained by using the inverse cdf of the normal distribution on the cdf of the nonnormal distribution.  The Anderson Darling Normality test assumes a mean = 0 and standard deviation = 1. 

This approach, unique to SigmaXL, is an extension of the Chou methodology used in Johnson Transformations and allows a goodness of fit comparison across all distributions and transformations.

Another approach to comparing models is Akaike's information criterion (AIC) developed by Hirotsugu Akaike. AIC is the MLE log-likelihood with a penalty for the number of terms in the model (where the penalty factor also depends on the sample size, n). The AD p-value method used by SigmaXL has the advantage that it is not limited to models with maximum likelihood parameter estimation.

References for Automatic Best Fit:
Chou,Y., A.M. Polansky, and R.L. Mason (1998). "Transforming Non-Normal Data to Normality in Statistical Process Control," Journal of Quality Technology, Vol. 30(2), pp. 133-141.

D'Agostino, R.B. and Stephens, M.A. (1986). Goodness-of-Fit Techniques, Marcel Dekker.

http://en.wikipedia.org/wiki/Akaike_information_criterion
Process Capability Indices (Nonnormal)
Z-Score Method (Default)

The Z-Score method for computing process capability indices utilizes the same z-value transformation to normality described above in Automatic Best Fit.  The transformed z-values are obtained by using the inverse cdf of the normal distribution on the cdf of the nonnormal distribution.  Normal based capability indices are then applied to the transformed z-values.  This approach offers two key advantages: the relationship between the capability indices and calculated defects per million is consistent across the normal and all nonnormal distributions, and short term capability indices Cp and Cpk can be estimated using the standard deviation from control chart methods on the transformed z-values. The Z-Score method was initially developed by Davis Bothe and expanded on by Andrew Sleeper.  For further details, see Sleeper, Six Sigma Distribution Modeling.
Percentile (ISO) Method
The Percentile method to calculate process capability indices uses the following formulas:

Ppu = (USL – 50th percentile)/(99.865 percentile – 50th percentile)
Ppl = (50th percentile – LSL)/(50th percentile – 0.135 percentile)

Ppk = min(Ppu, Ppl)

Pp = (USL – LSL)/( 99.865 percentile – 0.135 percentile)

References for Process Capability Indices:
Bothe, D.R. (1997). Measuring Process Capability, McGraw-Hill, New York.

Sleeper, A. (2006). Six Sigma Distribution Modeling, McGraw-Hill, New York.

Control Charts (Nonnormal)
Individuals – Original Data

The Individuals – Original Data chart displays the untransformed data with control limits calculated as:

UCL = 99.865 percentile 

CL = 50th percentile

LCL = 0.135 percentile

The benefit of displaying this chart is that one can observe the original untransformed data.  Since the control limits are based on percentiles, this represents the overall, long term variation rather than the typical short term variation. The limits will likely be nonsymmetrical.

Individuals/Moving Range – Normalized Data

The Individuals/Moving Range – Normalized Data chart displays the transformed z-values with control limits calculated using the standard Shewhart formulas for Individuals and Moving Range charts. The benefit of using this chart is that tests for special causes can be applied and the control limits are based on short term variation.  The disadvantage is that one is observing transformed data on the chart rather than the original data.

SigmaXL’s default setting is to display the three charts: Individuals – Original Data, Individuals & Moving Range – Normalized Data (with tests for special causes unchecked).
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Notes:


1. Copy and Paste the above symbols into a blank worksheet as needed to create the value stream map. Resize if necessary.


2. Recommended resource for Value Stream Mapping: Quarterman Lee and Brad Snyder, "The Strategos Guide to Value Stream & Process Mapping", Enna Products Corp., 2006.











Test 2: Equal Variances�H0: σ12 = σ22�Ha: σ12 ≠ σ22





Test 4: Equal Medians�H0: Median1 = Median2�Ha: Median1 ≠ Median2





Test 3: Equal Means�H0: μ1 = μ2�Ha: μ1 ≠ μ2





Test 1: Anderson Darling�H0: Data are Normal�Ha: Data are Not Normal





Alternative setting to achieve a target distance of 100 inches





Approximate Maximum Taste Score


























Click Create Stacked Column Format to Analyze with “Attribute MSA (Binary)” >> if you wish to analyze the above data using SigmaXL’s menu Attribute MSA Analysis tool.





Click Create Stacked Column Format for “Analyze Gage R&R” >> if you wish to analyze the above data using SigmaXL’s menu Gage R&R Analysis tool.





Click the Pareto Chart button to create a Pareto Chart of Weighted Scores by Input/Process Variables:
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