Service Pack Requirements

 What services packs do I need to run SigmaXL?

Please read the information in the article below to ensure that the Service Pack requirements for Excel are met.

Microsoft issues service packs to distribute updates to correct issues with system reliability, program compatibility, security, and more.

Any service packs issued by Microsoft for your version of Office and Windows must be installed before contacting SigmaXL support.

To confirm that you have the required service packs installed:

Excel 2016:  There is currently no service pack for Excel 2016. 

Excel 2013:  The current service pack is SP1

Click the File button


Select Account


Select About Excel


Excel 2013 SP1 can be downloaded from the link below

Excel 2010: The current service pack is SP2.

Click the File button


Select Help and click Additional Version and Copyright Information


Look for SP2 MSO beside the listed version information


Excel 2010 SP2 can be downloaded from the link below:

Excel 2007: The current service pack is SP3.

Click the Office Button:


Click Excel Options:


Resources - SP3 will show after the Excel version information:


Excel 2007 Service Pack 3 can be downloaded here: